1. Official MINIX forum

Using the A2 Lite on a non-Minix android box

Discussion in 'NEO A3, A2 Lite Airmouse' started by premiump, Jan 14, 2016.

  1. premiump

    premiump Member

    I have had my U1 for almost a week, bundled with an A2 Lite mouse. I have been so impressed with the A2 Lite, that I have bought a second unit for my brother. Trouble is, he doesn't have a MINIX box (...yet haha).

    I have tested the remote on his mobie dazzle 4k box, and most buttons just work, as does the air mouse function. I'm pretty sure I can add the edited keymap.XML to the correct folder to correct the ffwd/red buttons and maybe even the back button (won't get another chance to test for a few days) ... But there are two buttons that don't do anything, namely the "app drawer" button and the "switch app" button.

    Can I assign these buttons to do something useful in Kodi?

    It would be pretty cool if I could get the power button to put the box into standby, but I'm not sure if this is possible.

    Cheers
  2. Frederick_99

    Frederick_99 Well-Known Member Trusted Helper

  3. Mark112887

    Mark112887 Member

    I am also trying to get my A2 remote to work with a non-Minix box. More specifically the app switcher , app drawer, home and menu buttons on the remote which currently do not function

    Any help in getting these buttons to function probably would be greatly appreciated.
  4. Higgs

    Higgs Yellow Dude Super Moderator

    Try adding the A2 Lite key layout file to your box - http://www.minixforum.com/threads/kl-file-of-neo-a2-lite.4734/
    More info here - https://source.android.com/devices/input/key-layout-files.html
    premiump likes this.
  5. premiump

    premiump Member

  6. premiump

    premiump Member

    OK, I have managed to spend a little time on the Mobie Dazzle 4k.

    1. I copied MY keymap.xml into the relevant file location for Kodi, and the back button and RWD button work as expected. Oddly, the FFWD button does not seem to work at all.

    2. I have downloaded the Vendor_400c_Product_107a.kl file and tried to copy it into \systems\usr\keylayout using ES File Explorer. No joy. It says the location is read-only. I thought ES File Explorer would allow me to copy the file. What am I doing wrong?

    Cheers
  7. Higgs

    Higgs Yellow Dude Super Moderator

    Your device probably needs to be rooted to get write access to this folder
  8. premiump

    premiump Member

    I was hoping that wouldn't be the case, I didn't want to mess with his box.
  9. Higgs

    Higgs Yellow Dude Super Moderator

    Can you post a copy of your keymap file and we can check why the FWD button isn't working?
  10. premiump

    premiump Member

    Sure Higgs, thx ...

    <keymap>
    <global>
    <keyboard>
    <backspace>Back</backspace>
    <key id='61467'>Back</key>
    </keyboard>
    </global>
    <FullscreenVideo>
    <keyboard>
    <backspace>Stop</backspace>
    <key id='61467'>Stop</key>
    <key id="61637">FastForward</key>
    <key id="61636">Rewind</key>
    </keyboard>
    </FullscreenVideo>
    </keymap>
  11. Higgs

    Higgs Yellow Dude Super Moderator

    Instead or using double quotes like <key id="61637"> try with <key id='61637'>
  12. Higgs

    Higgs Yellow Dude Super Moderator

    Check with the Keymap Editor if those codes are correct.
  13. Mark112887

    Mark112887 Member

    I put the two keyboard layout files in the appropriate location, changed them to the appropriate permissions, rebooted and the three buttons on the remote still do not work. Any ideas?
  14. premiump

    premiump Member

    I have installed the Keymap Editor, but it only gives me three options: Edit, Reset to default and Save. How do I see what values are already assigned?

    EDIT: Ok, played about, the codes are correct. :/
  15. Higgs

    Higgs Yellow Dude Super Moderator

  16. Mark112887

    Mark112887 Member

    That seems to have worked on all buttons except for the app switcher. How can I take the changes that this application makes and make them permanent so that I do not have to rely on the app
  17. boggiano

    boggiano New Member

    I have a rippleTV Box (as well as a NEO U1) nad I have bought a second A2 Lite.

    I have downloaded the Vendor_400c_Product_107a.kl file and copied it into \systems\usr\keylayout (after a remount in RW of the filesystem) and then reboot: nothing! It works as before!

    Any help, pls?

    The "only" big differences between the two boxes are the version of Android!
  18. Carcinograte

    Carcinograte New Member

    I was wondering if anyone could help me with some code. I have the MINIX A2 Lite and a Mygica 1800E. I realise that the power button is IR and incompatible with the Mygica. My request is for keymap code to reprogram the front facing "window" button to put my box in standby, if that's even possible. Any consideration would be greatly appreciated!