1. Registration issues have now been resolved. New accounts are able to be created

Very small hesitations while using SPMC/KODI?

Discussion in 'NEO X6' started by cyran0, Jan 17, 2017.

  1. cyran0

    cyran0 New Member

    Hi, since I have the X6 (been a while now), I never had quite the perfect playback with SPMC/KODI. At first, I taught either the movie I was playing was corrupted or the problem was a network issue. I made many tests and the issue seems to be somewhere else.

    My setup is very basic. The X6 is plugged into a HDTV using the HDMI port. My medias are on my home WIRED network. That's it.

    The behavior is like this: I play a movie (any movies or any music audio), everything is fine, no buffering, never, and out the blue there is a drop with the audio and video stuttering. Often, 1 or 2 small drops follow. This happen between 1 or 2 hours apart.

    Anybody else has those annoying playback drops?

    My box cannot be more optimized, I think. I flashed the latest firmware. Did the basic setup. I sideloaded SPMC/KODI and that's it. I even avoid the library mode of SPMC/KODI to keep it as light as possible.

    Lately, trying to free up the box, I sideloaded Disable Service (found instructions in the forum). Tried Disable Application as well. BTW, had to root the box with Kingo Root to be able to use those apps.

    Recap:
    • flashed the X6 with the latest firmware, FW008
    • went through the X6 settings and disabled as much options as possible
    • sideloaded SPMC/KODI 16.4.2 (it's old but newer versions require Android 5)
    • disabled some services
    • freezed some apps
    • set No background processes (Developer options - Background process limit)
    • turned off notification of all apps one by one (yes!)
    Those tricks improved (a bit I think) the performance but I still get playback drops ?! What more can I do ?

    Even a movie from the SDCard won't play flawlessly ?!

    I tried to pinpoint the guilty process with the display processes option from the Developer options. While something is playing, from time to time I can see CPU peaks but it is hard to know which process is responsible for the drops. Noting much is going on, only SPMC is running!

    I got the X6 to replace a Ouya box which is less powerful (no HEVC support) but I never had any playback problem! Something is wrong with the X6 firmware, surely. Or the hardware? Going back to an older firmware is not an option, right?

    Anyone can share their experience with getting a smooth KODI playback?

    Anyone had any luck with LibreELEC? Tried some ROMs from over there for the Amlogic S805 (the X6 SoC) but they freezed the box. Tests using boot from SDCard.

    Would be nice if the Minix ppl could supply us with a Linux ROM (I like Debian). They are the only ones who can legally supply the binary drivers. Plz.

    Thanks in advance for sharing your experiences ... Cheers

    references:
    sorry ppl, the forum won't allow me to include weblinks
  2. mark2

    mark2 Active Member

    Have you tried XBMC for Minix
  3. cyran0

    cyran0 New Member

    @mark2
    I observed the same hesitations with the very old XBMC that shipped with my X6.

    Now.

    To access my media files on the network, I discovered that I get more performance with FTP connections instead of SAMBA. That's positive.
    To unload even more the X6, I set up an external MySql server for KODI. That won't do much as I said earlier, I don't use the library mode of KODI.

    ATTENTION!
    I found a clue about the manifestation of the problem: Every time a playback glitch occurs in KODI the following process shows up: irq/110-sdhc
    I manage to remotely (telnet) monitor that process with a shell script. Whatever trigger that process freezes the X6! Something to do with internal memory access?!

    Even Android Media Player has the problem so it is not a KODI issue! Tested with a remote file using ES File Explorer, the one shipped with the X6.

    Looking back, I been having this problem from the start so it's been a while, many firmwares back!

    That flaw could be looked into in time for the next firmware you (Minix) promised.

    Hope my efforts will pay off ... cheers
  4. dryster

    dryster Active Member

    Hi cyran0 I am only an X6 owner for about a week, so long term I have no experience with the box running through big files, however, if you wish I can run a file or two through it next week and see. One thing I immediately experienced that I have never heard on my other (none Minix) boxes, and this is with FW008, were occasional audio pops through the HDMI.

    I had researched a while before purchasing an X6 to "put my toe in the water" with Minix at the cheapest level, and that audio pop (when no file was streaming) was quite a surprise to me, and it was not just one, seemed almost on a cycle of sorts.

    It is perhaps something different than this irq thing you are experiencing, but if you want me to run a file off an external hard drive, thumb drive or SD card to see if my X6 does something similar, then I will, as I say, my X6 is FW008 and I am running Kodi 16.1
  5. cyran0

    cyran0 New Member

    @dryster
    Wow! Now that you mention it. I had those audio pops too with the same setup but with an older LCD TV. And they were brutal. After the TV change, the pops now come out as silences. "Lucky me". It is clear that your X6 have the flaw I pointed out. Thx for offering to test with a media file but I know for a fact that it does not matter how intense the media file is or what media player is used. Anything playing, heavy or light, can suffer because of that X6 flaw.

    Btw, since I don't use the extra features of SPMC, I went back to KODI 16.1 . I did more tests. I pushed even more the settings with the following. Google keywords to find the blog with explanations (I cannot post url here, yet): imoseyon dirty_background_ratio
    No change. Seems very much overkill anyway since KODI state that only 41% of RAM is used.

    There is nothing more I can do to workaround that flaw. I laid out the clues. I wish the Minix staff would confirm the problem and work on a fix for the next promised firmware.

    Again, I hope my efforts will pay off. Cheers.

    PS
    Please. Anyone experiencing those playback glitches, add your voice here!
    Last edited: Mar 16, 2017
  6. sammo

    sammo New Member

    I also get those moments of silence. It is very annoying.

    Was hoping that running LibreElec for Amlogic s805 on the X6 was an option but it appears you have already tried and it didn't work.

    Ken, are you still around? Please let us know what the plan is. It would be good if the X6 could be updated but if you have no plans then just let us know.
  7. dryster

    dryster Active Member

    If you mean the NEO X6 being updated to Lollipop, no, it's not going to happen.
  8. cyran0

    cyran0 New Member

    Did another test.

    For exactly the same setup, I replaced the X6 with a similar Android box from another brand, reused the same cables. Been testing with KODI 16.1 for a few days and no hesitations what so ever! Perfect playback!

    So, it is not the LAN (100mbps ethernet), not the HDMI cable, not my LCD TV, etc. The problem IS the X6.

    Considering we all paid a premium price for the X6. Plz Minix, fix that problem in the next promised firmware! Then, the X6 will be perfect for my needs.

    Cheers
    Last edited: Apr 6, 2017
  9. drgn

    drgn New Member

    Using X6 for more than a year. Runing XBMC for minix ver 15.3, do not encounter your problem.

    By the way, X6's LAN is 100Mbps.
  10. cyran0

    cyran0 New Member

    @drgn

    10mbps, ah, I met 100Mbps. X6 Firmware version plz? It is the only thing I did not test, going back to an older firmware.

    I wonder how many hardware version there are of the X6. If the problem is the X6 hardware (I doubt it), it could mean only some of us have the problem.

    I got the X6 almost 2 years ago, may 2015.

    I'm very sensible at the playback experience for some reasons. In general terms, I don't know how ppl can put up with crackling audio, bad framerate (like bad telecine), wrong ratios and the worst, bad projections at the movie theater! If there is something wrong with any playback situations, I will see/hear it.

    Like I said, not knowing what was going on with the X6, I blamed the network, suspected corrupted files, the TV, the receiver, the cables, etc. I did my homework and it all point out to the X6. If it is a firmware (software) issue, we could imagine that all Minix boxes have the same flaw but since the X6 is not as fast as the new model, the flaw shows up, from time to time.

    I exposed some observations. I would put my money on a bad driver, memory related.

    Cheers