1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Video 4k / 2k does not work properly

Discussion in 'X8 - X8H Official Firmware 002' started by zcanele, Dec 16, 2014.

  1. zcanele

    zcanele New Member

    Hello
    I open this thread again because 4K does not work properly. The picture and sound disappear a few seconds every two to three minutes. In 1920x1080 everything works. I thought I had solved the problem after changing the HDMI cable with a cable certified 4K, but there was something else. I do not know if it comes from the TV or if it is the Minix 8. The TV is a sSamsung 48UH7500. I have no other sources for testing 4K.
    Do you also have problems, an update is it planned.
    Thank you for an answer.
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We tested with the model you stated and it is ok @ 4K.
  3. zcanele

    zcanele New Member

    Hello.
    Thank you for the answer.
    You tested for how long? The display goes black and the sound does not pass for a few seconds and then it comes back. It does every 2 or 3 minutes.
    This morning a Samsung technician is connected to my TV and changed a setting of the HDMI input but it is always the same. It amended the UHD Color setting. He made what is described here: http://www.samsung.com/sa_en/support/skp/faq/1061738
    Tonight it still does not work.
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We are looking into this issue.
    We managed to duplicate the same issue on SAMSUNG models, however when we switched the same box to LG 4K tv with the same hdmi cable and power, it is perfectly ok. Something wrong with the SAMSUNG... the FAQ is weird somehow...
    Last edited: Dec 19, 2014
  5. Kyberg

    Kyberg New Member

    I'm having exactly the same 4K problem: The picture and sound disappear a few seconds every two to three minutes. In 1920x1080 everything works.

    My TV is the Samsung UE55HU6900, probably a 4K/UHD TV often sold because of a good price / performance ratio. Also tried a lot of certified 4K cables.

    Dear Minix guys, please solve the issue. I bought the Samsung 4K/UHD TV only because of claimed new Minix Neo X-8H 4K features and now spent some good money on a combination which does not work on 4K.

  6. zcanele

    zcanele New Member

    It seems that there is a problem with 4K Minix between 8 and a Samsung TV UE48HU7500L. Obviously Samsung says it comes from Minix!
    Can we have detailed standards used in 4K by Minix? Notament 4K 30Hz.
    That also means 4K2K-30Hz
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I am not trying to excuse ourselves but why nobody question it's a Samsung's issue while it works perfectly fine on LG? Because Samsung is a larger brand means they don't make mistake and the TVs are 100% bug-free? No way...
    They made some strange FAQs on their website which look like bxxxxxxx to us?
    Come on guys, we will try making it good but first of all please understand it's a Samsung issue, instead of ours! We're trying to help so please don't put the blame on us!
    We used the debug mode and could see the TV fails to authenticate the signal properly when the box sends the requests! Anyone knowing how to debug could verify my words! LG doesn't have this problem!
    We understand the frustration, but please be fair to us!


    Larger words look better? Do you think it's funny? @Kyberg
  8. WeK05

    WeK05 Audio Visual Master Specialist

    I am with Ken on this issue. Samsung 4K TVs (Series 6, 7, 8) have a chroma subsampling problem with 4K 60Hz 4:4:4 signal. Problems have also been reported with 24 and 30Hz 4K signal. All Samsung series 6 and some series 7, 8 TVs use Novatek NT14U chipset which seems to have the signal compatibility problem. The word is that it may not even be fully fixed with firmware updates (Sorry folks :(). Some of the other series 7, 8 and all series 9 TVs have the "good" chipsets - Samsung Golf-P (T-GFP8, T-GFP9). With the newer firmwares, if you use HDMI1 and label it as PC input, you should be able to solve this problem to a certain extent.

    All 2014 LG 4k TVs work fine on HDMI 3.
  9. Kyberg

    Kyberg New Member

    Hi Ken, sorry about the large font, it comes from copying the Samsung TV product type number from their website using a Android tablet. Was not used intentionally.

    Really like your products, chapeaux! Started with a Neo X5 long time ago ...

    Like me there will be many many other Minux customers having the Samsung 4K problem, because Samsung is the brand no. 1 with highest sellings.

    Will try HDMI1 port with the "PC" input setting and report back if that helps.
    Last edited: Dec 21, 2014
  10. Kyberg

    Kyberg New Member

    Hi Ken, tried HDMI1 with "PC" naming and Gaming Mode ON and OFF on the Samsung TV. Sorry to say it didn't work.

    Got the impression that the time of a readable screen on 4K was even shorter than before, approx. 2 seconds 4K screen OK, approx. 15 seconds black screen. It was difficult to locate the setting to switch back to 1920x1080-60Hz.
  11. Kamen

    Kamen New Member

    Hello, with Samsung UE-55HU7500 I have exactly the same problem. Every couple of minutes, even more often, the picture and the sound disappear for a few seconds. The situation is the same with each 4k setting. Evarything worked fine before the update.

    Please help!

    Kamen
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    @Kyberg @Kamen @zcanele

    We've solution for the Samsung TVs problem, we found the cause of the issue.
    Please upgrade to FW002A for now, wait for the FOTA.
    Or roll it back to whatever older version which works for you.

    Don't worry. It's 100% solvable. :)
  13. Kyberg

    Kyberg New Member

    Super, thanks Ken! Will move from FW002 to FW002A and wait for the FOTA.

    Hope is on the horizon that the recent purchase of a Samsung 4K TV will lead to a functional 4K combo with the 4K NEO X8-H. Champagne is waiting in the fridge to be opened. (y)
  14. Kyberg

    Kyberg New Member

    Hi Ken,
    Just did the brand new FOTA update from FW002A, version date is now: 2014-12-24. But the 4K mode unfortunately does not work yet on the 4K Samsung TV. Probably the 4K - Samsung fix will come with the next FOTA update?

    Also the FOTA update took about 90 minutes, pressing "RETRY" - Button about 50 times (connected from Germany).
    Last edited: Dec 27, 2014
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Yes. the fix is coming.
  16. dhcmega

    dhcmega New Member

    Hi all, what is the status of this? Thanks.
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    firmware 003 addressed it.
    why digging this thread up?
  18. dhcmega

    dhcmega New Member

    I have the update (I think so) and still cannot set 4k @ 60Hz on my Samsung UN50HU7000 (minix is X8-H)
    fimware info reads:
    Model number: NEO-X8-H
    Android version: 4.4.2
    Build number: KOT49H.20150207 release-keys
    Kernel: 3.10.33

    I have done this too:
    1. Use the first HDMI port - "HDMI 1" is the name of the top most "first" port. Don't confuse this with version 1 or 2 of the HDMI technology.
    2. Update the latest firmware. If your TV is connected to the internet, the option to update the firmware will eventually light up, though it will appear grayed out initially. Give it a few minutes (like 30). I'm on version 1052 after the update.
    3. Enable UHC Color from the TV menu under "Picture Options" on that first HDMI port - remove any cables plugged in before enabling.
    4. Rename the 1st HDMI Port to "PC" from the source menu by tapping and holding the remote control direction pad button on the HDMI1 source. When you let go, a sub menu will appear to rename the source. Select PC.


    I also downloaded the the bars videos, at 24 and 23.976 and both look the same, at all resolutions with a flickering ghost at both sides as they move forward.

    thanks!
  19. JimBobVFR

    JimBobVFR Active Member

    I might be mistaken but I'm sure I read recommendations to I use the MHL enabled port on Samsung 4K models, think its HDMI4 you want to use.
  20. dhcmega

    dhcmega New Member

    Hi JimBobVFR, tried HDMI4 with the same result. Previously activated the UHD color with no cable plugged, and rebooted TV and Minix. I only get 4k @24,25,30 and smtpe, no 50 or 60. Thanks!