1. Welcome to the official forum for MINIX devices!

Video Playback - Black flashes, then loss of source

Discussion in 'NEO U9-H' started by darrenkdean, Aug 20, 2017.

  1. darrenkdean

    darrenkdean New Member

    Running the latest firmware, I'm running into an issue where while watching A 1080p h264 ac3 5.1mkv movie, the screen randomly goes black & then comes back up. This happens several times back to back & then the LG 4K tv says there are no active inputs. Audio keeps playing thru the digital audio cable & sound bar while the picture is out. Turning the tv off & back on, brings the picture back.

    This is a new development since the last firmware update. All screen saver, energy saver, & HDMI cec settings have been turned off on both the tv & the neo u9-h. Video refresh is off.

    I've replaced the HDMI cord but that was not it either. At a loss on this one, any thoughts?

    Sent from my KFGIWI using Tapatalk
    PhillyGTA likes this.
  2. MrBig

    MrBig Active Member

    What are your video settings in MINIX/Android setup?
    If this is happening in KODI, what are you video and player settings?
  3. darrenkdean

    darrenkdean New Member

    Android:
    Display: 4k2k-60hz
    Scaling: 100%
    Daydream: Clock, Daydream after 1 HR, Sleep never
    Force RGB: Off
    HDR: On
    HDMI CEC: Off
    Playback: HDMI Self-Adaption Level

    Kodi 17.3:
    Resolution: 1920x1080
    Refresh: 60
    Delay: Off
    # of Buffers: 3
    Adjust display refresh: Off
    Enable HQ Scaler: 20%
    Allow hardware acceleration: MediaCodec enabled


    Sent from my KFGIWI using Tapatalk
  4. MrBig

    MrBig Active Member

    Try this:
    Turn daydream off
    Set HDR to Auto.
    Test the file, if still acting the same way:
    Try another HDMI port on the TV.
    Uncheck allow hardware acceleration
  5. wrxtasy

    wrxtasy Active Member

    Please check this Android setting in FW006 and try and set it to YCbCr420-10bit:
    http://www.minixforum.com/threads/neo-u9-h-fw006-20170810.17461/#post-139833

    If you are only watching 1080p content, then try this:

    Android Settings > Display > Screen Resolution > 1080p60hz

    Otherwise sounds like a HDMI problem. Possibly a Hotplug issue due to faulty HDMI connection or poor HDMI cable.

    You may even need to buy a 'Premium Certified" HDMI cable if you want to run the Android at a 4k2k Screen Resolution all the time with reliability.
    Those cables have actually been tested for reliable 18Gbps 4K HDR data transfer.
    Last edited: Aug 22, 2017
  6. darrenkdean

    darrenkdean New Member

    Thank you for the feedback. I have ordered certified 2.0 HDMI cables that are confirmed to support 4K, HDR, etc. I will test them on Thursday, work thru a process of elimination, & report back.

    Sent from my KFGIWI using Tapatalk
  7. darrenkdean

    darrenkdean New Member

    Update. Updated one of the NEO U9-H boxes to Kodi 17.4. Rebooted the box into Android Recovery Mode & cleared the cache.

    After taking these two actions, wireless buffering issues we were having with Live TV in Kodi appear to be resolved & I have had no more screen flickering playing TV Shows & Movies. I made no other configuration or HDMI cable changes, outside of the two steps mentioned above. Tomororw, I will cycle the remaining 7 boxes thru the same process, test, & report back.
  8. wrxtasy

    wrxtasy Active Member

    Be aware Android Kodi Krypton 17.4 still has Live TV deinterlacing issues when using Mediacodec only decoding - especially if using TvHeadend.

    Amcodec Hardware decoding and Hardware deinterlacing, found in Android Kodi Jarvis were the High Point for reliability and full motion deinterlaced picture quality. Its been downhill in Android Kodi since for Live TV use on AML platforms. And this is the exact reason why I use LibreELEC Kodi Krypton on a AML S905 Chipset - LE still uses Amcodec decoding as well.

    Amcodec Hardware decoding is still found in SPMC 16.7.1 (Kodi Jarvis).

    Click Here to download SPMC 16.7.1
  9. darrenkdean

    darrenkdean New Member

    Interesting, I was not aware. Thank you for the info. I'm running a couple of HD Homerun Primes with a ServerWMC backend & a Linux server with Emby for serving up content. I've not run into any deinterlacing issues that I'm aware of, yet... We have used S802 boxes for years with OpenELEC. We experimented with the various flavors (amlinux, ubuntu, openelec, etc.) Wifi performance wasn't great, but they've served us well. The NEO U9-H specs offer a new level of performance & some enhancements (HDR) that we were interested in. Perhaps in the future, a stable LibreELEC build will emerge, but until then, Android flavor it is.

    Overall, I'm very pleased with the picture quality & performance of the NEO U9-H running on an Android platform.
  10. MrBig

    MrBig Active Member

    I'm with you on this. I have not experienced any issues that could not be resolved. My box is running flawlessly with the latest KODI 17.4 and all addon updates.
    The only recent major problem was my U9 was running real slow. I knew it had to be an app, storage or something. So I checked and found I had less than 500k of free memory. It turns out I was accidentally saving my backups to the unit's memory, because I didn't change the backup location to my SD card. I had 4 full backups stored.
    I guess my point is I create the only problems I have with my U9.
  11. darrenkdean

    darrenkdean New Member

    I'm going to roll one of the NEO U9-H boxes back to Jarvis as suggested to run a few tests. Question: the link you provided above, is it to a generic Kodi Jarvis apk or the XBMC Minix Edition. Is there a difference between the two?

    Appreciate the guidance on this!