1. Registration issues have now been resolved. New accounts are able to be created

Video stream constantly has tiny pauses and starts/stops

Discussion in 'NEO Z83-4' started by ColoCoug, May 8, 2017.

  1. ColoCoug

    ColoCoug New Member

    I have a new Z83-4 and have installed the 1.66 BIOS. I use it in a kitchen as a TV access point for DirecTV (general use) and for Xfinity (live network channels from Denver.) The video is accessed via web browser, Chrome or Firefox.

    I have trimmed down the start menu to minimize load on the processor, and only open one browser to login to the video sources. Chrome and Firefox show the same problem.

    When watching any video, the stream constantly has tiny pauses and re-starts. A crawl across the screen on ESPN might hesitate 5+ times while one set of characters is moving across the screen. Full-screen motion video constantly starts and stops momentarily or for a few seconds, and every now and then stops to buffer for 30+ seconds.

    This does not happen on tablets or laptops used to view the same streams in the same room.

    The ISP is Comcast; the wireless source is an ASUS RT-N66U router with freshly updated firmware. The wireless system uses security so no outside users are connected to use bandwidth.

    I'm looking for ideas on how to get this streaming to work smoothly. The problem seems limited to the Minix, not to the system feeling it.
  2. FamilyGuy

    FamilyGuy New Member

    Mine does the exact same thing! Everything is updated. Other PC's on the same network work just fine. Can't seem to fix it.
  3. ColoCoug

    ColoCoug New Member

    Hopefully someone will come along with ideas. Since I started this thread, I have noticed more outright locking up and buffering than before, but I have also noticed that a laptop in the same area occasionally buffers as well. However, the ratio is at least 10:1 with the Minix box freezing the most.

    It's also odd that in Firefox, my feed from DirecTV freezes a lot more than my feed from Xfinity. Perhaps it's something different in the algorithm used to process the video.

    I'm also going to check my wireless router. Even though I've updated the firmware, I'm not convinced it's consistent. Doing multiple speed tests last night, I got 52-64 MBPS download, 11 MBPS upload. But is it hanging up? I didn't see that in multiple tests.
  4. FamilyGuy

    FamilyGuy New Member

    OK. So I decided this morning to sit down and try to fix this after I read your post. I used the Windows 10 Media Creation tool to make a bootable USB Windows 10 Installation drive. I then booted to that drive. Removed all of the factory partitions and let Windows create whatever it needed and install a fresh copy of Windows 10 with the creators update. Then I installed the latest Intel Drivers for video using the intel website. There were a few remaining devices in device manager that were not installed. So I copied the drivers from this forum and pointed each of those devices through device manager to look to that folder for new drivers.

    Now I had a fresh copy of Windows 10 installed on my Minix. I used Edge and went to ESPN and crossed my fingers. It worked perfect!!

    I hope that helps.
  5. ColoCoug

    ColoCoug New Member

    Sounds like that's working well for you. Must be something different about the before & after system.

    If you don't mind, it would be great if you could post again after a couple of days using it and see if the performance holds up as well as it is at present.

    I'll have to do some research into the process you describe. The Win10 Media Creation piece looks easy. From there on I'd be in unfamiliar territory, although I have changed the partition settings in a couple of computers. I don't know how to remove the factory partitions, although a quick search indicates that the ability to do that is contained in a functioning version of Win10.

    It looks like the Intel Driver Update Utility at http://www.intel.com/content/www/us/en/support/detect.html might be a way to restore the needed drivers.
  6. CptDobey

    CptDobey Member

    When you will be booting from the usb drive, you will have the ability to wipe all the partitions. The install program will create automaticaly all the needed partitions. Of course you will also lose everything which was on the Minix prior to the operation ;)
  7. FamilyGuy

    FamilyGuy New Member

    It has been a few days and I can confirm it is still working great. Something about the factory install wasn't working well with the streaming video. Could be a driver, could be Flash...who knows. I work in the IT world and sometimes it's easier to just start over than spend hours figuring out the problem.

    So a clean install did the trick for me.
  8. ColoCoug

    ColoCoug New Member

    That sounds encouraging. I found that I was also having a problem with my wireless router, so after messing with it, I have replaced it with a new ASUS AC1900. The tiny hesitations still exist, although stops for buffering have disappeared.

    I may get brave this weekend and give the re-install a shot. I have already invested enough hours in it.
  9. klapa

    klapa New Member

    I only have a 20 Mbit downstream connection that is throttled down to ~8-10 Mbit by my VPN and still have not experienced any buffering/hesitation issues attributable to this PC. I am streaming primarily 1080P as I don't have a 4K capable display.

    This was in fact why I went to this PC - my smart home theater app would continually hesitate as it could not utilize the 20 Mbit downstream rate.
  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If it's in a kitchen, please make sure the cooling is adequate for this fanless computer.

    If the temperature goes too high, it might throttle for safety reason.

    Also, you should increase the buffer size if the network speed is not so good.
  11. ColoCoug

    ColoCoug New Member

    Dang it. I've tried to run the Windows 10 tool twice and I get the message "We couldn't update the system reserved partition."

    I'm trying to resize the partition because evidently I need another 15 MB of room. So far the tools I've found are not intuitive and I'm still fighting it.
    Last edited: May 18, 2017
  12. ColoCoug

    ColoCoug New Member

    Well, so much for round one. I downloaded MiniTool Partition Wizard Free, and after a mere three hours of knocking my head against the wall I managed to expand the system reserved partition.

    Hint: what I finally figured out was to create a new partition using a couple of gigs from the large partition that held all the programs; I then deleted that partition leaving a couple of gigs of unallocated space on the main drive,not free space within a partition. I was then able to expand the system reserved partition, and the Win10 re-install would run.

    I may have made a mistake because I didn't choose to delete all personal info. When I got it done (about a 30-40 minute process) I have the same constant minor hesitation in the video stream that I had before.

    As predicted, I lost the drivers for various things including the wireless, so I'll string a long network cable from my router to the Minix Friday night and establish a network connection so I can download drivers and updates.
    Last edited: May 19, 2017
  13. ColoCoug

    ColoCoug New Member

    More progress. I couldn't get the wi-fi to work, even after trying adding some Broadcom drivers. I had already run the Intel driver download that I linked earlier in this thread.

    Then I found the thread here: A simple hack to enable all available Wi-Fi channels.

    I figured that a file that would enable ALL wi-fi channels would load the drivers needed. I was right, now I have wi-fi back.

    I've watched a bit of TV on it and I'd say the number of small hesitations is reduced but not eliminated. I'll see how it works out, but so far the playback does seem to be improved.
    Last edited: May 22, 2017
  14. Villa

    Villa Well-Known Member Super Moderator

  15. ColoCoug

    ColoCoug New Member

    After fiddling for weeks, I still haven't solved the frequent small pauses. I've also tried adding a Zyxel internet-over-AC-power adapter, and it seems to work as well or better than the wireless. I'm rather disappointed in this box. I ask it to do ONE thing - stream video from DirecTV or Xfinity online - and it continually has small hesitations.

    I'ev also replaced my wireless router with a new ASUS that works on both 2.4 and 5 GHZ; the Minix is connected to the 5 GHZ feed.

    When I take a four-year-old Lenovo laptop and using 2.4 GHZ and run it next to the Minix watching the same program, I get none of these small hesitations/pauses. It's not the bandwidth and it's not the wireless signal. I also shouldn't have to invest 6-10 hours in reloading the OS and chasing hacks to get this box to function.

    Ideas on how to improve the streaming performance are still welcomed.
    Last edited: Jul 8, 2017
  16. ColoCoug

    ColoCoug New Member

    Well, I have a final verdict after 15+ hours of fiddling: this processor doesn't have the horsepower to provide smooth video streaming. I don't have more time to mess with it.

    I used a different, new series Zyxel powerline adapter to provide wired ethernet service to the computer, and Speedtests repeatedly show more than 100 MPBS upload service and more than 10 MBPS download with the new Zyxel. I still have regular pauses and hangs in the video stream. Audio normally continues, although when a 10+ second pause occurs, audio also stops.

    If it can't stream smoothly with that kind of connection, friends, then it just can't stream. I can live with it but I don't find it satisfactory and I won't recommend this box to others. I'd have been better off to buy an i5-based compute stick and use it.