1. Official MINIX forum

VPN Issue since recent update

Discussion in 'NEO X8-H Plus Official Firmware Releases' started by donnydeadlight, Apr 2, 2016.

  1. donnydeadlight

    donnydeadlight New Member

    Hi All

    I'm a newbie to the forum so thought I should stick my head round the door and say hi! I've had a NEO X8-H Plus for a few months now. Have had no issues with it and love it! Since the most recent update though the VPN icon in the top left corner of the home screen no longer indicates if I am connected (permanently greyed out) even when my VPN is connected (have verified that I am connected using geo- location). Just a bit concerned that I would not notice at a glance if my connection dropped, without a physical check of VPN status. Anybody else experience this or have any suggestions around a fix? Ta

    Update 5/4/2016 - Have noticed that the VPN status icon illuminates briefly s the connection is made, and then returns to 'greyed out'. Any one have any ideas around why this is, was working fine on previous firmware? Would really appreciate some support with this. Thanks.
    Last edited: Apr 5, 2016
  2. Higgs

    Higgs Yellow Dude Super Moderator

    Welcome to the forum. Please take a minute to look over the forum rules. In particular the rules about posting in the correct place and also about not posting the same post in multiple threads.

    Thanks.

    Sent from my MotoG3 using Tapatalk
  3. donnydeadlight

    donnydeadlight New Member

    Apologies, pretty new to the whole forum thing. Did originally post this in what I thought was the correct place. Have to say I was very disappointed not to have had a single reply in the best part of a couple of months, given how good I had heard the support in this forum is. Wondered if it had just been missed entirely and so thought putting it somewhere more prominent might generate a response. No offense intended, just desperate at this point to get some help with this issue.
  4. Smartie36

    Smartie36 Active Member

    I have a different minix box but that vpn icon has never illuminated for me when I'm connected to my vpn (private Internet access). I believe that vpn icon illuminates when using androids built in vpn feature which explains why I never see it light up, doesn't bother me though as a quick pull down of the notification bar will show the status of the Pia vpn app.

    Sent from my GT-I9505 using Tapatalk
  5. donnydeadlight

    donnydeadlight New Member

    Hi

    Many thanks for your reply, appreciated. I am using CyberGhost which has a dedicated app and can also be used with OpenVPN protocols. Have tried it both ways, but same issue, though as I say did work previously. The status icon does illuminate, but only for a split second. Like you say, doesn't seem to affect the connection though. Not sure what has changed since update that may be causing it.
  6. @Jonweb

    @Jonweb New Member

    Hello,
    I have also a private internet access VPN and I noticed that this problem " icon illumination" appeared with the last update of few months ago, before this date the minix has alredy worked.
    Strange phenomena

    Jonweb
  7. donnydeadlight

    donnydeadlight New Member

    Think I may have figured this out... It would seem since the last update, that when using a third party app to make the VPN connection, the firmware is no longer able to distinguish 'VPN' traffic, from 'regular/unsecured' traffic and so no icon, though this was not previously the case. I have found though that when the native android app is used, the firmware can make the distinction, and so the VPN icon is activated for the duration of the connection.