1. Welcome to the official forum for MINIX devices!

Where can I find the original BIOS firmware?

Discussion in 'NEO Z64 Windows 10/8.1' started by imi, Nov 3, 2017.

  1. imi

    imi New Member

    Hi All

    Hoping someone can help.

    Upgraded the BIOS of my Z64W to the latest 1.83 that I found here and have been experiencing weird ethernet wired disconnect issues with Plex (as in triggered when using plex but the entire device drops off the network for a good 30+ mins OR a reboot)

    I have eradicated all other changes that i have made in the past week, rebuild win8 from scratch, updated drivers etc to no avail - the last thing that I would like to try is to revert back to the older / original version of BIOS - where can I find that?

    Lesson learnt - once you have something working - don't mess about - all started by installing the latest version of W10...should have left it alone as it was working flawlessly for over a year.

    Regards
  2. Villa

    Villa Administrator Administrator

    I'm no expert but I wouldn't advise changing the BIOS as BIOS 1.83 included this...
    1.) This BIOS disabled the ESRT service using by Microsoft update service to avoid wrong BIOS update being pushed to our devices.
  3. imi

    imi New Member

    Fair point - I’d still like to try out the previous bios to isolate the issue.
  4. imi

    imi New Member

    Win8.1 & Plex - Constant Network Disconnects

    Hi Team

    Been struggling with this for the past week and not making much progress.

    Was working perfectly as a Plex Server for a year with Win10 on it until I had to mess around with it :(

    Upgraded it to the latest Win10
    Upgraded the BIOS
    Installed VNC Connect.

    And things started to go wrong - essentially the unit disconnects from the network when using Plex to stream content.

    Or when using VNC and Plex simultaneously.

    In order to bring it back - I either have to wait for a hour OR reboot the box. As a Plex server the unit is no longer functional as this defeats the purpose.... :(

    Plex has been setup correctly - reachable both internally and externally - so that is not the issue.
    Connectivity is via Ethernet - 100MB FULL.

    I have since

    Fresh install W10
    Downgraded from Win10 to Win8.1 with a fresh install twice.
    Updated the drivers for graphics, Realtek USB
    Reinstalled Plex numerous times

    The only thing I have not tried is downgrading the BIOS firmware - which I would like to try however can't seem to find it.

    Has anyone experienced similar issues before and if so how did you resolve them?

    Once I get back home I will be able to access the logs and post them to assist with troubleshooting.
    Last edited by a moderator: Nov 3, 2017
  5. imi

    imi New Member

    Update

    What’s happening seems like When using plex the Minix PC triggers a DOS like attack on the network resulting in the pc dropping off the network and a flood of packets being reported by the switch and AP.

    How do you recommend I troubleshoot this?
  6. imi

    imi New Member

    UPDATE - disabled multicast forwarding on the network and this has solved the problem.

    seems like there is an issue with Plex in creating the situation in the 1st place - however the above measure remediates the issue - atleast for me.

    No longer need the original version of BIOS - not that I found it anyway.
  7. Villa

    Villa Administrator Administrator

    It doesn't appear to be available. I did look in the MINIX forum download server but could only find the latest.
  8. Ahomaru

    Ahomaru New Member

    Hello, good luck, I like to keep things.
    Here you have the two BIOS (android, Windows).
    Change first to android, so that it lets you install older Windows

    https: //mega.nz/#!0R10nLZI!wFSKv5ryiSlBPX_oIo7zYsL8K2KKfbYKqdGTlCupNiM
  9. Villa

    Villa Administrator Administrator

    That's not what @imi was looking for!
    He doesn't need it anymore either...
    What you have provided is available here...
    http://www.minixforum.com/threads/official-bios-conversion-files.5006/