1. Registration issues have now been resolved. New accounts are able to be created

WiFi Hotspot not working - Minix X7

Discussion in 'NEO X7' started by Mbegin, Dec 31, 2016.

  1. Mbegin

    Mbegin New Member

    Hello everyone,

    This is my first post on this forum and I hope the community will be able to help me :) So here is my issue: I bought 3 Minix X7 as my new internet provider requires it to stream TV. However, my provider (LOL or Luxembourg Online) uses it's own software and here is gets a bite more complicated. I went to the shop and got the 3 hub flashed and tested them at home: the TV works with all the other functions work well expect the wifi hotspot.

    Under the LOL software I am unable to activate the hotspot function. The hotspot slider goes to the 'on' position but no Wifi is emitted. I went to a LOL shop and the technician told me to boot under android and reset the hub and that might work. He told me that to boot under Android, I need during the 'X' phase of the booting press the left arrow multiple times on the remote control. However, this methodology did not work and my Minix keep only booting under the LOL software.

    Here are my questions:
    1. How can I force my minix to boot under Android?
    2. How can I reset the wifi adapter of the Minix?
    (3.) How could I reset the hub without losing the LOL software as I needed to stream TV but hopefully fix the Wifi?

    Some additional information:
    The same issue happens to all 3 Minix and during the booting phase I have removed the network cable.

    Thank you very much for any help :)
  2. Villa

    Villa Trusted Helper Super Moderator

    Is the X7 connected via ethernet?
    For WiFi hotspot to work you need to have the X7 connected via ethernet!
  3. Mbegin

    Mbegin New Member

    Yes, the minix is connected to Internet via an ethernet cable.

    Streaming TV, youtube or any other apps work well so it's not an Internet problem.
    Last edited: Jan 1, 2017
  4. Mbegin

    Mbegin New Member

    No one has an idea?

    Sent from my BBA100-2 using Tapatalk
  5. Villa

    Villa Trusted Helper Super Moderator

    I think you need to go back to the shop!
    I'm guessing you have some sort of custom ROM...
  6. Mbegin

    Mbegin New Member

    Yes, I have a costum ROM. But I don't have a choice of I want to receive TV hence my question, can I force the boot under Android?

    Sent from my BBA100-2 using Tapatalk
  7. Villa

    Villa Trusted Helper Super Moderator

    I think only your provider can help you!
  8. Mbegin

    Mbegin New Member

    Thank you for your answer!

    I already went back to the shop and they told me that the ROM is up to date and that they cannot do anything :(

    Sent from my BBA100-2 using Tapatalk
  9. Villa

    Villa Trusted Helper Super Moderator

    I pulled this image from their website and it clearly states WiFi Hotspot!
    Do they really not know how to get it working for you?

    image_crop__2017_01_06_22_41_32_151.PNG
  10. Villa

    Villa Trusted Helper Super Moderator

    ...and this...

    Screenshot_2017-01-06-22-44-35.png
  11. Mbegin

    Mbegin New Member

    Yes I know, it is one of the reason why I went with this provider as their hub have the hotspot functionality which would be really useful in my home!

    I didn't bought the 3 hubs with them directly, I bought them online and then I went to the shop to get them flashed. I made sure to get the exact same version they are selling (Minix x7) to make sure I don't get any issues with them. Last time I went to the shop they blamed it on me by saying I bought it online! I am pretty sure that is not the issue ... maybe the issue emerged from the flashing?
  12. Villa

    Villa Trusted Helper Super Moderator

    The info I posted above appears to be related to the X5 (Mini) but I would think it would be the same for the X7.
  13. Villa

    Villa Trusted Helper Super Moderator

    If I could get hold of the LOL custom ROM/Software I would try flashing my X7 and see if the hotspot works.
    @HardwareGuru would you be able to help?
  14. Mbegin

    Mbegin New Member

    In step 1 under the 'Wifi Access Point', the 'state' slider goes well on the 'ON' position but no Wifi is created. The technician in the shop told me he had this exact same problem. However, he told me that a reset under Android could maybe fix the issue. However, I am stuck in how to boot Android and reset the wifi settings. Is there not some kind of 'safe mode' boot function with the Minix?
  15. Mbegin

    Mbegin New Member

    I could ask to get the ROM but I seriously doubt they will give it to me. I was looking for a long time online to see if it was online without success.
  16. Villa

    Villa Trusted Helper Super Moderator

    I tagged @HardwareGuru, if anyone can help he can! He may come back saying he can't, but it's worth asking!
  17. Mbegin

    Mbegin New Member

    Thank you Villa for your help :) Let's hope for the best with the help of HardwareGuru! I will also try my best to get hands on the firmware
  18. Mbegin

    Mbegin New Member

    I went to the shop yesterday and they told me that everything is working fine on their side! I asked them to test in front of me but they had no time :( After talking for a while with the technicians, they gave me another Minix where they assured me that the hotspot is working. So this morning I connected to the Minix to my network and I get the exact same error: the wifi hotspot button slides to the 'ON' position but no wifi is emitted. One technician suggested that maybe my modem is blocking any 'hotspot' functionality on the network and that I should check the settings. I have a fritz 7490 and cannot find any options to disable hotspot function on the network, any ideas?
  19. Villa

    Villa Trusted Helper Super Moderator

    Maybe a silly question, but have you connected the ethernet cable?
  20. Mbegin

    Mbegin New Member

    Yes, I am receiving TV so internet is working fine!

    Maybe it has to do with a switch? The current network setup is as follows:
    fritz.box (lan2) ---> switch (4 outputs) (lan1) ----> Minix