1. Registration issues have now been resolved. New accounts are able to be created

X5 X5 Mini Freezes all the time

Discussion in 'NEO X5' started by Tomazzive, Apr 7, 2016.

  1. Tomazzive

    Tomazzive New Member

    Hi,

    I recently bought an Minix X5 Mini (after using X7 as well)
    With the stock firmware (4.2.2.2) I noticed that it freezes from time to time.
    Apparantly the device gets quite hot while playing (local or streaming) videos.

    This happened once in a week.

    So I flashed it and installed the latest KitKat firmware.
    Now it freezes after 1 or 2 hours...

    I tried to put it back to the older version, but I can't connect it anymore to the RKBatchTool. Not with the little button on the backside while connecting the usb and not with the software way in the android settings.

    Any help would be appreciated!
  2. HardwareGuru

    HardwareGuru Developer Administrator

  3. Tomazzive

    Tomazzive New Member

    I did follow that procedure. And tried both software as hardware option. I couldn't connect.
    hardware way => it boots in a special kernel with 8 options. but can't select one of the options. In the RKBatchtool I don't see any connected device.
    software way => i click 'connect to usb' and nothing happens. the mouse cursor is gone and in the batchtool I don't see any device connected.

    I really tried everything.
  4. HardwareGuru

    HardwareGuru Developer Administrator

    you dont use the correct USB cable. please use the original that came with your MINIX
  5. Tomazzive

    Tomazzive New Member

    I do use the same cable. I used it to upgrade it to 4.4.2, and then the procedure worked perfectly.
    I already ordered 3 new minix 7 mini, since I really think the x5 gets too hot and freezes. So with a better cpu and more memory, it shouldn't get that hot.
  6. HardwareGuru

    HardwareGuru Developer Administrator

    when booting into recovery menu it meens the otg cable is not connected. ( or not connected properly )