1. Registration issues have now been resolved. New accounts are able to be created

x5 mini stuck on splash screen after latest firmare update

Discussion in 'NEO X5 mini Official Firmware Releases' started by RobinFox, Apr 17, 2015.

  1. RobinFox

    RobinFox New Member

    Hi all,
    I updated to the latest firmware (2oth Mar 2015) as per the regular process. All seemed to go OK with the update but the minix box just sticks on the splash screen on startup and doesn't go anywhere. Left it for ages but still no joy. Any suggestions ??? thanks :)
  2. Vlad Sasu

    Vlad Sasu New Member

    Hi,
    me too, after installing the new FW (X5mini Kitkat 230) the minix box still looping endless restarting. What can I do?
  3. MaxeL

    MaxeL Active Member

    Flash it again with restore button option in RkFlashTool.
  4. Vlad Sasu

    Vlad Sasu New Member

    There is no more USB connection :)
  5. MaxeL

    MaxeL Active Member

  6. Daan

    Daan New Member

    RobinFox,

    Did you solve the problem?? I've got the same problem. Mij minix x5 mini stucks on the bootscreen. I did try to downgrade to FW 4.2.2., but this won't work also and now my minix keeps rebooting. So again installed FW 4.4 (x5mini-rk3066-240) . And still stucking on the bootscreen with the android logo. Please help me. Anny advise would be welcome. My minix is now useless.

    Details:
    minix x5 mini
    windows 7
    tried BatchTool 1.7 and 1.8
    tried FW x5mini-20150320-230 and x5mini-rk3066-240
    tried downgrade X5mini_20140311_1080fb

    (sorry for my bad english)
    Thanks in advance
  7. Rikki7

    Rikki7 New Member

    After an upgrade the minix can stay on the android logo for a good 15 minutes or more while it's installing everything. Make sure you give it plenty of time before you pull the plug.