1. Welcome to the official forum for MINIX devices!

X5 Wont Reset....weird things happening

Discussion in 'NEO X5' started by Firthy, Sep 19, 2017.

  1. Firthy

    Firthy New Member

    Hi all,

    So I'll prefix this by saying I reset my X5 about twice a year to keep it fresh and zippy and in all the time I've had it I've never had an issue. ....Until today.

    I've recently noticed it getting slow and had a couple of intermitent crashes so when the Youtube App was giving me a black screen today (something that has never happened on this device) I went to update it only to find I had issues with the Playstore as well. It was extremelly slow to start a download, taking 3 or 4 clicks to get any response and when it did download it wouldn't install the update at all. So I went into my settings and tried to clear the cache only to find that my system wouldnt do that. I then tried clearing the Youtube App cache and once again it didnt clear.

    At this point I decided to just do a Factory Reset and refresh everything....only to discover that despite 3 tries my X5 wouldnt do that either. ......Try it in Safe Mode...nope....still no reset.

    So, 2 questions...

    Anyone have any ideas whats going on?
    And, for the life of me I cant remember how to get to the start up options menu that Android has to try to reset from there, and I cant seem to find the info of how to do it, does anyone know?

    I cant do a reflash because I no longer have a PC with an old enough operating system for the RKFlash tool to work on (unless a new version has come out?)

    ....and to top things off my Null Keyboard app seems to have stopped working and I'm typing this with only a narrow letterbox veiw of my screen visable lol.

    edit: Oh, I'm on firmware 240 and thought I'd just update to 250 as a work around but when I went through settings it told me I couldnt update as I was already on the latest firmware. ....And thats definitly wrong. ...more weirdness???
    Last edited: Sep 19, 2017