1. Registration issues have now been resolved. New accounts are able to be created

Official Release X5mini Kitkat 230 ( 23 march 2015 )

Discussion in 'NEO X5 mini Official Firmware Releases' started by KAR, Mar 23, 2015.

  1. jp23

    jp23 New Member

    Am I the only one with Wi-Fi problems? Should I return it or is there a fix?
  2. warzouing

    warzouing New Member

    I have flashed my device X5-Mini with the KikKat 230 release and everything seemed to work well except for the 2 following that some people already mentioned.
    - Only 1 USB device is working. You can plug to either 1 of the 2 ports, the results are the same. The camera is not the issue here but it's rather the USB inside the version of firmware. Even if you try to use an USB hub and connect to only one USB port (no matter which one) with the 2 USB devices connected to the hub, only 1 device will be recognized. I think this one has to be fixed quickly as I need 1 USB port for my mouse and 1 USB port for Camera, Skype, Phone etc...
    - About HLS levels, there are 0, 1, 2, 3, 4 so which one should I use as sometimes I have to switch from 0 to 1 to have it worked and sometimes I have to switch it back from 1 to 0. The issue happened mainly with Youtube and some Online Movie streaming web sites. By the way what is behind those different HLS levels, what do they mean ?
    Anyway, overall it's a real improvement comparing to the JellyBean version from March/2014. Thank You !
  3. KAR

    KAR Developer Super Moderator

    All issues reported (USB, youtube and camera) are fixed in the coming release. By Switching HLS levels you will change the internal player used. With the next release most apps will work at the HLS 0

    Have Fun
    KAR
    warzouing likes this.
  4. warzouing

    warzouing New Member

    Thank you for a very quick response ! Now, I'm waiting impatiently for the announcement of the coming release. After fixing those 2 main issues, it should be perfect release !
    bachikho, HardwareGuru and KAR like this.
  5. HardwareGuru

    HardwareGuru Developer Administrator

    We need a test crew for a quick test of the new 2.4.0 firmware.
    Please let us know if you want to test the new firmware before release.
    ( only active members can apply)
    Test release: april 28/29
    Official release: 30 april/1 may

    Short Changelog;
    - Camera fixes
    - New mouse pointer ( bigger )
    - USB fix ( X5 series)
    - Youtube fix ( working in any HLS configuration )
    - New sensor/giro driver
    - Updated apps
    - Settings changes.
    - and things you will never notice :D
    KAR likes this.
  6. warzouing

    warzouing New Member

    I'm in ! Being a system admin myself for HP-UX, Oracle/Solaris, Linux Redhat, Linux Suse, I'm very open to test new things. From the start with Mediagate, AC Ryan, WD Media Player, Seagate Theatre, Patriot Box Office, Pivos with their Busybox up to now with MK808, MK808b+, Minix X5 mini, MXQ85 with different versions of Android, I got them all just for the fun of trying them and rate them somehow for the beneficial of my friend. The changes in the upcoming test release sound very appealing just with the HLS and the USB/Camera fix.
    KAR likes this.
  7. Sgf_Sdgf

    Sgf_Sdgf New Member

  8. warzouing

    warzouing New Member

    I'm having a Gigabit home network and for the sake of transfering files and streaming videos internally, I would like to know if a Sabrent USB2 Gigabit Ethernet Adapter is supported by the Minix Neo X5 Mini, if not is there any other one that will be supported. Right now I'm having a 100 Mb USB Ethernet Adapter and it is working fine but I think with a 1 Gb one, it will speed things up a little bit for the transfer of files from my NAS to the device. By the way, I just finished downloading the X5_240_Beta and will test it shortly. Will let you all know how it looks like.
    Sgf_Sdgf likes this.
  9. flusky

    flusky New Member

    Hi i have tried to install the kit kat 230 firmware using the rk tool 1.7 on my minix x5 mini. when i restore the firmware through my win 7 pc there are no errors and everthing seems ok and i leave it plugged in and connected to my computer for 15 to 20 mins. when i unplug my box and connect back to my tv and power up its stuck on the minix bootup screen. i tried reinstalling again but still stuck on bootup screen any suggestions i updated from 4.2.2
    Thanks
  10. haiquang

    haiquang New Member

    I updated my x5 mini to kitkat 230 from 4.2.2 too and eveything worsk well except a fews bugs people mentioned above (which are fixed in the next release 240).
    You might want to try downloading the firmware again and reinstall to make sure it's not missing any bytes (it's best using a download manager, I use downthemall plugin on FireFox). Mine steps were:

    1. Install RK driver on computer (windows 7).
    2. Edit config.ini of RK flash tool. SUPPORTLOWUSB= to SUPPORTLOWUSB=TRUE (If your flash tool recognized your minix, skip this step).
    3. Connect usb cable to computer. Hit reset hole with a paperclip while plugging in power cable.
    4. Choose firmware on RK flash tool.
    5. Hit "Restore" button, enjoy the new soul of your minix.

    Hope that helps.
  11. flusky

    flusky New Member

    Thanks i got ut working i tried to install firware for x5 mini when i actually have the x5
    thanks for your help
  12. KingKong

    KingKong Member

    So frustrating. I luckily have still a winXP operating system on an old PC. This will not flash using the win8.1 systems. I have looked high and low but no fix or mention on here. Why!?? I am on about the RKbatch tool needed to install the latest update. WILL NOT WORK on any other pc except winXP.

    Any chance this gonna be looked at???


    Thanks in advance!
  13. KingKong

    KingKong Member

    Also i notice no BATCH APP installer included in the latest update.

    Everybox has this app. Why not the minix x5 mini.

    Having to manually install the apps is so dated.

    Come on guys.
  14. KAR

    KAR Developer Super Moderator

    Works fine at my win 8.1...possible you are using an USB 3 port ?

    Kar
  15. KingKong

    KingKong Member

    Tried both ports on my pc usb 2.0 and 3.0. Not recognized. Plugged in winxp. Ran perfect as usual. I have the latest updated win 8.1 at home. Using the win XP is a pain.
  16. KAR

    KAR Developer Super Moderator

    Working perfectly at my windows 8.1. try to do the following:

    1 - plug-in the X5mini and remove the unknown device in the device manager
    2 - unplug the X5mini and reboot
    3 - download and install Rockchip driver Assistant (all versions)
    4 - plugin the X5mini and see if it is getting installed.

    If it is not working try:

    In the RKBatch directory there is a file named config.ini just edit the SUPPORTLOWUSB= change it to SUPPORTLOWUSB=TRUE and retry

    come on you should get this working...;)

    Kar
  17. KingKong

    KingKong Member

    nope nada. Gonna rest my brain now :eek: Least winxp worked . Thanks for the tips.
  18. haiquang

    haiquang New Member

    Check your pc settings, drivers (third-party usb 3.0 driver for example), anti-virus programs, etc. There's no way other people's pc (both win7 and win8.1) work and yours does not.
  19. Makis

    Makis New Member

    When will we get the new update? The problems with the HLS configuration in the current version are a little bit annoying...o_O
  20. Geoffrey Jacobs

    Geoffrey Jacobs New Member

    I'm also having audio issues, just a slightly different species:

    I start with sounds in the launcher working normally, start either SPMC or MINIX XBMC, and everything works normally. When I play either an AC3 or DTS bitstream using HDMI passthrough to my receiver, subsequent attempts to play PCM data are unsuccessful. If I attempt to play DTS or AC3 data, they work properly. Restarting the receiver does not resolve the issue. Restarting my X5 mini restores PCM playback. Toggling between the default and HDMI bitstream playback devices restores playback.

    Is this an issue others have encountered before? Is it some kind of mixer problem in the ROM? Any ideas on what data to check to troubleshoot the problem?