1. Welcome to the official forum for MINIX devices!

Official Release X5mini Kitkat 240 ( june 4th 2015 )

Discussion in 'NEO X5 mini Official Firmware Releases' started by KAR, Jun 4, 2015.

  1. rjs

    rjs New Member

    Hello All,

    I just updated my mini x5 with kitkat 240 firmware.
    All is great. I choose to unrar the metro launcher and then moved it as a system app and the launcher works flawlessly.

    The issues i face are below.
    Ethernet not working.( wifi and the Ethernet show different MAC id) even with static ip setting it does not work. Ethernet cable is all good because it was the same one used before this flash and tested with other devices.
    Whenever i try to uninstall some google apps like gmail, hangouts etc with Titanium backup it just comes back again, however had success with uninstalling facebook, skype.

    much appreciate your help.
  2. jocommb

    jocommb New Member


    i was removing apps with app master and all work great.... he has an option for disable booting unnecessary apps to....
  3. rjs

    rjs New Member

    thanks for that option. Also remember now may be the apk are located somewhere and on re-start it gets initialized. will check both the options later and see how it goes.
  4. jocommb

    jocommb New Member

    dont know i never again see once removed app.... and just a tip there is no more app master on google play, dont know why i have payed app master...i found it on ip mart...
  5. rjs

    rjs New Member

    Managed to resolve both the issues I had faced.

    1, Ethernet -- it just started to work out of the blue , glad though, no issues for the past hour.
    2, Removing system apps -- used uninstall from play store, most of the apps i want removed are removed however google and gmail remain. Can't see them listed in the app list, will try app master.
  6. rjs

    rjs New Member


    All undesired app removed. uninstalled it through Titanium backup and cleared the dalvik cache.

    All is good now. :) :) Thanks for the ROM, its way better to the stock one.
    camasapa likes this.
  7. klauzer

    klauzer New Member

    How is minix support thinking? There are people using windows 10 so why are there no drivers for that?
  8. camasapa

    camasapa New Member

    Hi,
    what rom are you using?


    Enviado do meu A0001 atrav├ęs de Tapatalk
  9. fabd

    fabd New Member

    Hi everyone,

    i'm totally new to this kind of device. I had been offered a mini x5 to use with kodi, and i'm looking how to upgrade to Kitkat.

    Can anyone send me a link or a documentation to upgrade my mini-x5 ? I read some reply on this post and see some videos that i can't believe it's so complicated to update the device.

    In the first post, i read that we add to put the file (renamed to update.rar) in the memory and it will discover the update ? Is it only that ?

    Why connecting it to windows ? And how to do ? i read someone modifying the registry to enable the device with the drivers (?!).

    Thanks for your answer. I'am not used to this kind of device, i better work with cloud technology...
  10. Villa

    Villa Well-Known Member Super Moderator

    Download link (to be used for a Fresh install or pre CE210 versions)
    http://www.minixforum.com/downloads/download.php?file=x5mini-rk3066-240.rar (drivers and Flashtool included)
    MD5 Checksums:
    x5mini-rk3066-240.rar - 44b141930e6490dde43e5dc258c14eea

    How to...
    http://www.minixforum.com/threads/h...irmware-for-minix-x7-mini-x7-x5-mini-x5.5230/
  11. fabd

    fabd New Member

    this is what i don't understand.
    I want to upgrade to KITKAT with the file you provided me and you send me a link to upgrade the Firmware with other link inside ?
  12. Villa

    Villa Well-Known Member Super Moderator

    What are you talking about?

    Download the firmware from the link I gave you above then follow the tutorial from the other link!

  13. fabd

    fabd New Member

    thanks for your support villa, i will try with the minix beside me. It will me easy to understand for me
  14. Zilch

    Zilch New Member

    Well, no success here, still no solution for win 10 users?


    Enviado do meu iPhone usando o Tapatalk
  15. fabd

    fabd New Member

    Update done. Not very easy on a Windows 8.1 that drivers are not recognized, but with some tutorials it can be done
  16. klauzer

    klauzer New Member

    Please share
  17. fabd

    fabd New Member

    i am writting what i've done and all link use to do it.

    I will share to you this evening.

    Does someone can confirm me that there is a Bluetooth chip Inside the x5 mini ? And does it work ? when i click on BT , it gives me back to the menu.
    camasapa likes this.
  18. fabd

    fabd New Member

    Because not everybody can Watch tutorial on YouTube or found like me it a pain to see instead of reading, here is what i do :

    - Download http://www.minixforum.com/downloads/download.php?file=x5mini-rk3066-240.rar
    - Unzip the file and go to <unzip folder>\x5mini-rk3066-240\RK_DriverAssitant\Release_DriverAssitant
    - Launch DriverInstall.exe and install the drivers
    -
    - Connect the X5 mini with the first USB connector on the right (cf. video ) and the other USB to your computer
    - Use a small paper clip and put it Under the minix where there is a small hole (cf. video)
    - Plug the power A/C and hear the BIP of your computer that tell you a new discovery (failed discovery with descriptor error in the usb device manager)
    - Open a powershell prompt as administrator (right click on Powershell, run as administrator)
    - Paste the line below :
    get-item -path HKLM:\SYSTEM\CurrentControlSet\Control\usbflags\2207300A0100 | New-ItemProperty -name SkipBOSDescriptorQuery -value 1
    it will create a new property in the registry. The usbflags is the one i find in a comment in this forum for a x7mini and also the same for x5mini
    - Reboot your computer and restart the procedure to boot the minix
    - Open BatchTool\RKBatchTool.exe. You should see a green 1 discovered device
    - Click on load the firmware (at the root folder of the rk3066-240.rar
    - click restore
    - 3 minutes after, it should be good.

    Thanks to villa and the guys who made the video, they are the real guy, not me

    For your information, i bought a mini x5 for a KODI device only, and too bad for me, it's to slow, the 1080p video are not smooth (CPU0 100% and CPU1 95%)
    Villa likes this.
  19. klauzer

    klauzer New Member

    I tried to reboot with the paper pin and without. Nothing happens. Computer recognise minix before the powershell input and after. But it can't be seen in batchtool.

    Thanks for trying to help me.
  20. Finn Jensen

    Finn Jensen New Member

    I have installed the Minix X5 mini version with no problem - (except from not being able from Windows 10).

    Where do I find the FOTA app, that enables OTA update??

    There is no such app in the image.

    /Finn