1. Welcome to the official forum for MINIX devices!

Official Release X5mini Kitkat 240 ( june 4th 2015 )

Discussion in 'NEO X5 mini Official Firmware Releases' started by KAR, Jun 4, 2015.

  1. Villa

    Villa Well-Known Member Super Moderator

    Get a paid Smart DNS/VPN service is a better option!

    http://www.zdnet.com/article/hola-vpn-still-riddled-with-security-flaws-researchers-claim/
    http://www.pcmag.com/article2/0,2817,2485083,00.asp
    http://adios-hola.org
    https://hola.org/blog/the-recent-events-on-the-hola-network
    http://www.theverge.com/2015/5/29/8685251/hola-vpn-botnet-selling-users-bandwidth
  2. Stuart Groombridge

    Stuart Groombridge New Member

    Thanks Villa, a very interesting and enlighenting read.
  3. Joseph Smith

    Joseph Smith Member

    @KAR @HardwareGuru - Do you know if there is a fix for this as its a major problem for me to setup the boxes from scratch? Thanks in advance, Regards, Joseph Smith
  4. lvt

    lvt New Member

    Is it possible to boot the customization ROM of this firmware without launcher(Both classic and Metro) ?
    I tried to boot directly to an application and successful at the 1st time but after rebooted Minix hang at animation logo .
  5. johnny64

    johnny64 New Member

    I bought

    NEO X5 mini 4.2.2 firmware (002, 28th August)
    Which upgrade sw we recommend?
    X5 mini KitKat240?
  6. KAR

    KAR Developer Super Moderator

    Yes

    Kar

    Verstuurd vanaf mijn SM-G903F met Tapatalk
  7. lvt

    lvt New Member

    Hi Kar,

    Is it possible to boot the MINIX without any launcher ?
    I tried few time but it hang at animation .

    Thanks
  8. johnny64

    johnny64 New Member

    Managed to upgrade to the new KitKat, braaavoo!
    RKbach tool-NEO Usbdriver instal.u Win7, Minix, click the needle, the tool by clicking on the restore!
  9. phuhuunew

    phuhuunew New Member

    how to watch youtube 1080p? youtube app on playstore (x5 mini)
    Last edited: Jan 15, 2016
  10. kn00tcn

    kn00tcn New Member

    i should have updated half a year ago... i am confirming the usb bugs in 2.3 are fixed, mounting & unmounting is working fine on both usb drives & sd cards

    tried playing youtubes in the youtube (not tv) app, firefox browser, lightning browser (from fdroid), all seem to work acceptable enough as long as you dont have any interfaces or page scrolling going on, i assume kodi will be fine, i think i remember 2.3 had the YT app crashing but kodi worked then

    i dont particularly like the 'new' mousepointer, isnt it the one that minix used years ago?

    i highly recommend a 'mini' ROM is compiled without any apps other than play store & ES (i think some of the AOSP apps should be gone as well, voice recorder/search/browser/etc)

    i dont remember if i correctly got root working on 2.3, will try on this 2.4 sometime...

    NEED A SHUTDOWN BUTTON OR SIMILAR, is the device simply hardwired to auto boot on power? a perfect workaround is reboot into recovery or some low level idle state so we can unplug the power after the OS's shutdown process, i am confirming i rebooted into recovery using adb

    the main bug that i dont think existed previously is when you go to settings>apps>disable or uninstall, you can no longer choose another app until you navigate away from the apps section, this creates quite a chore if you're disabling a bunch of 'all' apps

    edit: the other weird thing that happened was when the flashing tool completed, windows thought it lost the device then it had some kind of usb error along with asking to format the removable storage... the hdmi signal seemed empty so i unplugged then plugged the power, it booted normally with the new ROM like it should

    edit2: so ya, i guess it's physically wired to boot when there is power, so... i ran the root update then used 'SimpleReboot' from fdroid to reboot into recovery so i can unplug the power, good enough for me

    now what about stagefright, is there a chance to backport those fixes? & no it's not about MMS, there are multiple vulnerabilities that can be triggered by visiting a web page or an ad playing a video
    Last edited: Jan 17, 2016
  11. tom kirk

    tom kirk New Member

    Hi
    My name is Tomas I'm from spain (sorry for my spanglish)
    I have the neo x5 mini with 4.2.2 firmware (11th March 2014).
    I have a PC with windows 10 64 bits and another pc with windows 7 16 bits.

    I want to install the new firmware version X5mini Kitkat 240 ( june 4th 2015) and i have the following problems.

    First i tried to use the ota update, i use the configuration menu, go to update section and after try to find a new update, the answer was that i have the last version , no updates available for me. that's normal?? why the new version it's not available for me via OTA ??

    In the spanish support page , the last version available for the x5 mini was 4.2.2 4th FW Release (0311), so my current version, may be this is the problem and for spanish market the new firmware its not available via OTA??

    After i tried to use the tradittional update way with usb drivers and Flashtool using my windows 10 pc. My problem is that i lost the original usb cable that come with the x5 mini so I tried to use another USB male TO USB Male that i had, but is not the original one.

    After follow all the steps , installing usb drivers and use the flashtools my pc didnt recognize the device. when i connect via usb my device to my windows 10 PC nothing happen.

    I tried with another pc with windows 7 and i had the same result , nothing happen when i connect my device using this cable.

    So i suposse that the problem its the cable I use because it's not the original one (by the way the usb ports in the device works ok, I use a hard disk and a keyboard connected to them without problems)

    So my questions are

    the original cable its a special cable ??

    can i buy another one? where??

    can i build another one?? i have a lot of different usb cable so if i cant get the conection schema between pins i can easily build one.

    thanks in advance for your support.
  12. tom kirk

    tom kirk New Member

    Hi again.

    I decided to buy a new cable , a 2.0 usb cable type A male to A male 1 meter (2 euros) and everything was ok using my windows 10 pc and folow the instructions in the m6242 post.
    How to: Update to newest firmware for MINIX X7 mini / X7 / X5 Mini / X5
    Discussion in 'General - Guides and FAQ' started by m6242, Apr 6, 2015.

    Anyway i dont understand why the ota update does not work


    Thanks
  13. Villa

    Villa Well-Known Member Super Moderator

    I believe it is not possible to update OTA when updating the Android version!
    You had Android 4.2.2 Jelly Bean and you have updated to Android 4.4.2 Kitkat.
  14. tom kirk

    tom kirk New Member

    I don´t know, in all the messages at the beginning of this post nobody of the technical team mention that if you have to change the android version you can´t use the ota upgrade, may be Kar can clarify this point.
  15. Villa

    Villa Well-Known Member Super Moderator

    I just told you how it is!

    Yes @KAR can probably explain the technicalities, I guess, if you are interested.
  16. Higgs

    Higgs Yellow Dude Super Moderator

    It does state;
    The key part being or pre CE210 versions. So it should be clear that if you have an older firmware than CE210, then you need to use the rar file and the RK flashtool.
  17. tom kirk

    tom kirk New Member

    thanks for your answers.

    So if i understand well CE210 version mean KItkat version (sorry its something that until now it was not clear for me)

    may be for other user that can read this instructions it would be more clear saying

    'Download link (to be used for a Fresh install or pre Kitkat versions) ' OTA only available for kitkat version