1. Registration issues have now been resolved. New accounts are able to be created

Official Release X5mini Kitkat 250 ( february 8th 2016 )

Discussion in 'NEO X5 mini Official Firmware Releases' started by gufone, Feb 8, 2016.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    We cant share any source due to nda agreements with rockchip. But there are a few sources available, google is your friend. Ps. Warrenty will void when you do such.
  2. karlp

    karlp New Member

    That's really not how GPL compliance works actually. I'm an owner of a minix neo x5 mini, and I'd _really_ like to get the gpl sources corresponding to _any_ released firmware for my device. I'm not asking for sources to rockchip blobs like rk_nand or wifi drivers. And no, google is not my friend, I've never yet found a functional source tree with a corresponding .config that results in even a bootable kernel. Minix responded once a year or so ago to my request that I should send them an email, which I did, but then _that_ email was never replied to.
  3. HardwareGuru

    HardwareGuru Developer Administrator

    I can not release anything.. if you want to discuss your point on GPL compliance please contact minix directly. This discussion for me ends here as i can not supply anything.
    It might be frustrating but on this topic is no room for endless discusions about such so any posts regarding such will be removed after this post. I hope you understand.
  4. karlp

    karlp New Member

    No problem, just thought I'd ask again as there seemed to be activity and new builds. Being listed under official firmware releases made me think this was an official minix release...
  5. HardwareGuru

    HardwareGuru Developer Administrator

    It is an official minix release, just build and maintained by the our dev team and approved by minix thus this release will be covered by warrenty etc...
    gufone and midnight like this.
  6. dung

    dung New Member

    how unroot minix x5mini?
  7. dung

    dung New Member

    installation fails
  8. Higgs

    Higgs Yellow Dude Super Moderator

    Could you please keep your posts short and to the point? :whistle:

    Seriously though, "installation fails" is not enough information for anyone to help you. Please provide at minimum;
    • Your current firmware
    • exact steps you are following
    • any error messages you are seeing (screenshot or exact wording of error)
    • what stage the 'installation fails'
  9. markman34

    markman34 New Member

    Hi everyone.
    Second post so I'm a bit of a newby.
    I did the 2.5.0 update on my x5 mini and experienced wifi problems. Posted here but did not receive a single response.
    So I retried the firmware and the wifi issues are gone but my device is always crashing now. Can't make it through a movie without crashing.
    I have uninstalled everything and the problem persists.
    Someone please tell me there is a fix to this.
    Is it possible to downgrade to the previous firmware?
  10. nimish Shewaramani

    nimish Shewaramani New Member

    Hello,

    I have updated with latest firmware. It is working prefectly fine. But their is one majot issue.
    THE date and time is not retaining in my devices. The Devices has preinstall RTC battery and it was working perfectly fine in my older Firmware(4.2.2).

    But in latest Firmware we are facing the problem of date and time and it is getting automatically reset when we start devices in morning or after restarting it. The devices are used for commercial purpose and we can't afford such error os date and time not retaining. Please help me out for this issue.
  11. HardwareGuru

    HardwareGuru Developer Administrator

    The x5mini does not have a battery, it fetches time from an online utc time server..
  12. Jainam

    Jainam New Member

    there is a battery slot in minix meo x5 mini. on installing a battery it retains time in Android 4.2.2 but not in Kitkat
  13. markman34

    markman34 New Member

    Bump
  14. HardwareGuru

    HardwareGuru Developer Administrator

    250 firmware should work just fine.
    try a factory reset:
    settings > backup and restore > ....
    See if that solves the issue.

    If the problems persist you can allways roll back to 4.2.2:
    http://www.minixforum.com/threads/downgrade-4-4-2-kitkat-to-4-2-2-jellybean-rockchip-only.5218/
  15. ikkiedik

    ikkiedik New Member

    where can I find the download for this firmware i have stilla 2013 firmware
  16. Villa

    Villa Well-Known Member Super Moderator

  17. markman34

    markman34 New Member


    Thanks guru.
    I have tried the 2.5.0 install twice.
    First attempt had the wifi problems.
    Second attempt the wifi was fixed but the unit just goes to a black screen and I have to unplug to get it back up.
    The only other thing I haven't mentioned is that with my Rii keyboard/mouse or my Logitech mouse I get occasional connection/delay/repeating keystroke problems.
    I paid a fortune for this thing from my neighbour and it has never quite worked properly.
    Thanks again for the help all!

    Mark
  18. WhipCracker

    WhipCracker New Member

    I'm having the exact same problem as you too. I'm wanting to install the RTC battery into the unit, but it appears that it'll void the warranty (one of those funny stickers on top of the screw) so I'm just thinking of taking it back for a refund.
  19. MFCruiser

    MFCruiser New Member

    Just updated to latest 250 from 4.2.2. Yep, I know it's a bit ....old. The new firmware resolves a quite a few annoying issues that we have had to put up with. Glad to take the time and updated it via a Windows 10 box.

    So kudos to the development team. Thank you. Neox5 mini is not left orphaned just because Minix got my money a while ago. :). Thanks again.
    Villa likes this.
  20. nimish Shewaramani

    nimish Shewaramani New Member