1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

X6 002 firmware (20141115)

Discussion in 'Official Firmware Releases' started by MINIX - Ken, Nov 15, 2014.

Thread Status:
Not open for further replies.
  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO X6 users,

    We're pleased to release the 002 firmware.

    Burning tool download link:
    MINIX Server: http://minix.com.hk/downfile/USB_Burning_Tool_v2.0.3_x86.rar
    Forum Server: http://www.minixforum.com/downloads/download.php?file=USB_Burning_Tool_v2.0.3_x86.rar

    Firmware download link:
    MINIX Server: http://minix.com.hk/firmware/NEO_X6_002_FW.zip
    Forum Server: http://www.minixforum.com/downloads/download.php?file=NEO-X6-002FW.zip

    Change log:
    1.) Enhanced TF card reading speed;
    2.) Fixed HDMI occasional no display issue;
    3.) Fixed system halt issue when fast fowarding/rewinding some videos;
    4.) Fixed some streaming apps playing with audio but no display issue;
    5.) Sync. with latest AMLogic source code;

    Regards,
    Team MINIX.
    Last edited by a moderator: Nov 15, 2014
    izmeMarco and Gh0st like this.
  2. Joseph Smith

    Joseph Smith Member

    I have tried 50 times to download the firmware, is there anywhere else we can download it from? Thanks in advance.
  3. HardwareGuru

    HardwareGuru Developer Administrator

    uploaded to forum server and added links to post#1
    izmeMarco likes this.
  4. Joseph Smith

    Joseph Smith Member

    Thanks - downloaded fine :)
  5. Joseph Smith

    Joseph Smith Member

    Hi I was hoping the 002 firmware would of cured the problem where the X6 is not detected in Windows or ADB or MoboRobo, are you aware of this problem and can this be fixed? Thanks for all your efforts, Regards Joseph
  6. Fafa

    Fafa New Member

    Hi,

    When do you think the update will be available by OTA ?

    Thanks
  7. Fafa

    Fafa New Member

    Arf I tried by USB burning tool but the program not run on my Win8.1 (0xc000007b)
  8. Joseph Smith

    Joseph Smith Member

    Hi is there going to be a fix for the X6 as its not recognised by windows, ADB or Moborobo, really important for us resellers. thanks in advance Joseph
    Jesmond Spiteri likes this.
  9. No ADB yet and no Windows storage access. Also issues with IR remote seems to not have been acknowledged yet by MINIX and the A2 CAPS LED light does not work either. It also seems that the A2 back button takes you to the home page of XBMC rather than 1 step back and is so annoying. Please can someone listen to these problems and at least acknowledge them and someday rectify. Thank you for your support.
  10. Joseph Smith

    Joseph Smith Member

    Hi is there any update on a fix for the X6 as its not recognised by windows, ADB or Moborobo, really important for us resellers. thanks in advance Joseph
  11. davide95

    davide95 Member

    I've some problems updating to 002 firmware.
    I'm a linux based operating system user, so I can't install the USB burning tool for windows (Ayway, I've tried to install the 2.0.3 version in a win 8.1 machine but it reported me an error, so i've tried to install the 2.0.1 version but it didn't recognize my Minix X6) .
    Then I tried to update the X6 using an usbsitck (settings>>update>>I've selected the NEO-X6-002FW.zip file in the usbstick, checked wipe data and media>>update. Then it reboot into recovery, I choose update via ustick>>NEO-X6-002FW.zip. It start the update but it say "footer is wrong" and the updating process is aborted...)
    What to do?
    Why don't release OTA updates?

    Ty
    Davide
  12. Higgs

    Higgs Yellow Dude Super Moderator

    What error did you get installing the 2.0.3 Version?
    Did you uninstall the previous version first?
    The 2.0.3 ver installed first time for me on win8.1.
    You can't install this fw via usbstick, you have to use the burning tool.

    Sent using Tapatalk
  13. ADB is needed for X6 please. Thank you.
  14. Jocke Sorlander

    Jocke Sorlander New Member

    Do you have 32 bit 8.1? On my 64 bit it wont work even in compatible mode. Sucks that "ordinary" usb - flash dont work.
  15. Higgs

    Higgs Yellow Dude Super Moderator

    64bit. i uninstalled the old version and then downloaded and installed this no problems. what error do you get?

    Edit: Just to be certain I uninstalled it and reinstalled it with no issues.
    Last edited: Nov 22, 2014
  16. davide95

    davide95 Member

    I tried it on win 8.1 64 bit. Frist installation of this tool...
  17. Higgs

    Higgs Yellow Dude Super Moderator

    and what error are you getting?
  18. Jocke Sorlander

    Jocke Sorlander New Member

    Its OK now. Moborobo helped.
  19. davide95

    davide95 Member

    Something related to dll....
    BUT, I installed the 2.0.1 version, then I uinstalled it and re-installed the 2.0.3 version: it worked, no more errors during startup of the app.
    Thanks
  20. Cam Wynd

    Cam Wynd New Member

    I've been spending a lot of time trying to get the burning tool to work, on multiple systems and the best result so far is an error sayiny the application could not start properly.

    When is this going to the OTA upgrade, or at least a SD card based upgrade like Hardware Guru made for the X8 series?
Thread Status:
Not open for further replies.