1. Official MINIX forum

X6 002 firmware (20141115)

Discussion in 'Official Firmware Releases' started by MINIX - Ken, Nov 15, 2014.

Thread Status:
Not open for further replies.
  1. Higgs

    Higgs Yellow Dude Super Moderator

    Have you tried what worked for davide95 (post above yours). Install version 2.0.1, uninstall then install version 2.0.3.
  2. Cam Wynd

    Cam Wynd New Member

    Yep - I tried that, but it didn't work for me. Thank for the suggestion.

    C
  3. davide95

    davide95 Member

    Try to disable "verify driver signature" on Windows 8.1 advanced startup
  4. Joseph Smith

    Joseph Smith Member

    Hi

    I have checked the X6 and USB Debugging is enabled. The problem with the X6 is that it is not recognised by windows at all running in normal startup mode. In older models like the X5 we had a USB section where we could tick CONNECT TO PC. The X8 also had a similar problem when Beta 9 and 9.2 were released. the X6 and X8 should both prompt us when connecting it to a PC in normal mode. The prompt should read something like - DO YOU ALWAYS WANT THIS COMPUTER TO HAVE ACCESS TO USB DEBGUGGING - the wording is not exact, but I am sure you know of the message.

    As the X6 is not picked up by Device manager or My computer on all windows versions, it is seems that there is no CONNECT TO PC service (I am just calling it a CONNECT TO PC service as its an easy way to explain what we are talking about)

    I would be grateful if someone would acknowledge this problem as many users have reported it and we are yet to receive an acknowledgement.

    As you can imagine this is a very simple test. just connect the box into a PC and turn it on as normal.

    The X6 is also not recognised by ADB or Moborobo (Running in Normal mode)

    Thanks for all your help.

    Kind Regards


    Joseph Smith
  5. Gianni

    Gianni New Member

    When do you think the update will be available by OTA ?
    Thanks
  6. I have same issue with x6 and x8 Beta 9, etc. Beta 8 was good. Also x8 FW002 same issue, no ADB :/
  7. chris16v

    chris16v New Member

    does anyone know how to resolve the Burning tool launch error. I am running Windows 7 64bit and the burning tool installs without error but wont launch, the error is basic. something like: "the burning tool cannot load"

    i have uninstalled the tool, rebooted and reinstalled. no errors during reinstall, but same error persists
  8. davide95

    davide95 Member

    First install the previus (2.0.1) version, then install the new one (2.0.3) like i ve already said.
    That worked for me
  9. inonz987

    inonz987 New Member

    I have done it by this method.
  10. Kintaro

    Kintaro New Member

    Hi,

    thank you for the update.

    The X6 002 firmware has a SDFix "patch" in it or we have to root the device and install some SDFix app to do it?

    Regards
  11. chris16v

    chris16v New Member

    i have followed previous instructions to install 2.0.1 then 2.0.3 which I have done, now thankfully the burning software launches BUT i don't see the X6 connecting in any way.
    Windows device manager doesn't see the X6, and subsequently the burning tool doesn't connect either. I have tried powering it the X6 with/without holding down the little power button, usb first/last, power first/last.
    The burning tool doesn't see it and doesn't connect.

    any ideas?
  12. davide95

    davide95 Member

    Yes, change usb port on the x6
  13. chris16v

    chris16v New Member

    thanks daide95 there are 2 ports and I have tried both, windows device manager sees nothing.
    I have checked the usb port and the wire, they are fine. the X6 fires up fine, so what am I missing?
    is there a certain procedure/order or way of doing this with a combination of power wire/usb wire/power on button, etc?
  14. Higgs

    Higgs Yellow Dude Super Moderator

    You also have the reset button pressed, before pressing the power button?

    Sent using Tapatalk
  15. chris16v

    chris16v New Member

    ahhhh, a reset button. I cant find that. I am inspecting the X6 and cant see it and even the manual doesn't describe a reset button. the manual describes every other port but no reset button, is it hidden somewhere?

    manual = poer button, sd slot, usb port1, usb port2,
    then its headphone jack, hdmi port, Ethernet, 5v power and that's it, no reset button........
  16. Higgs

    Higgs Yellow Dude Super Moderator

    On the bottom of the box, you'll see a pinhole, use a pin to press the reset button.

    Sent using Tapatalk
  17. chris16v

    chris16v New Member

    guys, thanks for your help. For anyone who is also looking to flash to the latest firmware and needs a holding hand, read on:

      1. download burner tool 2.0.1 from stock firmware thead and install
      2. download burner tool 2.0.3 from post 1 of this thread and install
      3. download the firmware from post 1 of this thread
      4. follow the fireware upgrade instructions instructions http://www.minixforum.com/threads/how-to-flash-the-beta-firmware-image.116/
      5. when switching on the X6 for it to communicate with your Windows machine, have a small pin to stick in the tiny reset hole located on the under side of the X6 box.
  18. Joseph Smith

    Joseph Smith Member

    Higgs

    I hope you are well

    It seems Minix is avoiding the questions regarding the X6 not be detected by windows or ADB, is anyone ever going to answer these queries?

    I believe we have been very very patient?

    Regards

    Joseph Smith
  19. Higgs

    Higgs Yellow Dude Super Moderator

    You need to check with @MINIX - Ken or @MINIX - John. I don't work for Minix and am not a developer. I just help moderate the forum.
  20. Joseph Smith

    Joseph Smith Member

    Higgs, Thanks but as you can see no-one seems to be active on the X6 queries?
Thread Status:
Not open for further replies.