1. Registration issues have now been resolved. New accounts are able to be created

X6 005 firmware (20150307) via MINIX FOTA

Discussion in 'Official Firmware Releases' started by MINIX - Ken, Mar 7, 2015.

Thread Status:
Not open for further replies.
  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Dear all NEO X6 users,

    The new 005 firmware is now available via FOTA, please kindly note.

    Feedbacks are welcomed~

    PLEASE DO NOT DISCONNECT THE POWER SOURCE DURING UPDATE!!


    Change log since 004 firmware:

    1.) Fixed UI problem with Hebrew language; (Android system bug)
    2.) Fixed video playback random slowing bug;
    3.) Improved H.265 video playback smoothness; (NEO X6 supports 1080p max.)
    4.) Fixed 1080p 24Hz audio issue with external amplifier

    P.S. Please make sure you're with at least firmware 003 in order to receive the MINIX FOTA update~
    If not, please update to firmware 003 first:
    http://minixforum.com/threads/x6-003-firmware-20141225.3066/

    Regards,
    Team MINIX.
  2. Scugni

    Scugni New Member

    Hello, I'm trying to update the system via app "firmware update" and it says it is already updated:-(
    The currently installed version is: KOT49H.20150203 release-keys
    It 'possible that the update is not yet available?
    Thank You.
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    It might take some time to become active.
    Please check again later.
  4. volamaster

    volamaster New Member

    Updating...! :)
  5. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    FOTA server is under maintenance today (bandwidth upgrade),
    service will be resumed tomorrow.
  6. Menachem Zibziner

    Menachem Zibziner New Member

    Hi there,
    My Minix 6's firmware is 20141008 (stock)

    What would be the fastest route to fw005:
    1. fw003 via usb -> OTA updates? or
    2. fw002-> 003 -> OTA?

    In other words, can I update directly to 003 and keep my stock firmware data (no wipe)

    Thanks in advance
    Menachem
  7. Meng Chan

    Meng Chan New Member

    I am using FW3 I tried OTA but it show connection fail or no update, what should I do?
  8. Honex

    Honex New Member

    I did the 1. option with no problem.
  9. Menachem Zibziner

    Menachem Zibziner New Member

    Babysit it, press "Retry" until it done. Will work.
  10. Menachem Zibziner

    Menachem Zibziner New Member

    Thank you "Honex"
  11. Meng Chan

    Meng Chan New Member

    Finally updated to FW5, really have to base on luck, keep trying and trying....
  12. onericardo

    onericardo New Member

    Is there any reason to not release the full firmware like you did in 03 ?

    I mean, if we want to do a "fresh" install, we need to install 03 and then the update(s).
  13. Higgs

    Higgs Yellow Dude Super Moderator

    Just install the update, then do a factory reset.
  14. icy20

    icy20 Member

    My x6 finds the update but when i press download it says network connection failed. What is wrong? I tried with both ethernet-wifi...I have 003 firmware ATM...
  15. Honex

    Honex New Member

    There is solution literally 5 posts above your post. Just click on retry until its downloaded.
  16. icy20

    icy20 Member

    It took me almost half a day to get it to work. Don't know why...
  17. tgriger

    tgriger New Member

    I have X6 with 005 and if I turn off XBMC, no problem, X6 starting from sleep mode very quickly (2-3 seconds). But If I don't stop XBMC before sleeping, X6 is starting very long time, about 1-2 minutes.
    Is it problem in firmware or Do You have some workarround? (I know, turn off XBMC :) )
    dibotto likes this.
  18. dibotto

    dibotto Member

    Done update 005 all ok. I have an amp yamaha rx-V465 and before the upgrade I had a problem with the sound with movies 1080p 24Hz. With the update frequency active video when watching a movie at 24Hz the amp started to stutter. Problem solved with the update oo5.

    I'm noticing, especially with H265, repeated delays during video playback. The sound is perfect, the video is not fluid. I tried both xbmcminix 13.3.0, 13.3.3 is xbmcminix final, both SPMC 14.2.0. Same result. If active updating the video frequency, and therefore, I see movies at 1080p 24Hz, I slowdowns of the video during playback. If this aspect improves everything is perfect.
  19. dibotto

    dibotto Member

    I have the same problem
    tgriger likes this.
  20. dibotto

    dibotto Member

    does not write any more on this forum ???I'm noticing, especially with H265, repeated delays during video playback. The sound is perfect, the video is not fluid. .... not had to release a new firmware 006 for x6 ???
    Last edited: Apr 27, 2015
Thread Status:
Not open for further replies.