1. Official MINIX forum

X6 Crashes, goes back to Launcher screen

Discussion in 'NEO X6 Official Firmware Releases' started by jimn, Dec 6, 2014.

  1. jimn

    jimn New Member

    I bought this for me elderly mother to run as a trouble free appliance type device - I'm in HK she is in Australia

    Really disappointed with it as it now crashes every time she tries to use it. So right now its useless.

    I have her set up with XBMC latest version - as soon as you select a movie, the system reverts to the Launcher screen. hard reset did fix it for a while but now it happen every time - when selecting a music track this was fine for a while but now i hear that it plays for about 20 seconds and again reverts to the launcher screen every time.

    what rubbish!!!!

    I'm assuming it's still on the original f/w - i tried to do an OTA but there was nothing there. So now i have to try to resolve this somehow remotely from HK - not impressed. Particularly since there is no OTA f/w update.

    Does anyone have any ideas as to what's going on/how to fix?

    Thanks

    Jim
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Hi Jim,

    1.) The stock firmware is performing fine;
    2.) Which version of XBMC you asked her to install?;
    3.) Nobody could tell the cause(s) of the crashes now;
    4.) Get a swap if possible;

    It's really hard to help someone this way.
    I did the same for my mother too, however, I got it setup, removed all unnecessary stuff, and tested for one week before I gave it to her.
    It's not about age but the knowledges possessed. Since she is nearly 60 years old I couldn't demand her to learn new things anymore.
  3. jimn

    jimn New Member

    Thanks Ken

    I've chucked it out - getting an ASUS Chromebox re-installed with OpenElec, which will be rock solid. I really don't have the time or inclination to try and resolve this remotely.

    Thanks anyway

    Jim
  4. jimn

    jimn New Member

    The stock f/w is NOT performing fine
  5. jimn

    jimn New Member

    Installed XBMC Gotham btw
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    No matter which box you get, you should 100% set it up, test for at least a week to make sure everything is fine, before passing it to your mother. Can't expect her to sort anything out, you need to do it in advance for her, son. Good luck.
  7. jimn

    jimn New Member

    True - but had limited time

    Fact remains - the box should work as advertised; it doesn't, clearly malfunctioned

    I now have an ASUS Chromebox running OpenElec - rock solid, with no android baggage
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    I have no idea what's happening on her side but a normal functioning unit wouldn't have the problems you described.
  9. jimn

    jimn New Member

    So then why did MINIX sell me an abnormally functioning unit ? AKA now as a brick
  10. jimn

    jimn New Member

    Not to mention the countless hours i spent setting it up - it's junk
  11. Gh0st

    Gh0st Australia's Finest Since 1981 Administrator

    I've got one setup for my wife in our room & one for my mother also. Both on firmware they came with and beta 3 MINIX XBMC.
    Never had them ask me for help & believe me if something remotely out of the ordinary happens they'll let me know.

    It does sound like possibly a defective unit.
    That is not MINIXs fault, that is the world of electronics. The failure rate is small but it happens.
    I recently set my mother up with an Xperia Z2 tablet. 2 months later it stopped working.
    The PCB was faulty & Sony don't cover that in the warranty (surprise surprise) so we could spend $500 to fix a $650 tablet.
    With the X6 you have a proper warranty as long as you don't root it or hit it with a hammer.
    I'd suggest you take advantage of that warranty

    Sent from my brain, to my fingers & then to Tapatalk
  12. jimn

    jimn New Member

    Thanks Ghost. To be honest I don't really have the time or inclination

    I much prefer the appliance / STB experience of a dedicated XBMC unit - rather than the baggage of Android; although it's good to have things like ABC iView, via an App. Hopefully it's available as an XBMC add on.

    Jim
  13. Gh0st

    Gh0st Australia's Finest Since 1981 Administrator

    I'll check mate. I know there were addons for Prime & channel 10. Don't think there is for ABC though.
    If you want, get her to send it to me (I'm down in SA) I can get it sorted. You can use XBMC as a launcher and launch iview etc from the programs menu. That way you have the ease of dedicated XBMC & the option of other useful droid apps

    Sent from my brain, to my fingers & then to Tapatalk
  14. jimn

    jimn New Member

    Mate - that's incredibly generous of you.

    I'm heading down there next week for Christmas - She's in Narooma btw.

    Can you please PM your address and I'll revert with contact details too.

    Very, very much appreciated!

    Jim
  15. Gh0st

    Gh0st Australia's Finest Since 1981 Administrator

    No worries! I'll pm you when I get home.

    Sent from my brain, to my fingers & then to Tapatalk
  16. jimn

    jimn New Member

    awesome - thanks mate
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Thanks.
    Gh0st likes this.
  18. Harry in Spain

    Harry in Spain New Member

    I am a dealer and I am finding that a lot of the X6 are freezing and going back to launcher screen have spoken with distributor but problem not solved getting anxious anyone else with this problem
  19. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    please update to the latest 007A firmware, run a system factory reset afterwards.
  20. I have issues with IPTV which goes back to launcher when zapping through channels in the LIVE TV section of XBMC. These issues with IPTV were solved for the X8H/Plus a few months ago, before the x6 was born. I own an X8H-Plus too and this does not suffer these issues with IPTV. Can you take care of this please? The use of IPTV is definitely the future and this has to work properly. I also own an X5 which works beautifully. Also with the X6 the preview picture is offset and one sees only 1/2 or 1/3 of the picture, exactly same issues the X8H had some time ago. Please take action. Thank you.