1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

X6 stock firmware (20141024)

Discussion in 'Official Firmware Releases' started by MINIX - Ken, Oct 24, 2014.

Thread Status:
Not open for further replies.
  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  2. sonofdibnah

    sonofdibnah New Member

    Is there a change log for this? I've experienced data loss from the sd card on the shipped firmware and had to unmount then remount the sdcard in order to be able to delete damaged files. I will be loading this anyway but it would be nice to know the issues it addresses.
  3. HardwareGuru

    HardwareGuru Developer Administrator

    This has adressed a SDcard fix.
    I dont know the full changelog
  4. handroid

    handroid New Member

    I have a weird problem with the X6. I have connected the X6 over HDMI with my Onkyo receiver. When I put the X6 in sleep mode and switch off my Samsung TV, there is no way to power on my TV. The IR remote for my TV doesn't work neither does the on/off switch. It first I thought my TV was broken, but as soon as I pulled the power plug from the X6 my TV remote and TV was working again.
    I assume this has something to do with the CEC control. I tried different CEC settings on the Minix, no luck.

    Maybe the new stock firmware solves this issue. I'll report back later.

    Update: I flashed the new stock firmware and the problem is solved.
    Last edited: Oct 29, 2014
    HardwareGuru likes this.
  5. sonofdibnah

    sonofdibnah New Member

    I have updated to the new firmware and continue to have problems with data loss from the sd card. I added a movie to a folder "films". Restarted the box thro using the power button on the remote. Folder "films" was empty. Thro android settings I unmounted and then remounted the disc and now "films" is no longer there.
  6. Jönke

    Jönke New Member

    Does true 23,976 Hz work on x6 ?
  7. Chavdar

    Chavdar New Member

    Hello,
    Just got my new X6 device and so far I can say it is awesome.
    But there are several issues that I want to point:

    1. Google+ at the store said that this device is not compatible and can not install it.
    2. HDMI-CEC is very unstable. Randomly loses connection and I need to turn off the TV ( Sony Bravia ) to make it work again.
    3. HDMI-CEC lacks of mapped keys, not working EPG, info, channel switch, subtitles, SMS type text input.
    4. HDMI-CEC is not in libcec.

    Of course this does not prevent me from enjoying my new device :)
  8. Which port should be used for flashing? The one next to the SD card slot? Also how to get ADB access to the box please?
  9. Guys, some help how to flash the baby please. I am in system recovery and a menu comes up as attached image. Remote control vol up and down does not work at all. Any help please?

    Attached Files:

  10. Higgs

    Higgs Yellow Dude Super Moderator

    Did you read.the first post? The link to 'how to flash' is there.
    Use the usb-usb cable that came with the box, in the usb port nearest the edge.
    Sent using Tapatalk
  11. Higgs

    Higgs Yellow Dude Super Moderator

    The outside one, nearest the edge.

    Sent using Tapatalk
  12. Yes but that is just the software part which I already used with the x8 without issues but the x8 has an OTG port.

    I managed to flash it now but the cable had to be inserted before power on/reset combination otherwise that Android System Recovery menu comes up which takes you to a dead end as yet.

    Also can you help me with accessing the storage from a computer please. When the x6 is started up I cannot access the SD Partition from Windows. Any ideas?
  13. Higgs

    Higgs Yellow Dude Super Moderator

    Use an ftp app like ftpdroid.

    Sent using Tapatalk
  14. Yes ok but what i need is ADB mostly. Is it not working yet? tnx
  15. loko99

    loko99 New Member

    Hi,

    can not get my pc (windows 7) detects :(
  16. davide95

    davide95 Member

    Is this a beta-firmware or a stable one?
    ty

    PS: I've experienced data loss from the micro-sd too
  17. Fafa

    Fafa New Member

    Hi,

    The update by OTA doesn't work with the X6 ?

    Thanks
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We haven't push new update to the OTA server yet.
  19. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  20. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Hello, sorry to hear that, this issue is rare and is addressed in 002 fw.
Thread Status:
Not open for further replies.