1. Registration issues have now been resolved. New accounts are able to be created

Official Release X7 Kitkat 250 ( february 8th 2016 )

Discussion in 'NEO X7 Official Firmware Releases' started by gufone, Feb 8, 2016.

  1. HardwareGuru

    HardwareGuru Developer Administrator

    I think it did lol.. too long ago i have had any 4.2 on any device ;)
    ZeevE likes this.
  2. ZeevE

    ZeevE New Member

    I wish I won't have any more nand issues.
    This nand issue was the core problem so it was actually the main reason for me to decide to upgrade the device to the kk v250.
    I can agree with you that the blinking led is much less important comparing to other issues that you had to deal with.
    Anyway, thank you HardwareGuru and all the team for this wonderful KK v250 firmware version, I really love it, so far so good!
    Villa likes this.
  3. Fedur

    Fedur New Member

    There is no nand issue on v240 also. Best rom for minix x7 neo. Super stable and fast only bad thing is 1080p kernel for people who whant play some games on it. It is too slow. 720p was better (quickshoot rom etc). For media player v240 and 250 are the best.

    Wysłane z mojego LG-D620 przy użyciu Tapatalka
    Last edited: Oct 24, 2016
  4. Hungdbp

    Hungdbp New Member

    anybody can help me ?when finish installation 250 fw, the "connected device" block remain in pink colour and my mini x not working
  5. HardwareGuru

    HardwareGuru Developer Administrator

    When it is pink press "switch" on the flashtool first. Then it should switch to green.
  6. Hungdbp

    Hungdbp New Member

    thanks for reply but normally when installation finish that block goes off,is it correct?
    sorry for my english
  7. HardwareGuru

    HardwareGuru Developer Administrator

    When flashing succeeds and it goes pink, try leaving it for 15 minutes before unplugging it.
    After that connect it to your TV.

    * pink means that there is an USB abd device connection
  8. Hungdbp

    Hungdbp New Member

    thank you so much,i'll try as your advise
  9. Hungdbp

    Hungdbp New Member

    installation was succeed but when I connected to TV and powered it on, there only startup screen appeared,after that my MINIX was OFF(I have tried many times and the same result), could you tell me why?
    thanks
  10. FedeSp

    FedeSp New Member

    Hello everyone, I have a big problem, while updating my Minix X7 around 90% has restarted, from that time are no longer able to start it. if disalimento and restart the computer that I hear a new terminal but then turned OFF,. while if I connect it to the TV restarts below. What can I do? I spoke with the media and gave me the link to this thread. I have a notebook with Windows 10
    Darkshine likes this.
  11. NewB

    NewB New Member

    Hi everyone, I am in need of assistance upgrading my X7. I have never put a firmware release on this device until now. I am using Windows 10 and applied the reg keys needed for for the x7 drivers to work. I am using version 1.8 of the RKBatch tool and when I connect the X7 in flash mode it appears in the batch tool with a green block. I load the firmware and click restore and the upgrade goes through without any errors. When I plug the X7 into my TV and boot it up it goes through its startup until it gets to the Minix logo and then it starts showing huge black "pixels" all over the screen and is really slow. I mean click an arrow on the remote, keyboard or move the mouse, and wait a minimum of 30 seconds to see the change on the screen. It is essentially bricked.

    When I loaded the firmware it completes successfully but block remains pink no matter how long I leave it.(left for hours once). I've tried clicking the "switch" button which does turn the block green, but it still behaves the same on boot up.

    Any ideas?
  12. NewB

    NewB New Member

    Update: Well I couldn't keep from playing with the damn thing and decided to try a really old firmware from the forum and tried the 004 firmware, now I believe I really have bricked it as I cannot boot it up and I can't get it to stay in recovery mode. When I attempt to put it in recovery mode it connects briefly to the PC and then disconnects again.

    Help!!

    Fixed bricked issue: Followed the below link to successfully restore:
    http://www.minixforum.com/threads/unbrick-your-minix.4416/

    still have the original issue :(
    Last edited: Nov 15, 2016
  13. EagleEye

    EagleEye Member

    Try batch tool 1.7
  14. NewB

    NewB New Member

    I actually thought of this, but it didn't work on My Windows 10 PC. It doesn't detect the X7. I read that it is simply a Config.ini issue, but instead I found a friend with a Windows 7 computer and tried the restore from his computer. It restores without errors and disconnects from the PC when complete, but still had the same issue when I connect it to my TV and.

    Appreciate your help though!!
  15. EagleEye

    EagleEye Member

    And it was working fine before flashing?
  16. NewB

    NewB New Member

    Actually it's my brother in-laws, and he now informs me it was freezing up on him all the time before he asked me upgrade it for him. I have the x7 as well and I flashed mine months ago without issue. So is his just NFG then? or is it possible to revive it?
  17. EagleEye

    EagleEye Member

    Looks like a hardware failure i think R.I.P for this device
  18. Adambob

    Adambob New Member

    Hay does any body know if there is going to be a version 5.1.1 or 6.0.0 (Android versions)
  19. gvpatelgm

    gvpatelgm New Member

    I'm using Neo x7 kitkat 250 it's old. Update for latest...
    Lollipop or marshmallow version when possible??????any other stable custom roms??? etc....

    Sent from my Redmi Note 3 using Tapatalk
  20. midnight

    midnight Moderator Moderator

    I don't think at this time there are an official plans to up grade to 5.1 or higher for the the X7.