1. Official MINIX forum

Custom ROM X7 Kitkat v2.1.0 Community Edition

Discussion in 'NEO X7 Custom ROMs, Kernels & Discussion' started by HardwareGuru, Dec 15, 2014.

Thread Status:
Not open for further replies.
  1. HardwareGuru

    HardwareGuru Developer Administrator

    MINIX Forum "Community Edition" Kitkat 4.4.2

    OTA;
    For this release there will be NO OTA, sorry guys..
    There are some changes wich can not be updated through OTA
    It is technicaly imposible to do.
    We decided that it was best to do it now then in a later state as we have to do it eventualy.

    Flashable Image:
    This firmware will be provided as flashable firmware.
    You NEED to flash it with the usb flashtool provided in the download link.

    The future of CE;
    This will probably last "Community edition" and next releases will become "Official MINIX" releases. This meens it will have the MINIX logo's etc but still our team will be working on it.
    After this release and the feedback from it we will also start porting to the X7mini, X5 and X5mini but this will take some time before they are ready. Stay tuned :)

    Changelog (2.1.0)

    - sleep suspend fixed( wakeup from USB Remotes / IR remote / Powerbutton )
    - fully renewed audio bitstream system + audio input fix ( show usb audio input devices )
    - Screen settings all on one page
    - aditional VPN/networking config ( IPIP,L2TP,PPP )
    - removed PIN for VPN settings
    - VPN wifi hotspot fix
    - Removed google searchbar from desktop
    - long press menukey to hide/unhide systembar
    - update drivers for future X5 branch
    - recovery show UI + Null pointer fix
    - USB storrage announcements framework renewed
    - wifidisplay / miracast HDCP key integration ( not functional yet )
    - libffmpeg and RKffplayer updated to version 8-12
    - fixed RKexplore app
    - fixed WifiDisplay app
    - Small HLS fix ( not much yet )
    - Updated Gapps ( Google Apps )
    - Google sync issues fixed
    - New kernel logo / bootanimation ( add KAR )
    - a few others

    Old Changelog (2.0.0);
    - recovery/OTA fix
    - static ip bug fix
    - video player/hls fixes
    - security vulnarability fixes
    - init.d support
    - camera brightness fix
    - freeze after uninstall app fix
    - HDMI patch for DRM apps
    - DDR optimalisation ( not overclock )
    - Multi user support ( not fully working yet )
    - Dual input devices frees/crash fix.
    - new kernel logo
    - etc.

    Download link:
    (NOTE this is version "c" with bluetooth fix and network fix)
    If you allready installed the first version of CE 2.1.0 please download the fix under "Available Updates".
    http://www.minixforum.com/downloads/download.php?file=X7_Kitkat_CE_v2-1-0c.rar

    MD5 checksum for included X7_Kitkat_CE_v2-1-0.img: 1db5537fc94cb40ac47024ea95c6cc4c

    WARNING!! WARNING!! WARNING!! NOT EASY TO GO BACK TO 4.2!!
    (You need to use RK flashtool, do not try to flash it like an OTA update.zip !)


    Available Updates:
    X7 CE v2.1.0 - root update
    X7 CE v2.1.0 - unroot update
    X7 CE v2.1.0a - bluetoothfix

    To install the available updates (this is not for the Firmware!) rename the downloaded file to update.zip and place at the internal flash drive root or USB stick root, android will find the update and request you to install.

    From the MINIX Forum Developers Team;
    @gufone
    @KAR
    @HardwareGuru

    Also thanks to the MINIX Engineers, without them we would not come this far!
    Last edited by a moderator: Dec 21, 2014
    Francko76, silverstone, KAR and 10 others like this.
  2. adrian

    adrian Member

    all sounds good thanks for all the work put in by all .... downloading........................(y)
  3. king2deer

    king2deer New Member

    So will i lost all my data?
  4. HardwareGuru

    HardwareGuru Developer Administrator

    Yes.. It will do a factory reset.
    There is no way to prevent that.. Sorry
  5. adrian

    adrian Member

    for the like of xbmc ... just backup to sdcard or something and restore it once done ... nothing lost (y)
  6. king2deer

    king2deer New Member

    Never mind , i can just backup them
    Thanks for fixing miracast btw :)
  7. cumicumi

    cumicumi New Member

    Any trick to make windows 7 sp1 recognize neo x7. No matter hard i try to add driver, but it doesn't work.
  8. KAR

    KAR Developer Super Moderator

  9. adrian

    adrian Member

    had a nightmare with that myself after a format of windows and not having the drivers installed
    at first i let window's do its thing ... NO go
    then i'd downloaded the drivers from rockchip ... installed & rebooted .... NO real go (when trying to put minix into flash mode)
    so in frustration i just pushed to power button to turn minix on ... for some weird reason window's then found the drivers and everything was ok
    once that crap was all done in went into flash mode ok
  10. adrian

    adrian Member

    same setup as EVERY Rom I've ever used (xbmc/kodi backups from last Rom)
    1channel, icefirms, navix, youtube, sportsdevil all work just fine
    Rom speed & netspeed seem good
    pass-through working good on minix xbmc version ... the latest version of kodi rc3 gave problems at first although after a audio default of the settings and then reset for passthrough everything work fine

    it would appear the little click sound is still there when closing down xbmc or leaving minix to sit for a short time after playing any sounds
    (always a good wake up call if the receivers been left up loud :eek:)
    vn800art likes this.
  11. DutchDiversion

    DutchDiversion Active Member

    Hi Guru, Gufone and KAR,

    Thank you for this new version, installed the 2.0 version yesterday and it's working like a charm.
    Scrolling through the changelog I notice the following:

    - fully renewed audio bitstream system + audio input fix ( show usb audio input devices )

    Could you please explain what this means? Does this version have better sound output or is it only the input that has changed?

    Thanks again for all your time and effort, upgrading from HWG 5 to Community version 2.0 was a big step upwards!
    Last edited: Dec 15, 2014
  12. Pemicope

    Pemicope Member

    Thanks guys, good work! (y)
  13. gispi

    gispi New Member

    Thank you very mouch for the new versión.
    in that versión is solved the problem DRM-HDMI for playing videos in diferent app?
    -canal+yomvi in spanish not working video player in old versión 2.0, but working in mali patch 5 vesión.
  14. taki

    taki Member

  15. orcomanno

    orcomanno New Member

    Hello everyone, you can get MD5 checksum
    for the ROM v2.1.0 Community Edition?
    Thanks for the great work
    .... ((y))
  16. Dennis Raul

    Dennis Raul New Member

    Hey (have posted in the Official Firmware Section as well)

    Hi, am facing a weird problem.

    Post Updating to FW 10, the WiFi stopped turning on for some reason.

    Was on FW 08 earlier and it worked just fine, ever since i updated to FW 10 it just wont turn on!

    1. Ethernet works just fine
    2. Have Factory Reset twice
    3. Updated twice

    Hence i wanted to upgrade to this FW but if i try and connect to my PC (Win 7 Pro or Win 8.1 Pro) it wont 'Ding' and connect, no matter how many times i try or how many variations of it

    It will boot in to Flash mode with the various options but refuses to be recognized by my PC's

    1. Have installed drivers locally on both machines using NEO Driver Assist
    2. Uninstalled and tried again to no avail

    Help!

    Dell XPS M1530 Win 7 Pro
    Lenovo Z580 Win 8.1 Pro
    Minix X7 16 GB (Current FW - Official Ver. 10)
  17. DutchDiversion

    DutchDiversion Active Member

    Hi Dennis,

    I had the same problem and it worked when I set my USB mode to 2.0 only in the bios of my laptop.
    Then started the Flash tool as administrator and it worked.

    Seems to be a problem with USB 3.0, atleast on my laptop.

    Hope this helps.
  18. Dennis Raul

    Dennis Raul New Member

    I tried it in my XPS which has no USB 3.0 and still faced the same issue.

    Let me try using the Flash tool in Admin mode.

    Thanks !


    Sent from my iPhone using Tapatalk
  19. Higgs

    Higgs Yellow Dude Super Moderator

    Make sure you are using the micro usb cable that came with the box. It has a longer metal connection. Standrad micro usb cables (e.g. phone charging cables) may not work.
  20. Dennis Raul

    Dennis Raul New Member

    I am, used the OTG cable that came with the box ( Long Male OTG to USB Female)

    Although it's connected to a Male to Male USB Cable.

    I did manage to get it to show up in the Windows Device Manager > Manage section as an Android ADB Device

    Although it came as Hidden for some reason


    Sent from my iPhone using Tapatalk
Thread Status:
Not open for further replies.