1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Custom ROM X7 Kitkat v2.2.0 Community Edition

Discussion in 'NEO X7 Custom ROMs, Kernels & Discussion' started by HardwareGuru, Feb 2, 2015.

Thread Status:
Not open for further replies.
  1. bubbadk

    bubbadk New Member

    Yes. But when I use that method and I try to go to flash mode. It goes straight to cwm. Or am I doing something wrong.
  2. Lansen Walraet

    Lansen Walraet New Member

    If you are in win 8.1 use rk android tool, rk flashtool doesn't work.
  3. bubbadk

    bubbadk New Member

    I got it. Used android tool. Thank you
  4. Trekie2

    Trekie2 New Member

    Thanks guys for this incredible firmware!!!!...was about to give up in my X7 with the stock 010 firmware...this is so much better, great work and I can't say Thank you enough!!!!!!!

    I do want to add to the HDMI Bitstream issues others have spoken about in this forum....when I was on stock 010 firmware and running SPMC I could get 5.1 surround out of the HDMI port, but now with this firmware and SPMC all I get is two channel. I run my X7 into my receiver through HDMI...I have selected HDMI Bitstream from the Android setting menu not the Rockchips as it has no selection for HDMI Bitstream or Pass through....so none are selected...all left blank. I use Pass through in SPMC and enable both the DD and the DTS options. All I have been able to achieve is Stereo, mind you I have had none of the sound drop offs others have stated.

    So if anyone can get it working please post how....and if it's a known bug and being worked on by you firmware gods I will patiently await!!!

    Thanks again guys for the best firmware ever!!!
  5. fefo.gautier

    fefo.gautier Member Beta Tester

    Hello HG. Are we going to receive an OTA update soon regarding what you commented I February? Thank you so much.

    Send using v975m
  6. avgust

    avgust New Member

    Hi,

    How to modify CPU GPU DDR clocks setting (I would like overclock them)?

    In QS3 many ready OVERCLOCKS kernels were ready for use, I'm wonder if those kernels can be used in CE 2.2.0?

    P.S: I hope its a right thread to for this question :)
  7. fabeer

    fabeer New Member

    +1 for me,very very good job on this firmware!Fast,not buggy
    ligue 1 orange,M6 replay works fine.

    Keep up the good work guys!congrats
    HardwareGuru likes this.
  8. HardwareGuru

    HardwareGuru Developer Administrator

    Next release is schedulled on next monday.
  9. Antoine

    Antoine New Member


    So I did re-install MX player and his codecs with the same result. I undertood that I wasn't able to use HW+ decoding due to license issues on A3C and DTS (no sound). But finaly I used an old codecs version which was still supported these and now everything is fine. I just needed to use HW+ decoding!
    HardwareGuru likes this.
  10. kaan

    kaan New Member

    Hello everyone, i was wondering if anyone is having trouble trouble Setting up the QWERTZ Keyboard Layout for a logisch k400. Also i would like to mention that some pay tv apps (like Sky in Germany) are limited to only so much devices. Once you flash the minix, the dvice ID changes and you have to reset the List of reg. Devices in your Sky Account. This can only be done once every 60 days. So changing the device ID every time you flash the image sucks. Thus, making OTA updates even more important.
  11. HardwareGuru

    HardwareGuru Developer Administrator

    We dont provide overclock kernels, sorry.
    Replacing the kernel is not easy to do on this firmware.
    Our kernel is included into the boot image, QS has a seporate kernel.
    Unless you know how to unpack the boot, convert the QSkernel to a zImage, replace the kernel and repack all it will not work.
    * Nope... i wont teach how to :D.. as i have better things to do :whistle:

    HWG
    avgust likes this.
  12. HardwareGuru

    HardwareGuru Developer Administrator

    The default layout for external keyboards is QWERTY, there can just be one preset available unless we replace the keylayout and it changes for everyone. ( wich we will not do)
  13. otchill

    otchill Member

    hi guys,

    it is very good news to hear you that next monday new edition will be released. I hope that you could fix 1080px60 and some sounding match problem..

    thanks again..
  14. HardwareGuru

    HardwareGuru Developer Administrator

    We will release a seporate kernel for the few people having HDMI flicker issues, the 1080i(interlace) will be gone, but the HDMI flicker is solved properly without overclocking chips like they fixed it on other roms.
    NOTE; it will be a seporate patch to apply besides the OTA for the few that are having this issue ( x7 and X7mini ).
    avgust and MaxeL like this.
  15. Trekie2

    Trekie2 New Member

    You guys looking into the HDMI Bitstream not outputting 5.1?

    Again, thanks guys!!!
    Last edited: Mar 21, 2015
  16. meanmoose

    meanmoose New Member

    Hi guys,

    I cannot seem to get my minix to connect to the computer. The video speaks of the "micro usb cable provided". I've lost that. Is there a way to flash without this cable or if I can purchase this cable separately?
  17. Villa

    Villa Trusted Helper Super Moderator

    Do you not have another micro USB cable you can try?

    So long as it is a data type and not a charging type, it should work. The MINIX cables have a slightly longer micro USB connector but that shouldn't matter. I have used other cables just fine.
  18. meanmoose

    meanmoose New Member

    If its not a USB cable problem then I dont know why.. Its running finless ROM. In bootloader mode as well.
  19. Villa

    Villa Trusted Helper Super Moderator

    I don't understand! If what, is not a USB cable problem? You said you have lost the cable!
  20. meanmoose

    meanmoose New Member

    I have micro USB cables lying around, just not the original long one that came with it. Followed the other instructions but the computer didn't recognise the minix.. I assumed that perhaps the one I'm using is too short? or if theres something special about the cable that it came with since the video mentioned that you had to use that one.
Thread Status:
Not open for further replies.