1. Welcome to the official forum for MINIX devices!

Custom ROM X7 Kitkat v2.2.0 Community Edition

Discussion in 'NEO X7 Custom ROMs, Kernels & Discussion' started by HardwareGuru, Feb 2, 2015.

Thread Status:
Not open for further replies.
  1. Higgs

    Higgs Yellow Dude Super Moderator

    This might help;
    How to trim off some plastics to ensure perfect contact:
    vn800art likes this.
  2. Villa

    Villa Well-Known Member Super Moderator

    I said the cable has to be a data cable and not a charging cable. They all look alike. All you can do is try all that you have.

    And what Higgs suggests as that has worked for others. But it still needs to be a data type.

    I personally have never found a problem with a shorter connector.
  3. meanmoose

    meanmoose New Member

    It transfers data from my computer to my nexus 7. I assume its a data cable then?
  4. Villa

    Villa Well-Known Member Super Moderator

    Sounds good!
    If it doesn't work try Higgs suggestion.

    Charging type are usually supplied with BT speakers and the like.
    HardwareGuru likes this.
  5. Angelo Calvo

    Angelo Calvo New Member

    Thanks, for your work, i'm waiting for it , because we cant use skype since upgrade. I need your help, who can i move apps to a 32GB SD card that i just bought ? Regards have a nice week end.
    Last edited: Mar 21, 2015
  6. HardwareGuru

    HardwareGuru Developer Administrator

    @ TestCrew;
    CE 230 prerelease is available in Beta section
    Smallgent and Andrea Borgia like this.
  7. hollywoodfrodo

    hollywoodfrodo New Member

    Help! I think I bricked my Minix X7. I has never updated the firmware before so it was on whatever it originally shipped with. Here's what I did: Windows 7, Downloaded and unzipped rar file with no problem. Installed Driver - no problem. Started flash tool - no problem. Put Minix in Flash Mode - Computer detected - no problem. But I missed the part about "restoring" and not "updating" so I "updated". The process completed and then after that when the Minix restarted it got stuck on the minix logo screen - never changed.

    So I did some more research and realized I was supposed to use restore. So I unplugged the minix power supply - plugged it back into my computer - reattached power - put it into flash mode. The RK flash tool recognized it again with no problem. This time I used RESTORE. The process completed successfully with no problems or errors.

    When my minix restarted, the same thing happened - stuck on the minix logo screen. I tried removing power then plugging back in and restarting but it still gets stuck on the minix logo screen and will not pass that screen.

    Hoping someone can help me get it working again - I'm sure there's gotta be a way. But I'm at a lost. Right now I just have a little square brick that I can't do anything with. Thanks for any help!
  8. Trekie2

    Trekie2 New Member

    Well I am no expert and there are far smarter individuals here to answer...but I can tell you that when I updated mine and restarted it....it took like 10 minutes for it to come back up....but that was only on the first power up since the update...when I was running 010 firmware it was a mess, slow and if froze constantly...so I was not surprised that it initially took so long to restate after the flash to CE Edition....but after that it boots way quicker than it used to.

    So how long have you left it plugged in after the flash?....try again and give it some time....other than that I am sure some of the people here will be able to help....lots of smart individuals here....and if it does come up, enjoy it as the CE Edition will make your X7 the box it should be....
  9. m6242

    m6242 Active Member

    Try again and if this don't work, I remember the following:

    1. Power off your device
    2. Connect your Minix with OTG cable and your pc.
    3. Hold and press power button and press the hole with a paperpin (hold it pressed (both) all the time)
    4. Now press restore in RK flashtool (yes you need another Person or a third hand)
    5. While flashing keep power button and the pin pressed all the time (your hand will hurt).
  10. hollywoodfrodo

    hollywoodfrodo New Member

    Okay, m6242, just for the sake of argument, I tried it your way, though I don't think holding the pin and power button in the entire time is necessary. When you press the pin and power button together for 3 seconds it puts it into flash mode and it stays in flash mode until your done without the need to hold them for the entire time. I did it anyway, just to try it and the results are the same.

    After flashing the firmware via the RK Flashtool, when the Minix boots back up, I get the following messages which maybe will help someone help me figure out what to do. My screen cuts off the first few letters so I'm not sure of them...
    issing bitmap stage_empty
    de -1
    issing bitmap stage_fill
    de -1
    overy system v4.4.0

    ailed to mount /metadata (Invalid argument)
    ailed to mount /mnt/external_sd (No such device)
    ailed to mount /mnt/external_sd (No such device)
    ailed to mount /mnt/external_sd (No such device)
    one_data_if_exist->can't find databk partition
    matting /data...
    matting /cache...
    matting /mnt/internal_sd...
    ooting...

    After that, it starts to boot and gets permanently stuck on the minix logo screen. I have left it there for at least 20 minutes (sometimes longer) each time. It just stays stuck on that screen.
  11. hollywoodfrodo

    hollywoodfrodo New Member

    Also, if it helps, I am able to boot the device into the Android Built in Recovery System if there's something I could try to do through that system...
  12. moiloon

    moiloon New Member

    hi can anyone help, ive gone from the last official x7 firmware jelly bean, to this version
    my problem is I im now getting terrible buffering issues, and now I get bad artifacting when tryin to watch live streams.
    can anyone help me to resolve this
    if I cannot resolve, can I just refash minix official last jelly bean 4.2.2?
    as before I was using this rom I had no trouble with the streams and no artifacting

    hope someone can help me out on this as im no expert, but tried nearly all settings in kodi, and in android settings
    which changed nothing
    I still cant watch a thing
  13. m6242

    m6242 Active Member

    Look here: http://www.minixforum.com/threads/unbrick-x7-the-x7-is-never-dead.500/
    If you can see your Minix in RK Flashtool as a device I think it is not bricked.
    Do you checked the MDsum of your firmwarefile, if it is correct?
  14. hollywoodfrodo

    hollywoodfrodo New Member

    Nope - I didn't check the MDsum - wasn't 100% sure how to... If you can give me instructions, I'll try - maybe that's the issue. Yeah, I don't think it's totally bricked since it does show up in Flash Tool and I can boot it into Android Recovery, but I can't get it to actually boot up so it's semi-bricked, I guess. Thanks for your help.
  15. m6242

    m6242 Active Member

    There are quite some cool search sites out there (y). Google e.g
    Try this one: http://www.winmd5.com/
    Just select the Firmware file an compare the Md5 Checksum. If it is the same, you have downloaded it correctly.
  16. Villa

    Villa Well-Known Member Super Moderator

    Do you mean so that they run from the SD card? That is not possible!
    If you root your device you can use an app called FolderMount to mount Internal SD folders to your External SD or USB.
  17. nthemaster

    nthemaster New Member

    It will happen today the update?
  18. hollywoodfrodo

    hollywoodfrodo New Member

    @m6242 - haha - yeah, I guess I was being lazy. So I have good news - I finally got it to work! Even though I didn't check the MDsum, I figured I should maybe try re-downloading so I did. Then I noticed that unlike before when I put my minix in flash mode it would drop out of flash mode after a few seconds so I had to do the thing where I held the power button and pushed the flash button w/a paper clip the entire time I was updating, but... it worked!!!

    Thanks for all the help!
    vn800art likes this.
  19. HardwareGuru

    HardwareGuru Developer Administrator

Thread Status:
Not open for further replies.