1. Registration issues have now been resolved. New accounts are able to be created

Official Release X7mini Kitkat 240 ( june 4th 2015 )

Discussion in 'NEO X7 mini Official Firmware Releases' started by HardwareGuru, Jun 4, 2015.

  1. Geovanny Reza

    Geovanny Reza New Member

    hello i have a problem with my minix as it restarts every few minutes and suddenly does not work and does not turn I can do
  2. letterale

    letterale New Member

    I have probably a similar problem: after upgrading everything seems to work fine but I have randomly reboot.

    Essentially freezes the screen briefly and then Minix Neo Mini 7 restarts. This problem happens with different internet browsers (it happens through the pages up or down) and Kodi (watch a movie in full is impossible).

    I ask: is there any control I can do? Is there any log to look at? What I can do to try to solve?
  3. Lanzalad

    Lanzalad Member

    I've just tried to update a minix 7 mini that was running on 230 and I tried many times on wifi and ethernet and i've done a full restore and tried to clear out the cache on the system up date.

    But i just seam to get this every time:-

    Screenshot_2015-10-06-00-14-13.png

    Screenshot_2015-10-06-00-14-40.png

    Screenshot_2015-10-06-00-14-51.png

    So i downloaded the 240 update and renamed it update.zip and placed it onto a formatted USB stick.

    File name downloaded :- x7mini-rk3188-OTA-240.zip

    Turned off the minix box then Inserted the USB into the minix box and rebooted and i just get this again and again...

    Screenshot_2015-10-06-00-40-44.png

    Screenshot_2015-10-06-00-41-01.png

    So then i turned off the wifi and ethernet and rebooted the box and waited.... and nothing happened so then i turned off the box and changed the USB slot on the box and waited and nothing...

    So as i've said i did a full system restore without any backup to clear out anything that may be causing a problem and i looked at your thread and wondered if i place the file on the internal SD it would work to find out that i was out of space but i had just done a full restore ...!

    Screenshot_2015-10-06-01-00-18.png

    I also found the following files on the system "update-minixforum.zip" and the "update-minixforum_tp.xml"

    Screenshot_2015-10-06-00-59-59.png

    Should or would the files here be stooping the OTA update..? do i need to delete them..?

    So in the end i downloaded the flash package and used the pc to do a full system format and install.

    After setting it up and clicking on "RESTORE" and it seems to have worked just leaving the box for 10 minutes then i'm going to do a reboot.
    Last edited: Oct 6, 2015
  4. verticalj

    verticalj New Member

    Hi,

    I just did the fresh install to get the new firmward and everything looks ok but the screen keeps flickering. It happens more often when i'm in the google play store, but in other apps as well.

    Model: NEO-X7-mini
    Android version: 4.4.2
    Vendor SW version: 240

    I read that there was a hdmi flicker patch for 230, is it applicable to 240 and how do i go about installing it?

    Thanks
  5. Villa

    Villa Well-Known Member Super Moderator

    HDMI flicker patch: http://www.minixforum.com/downloads/download.php?file=X7mini-CE-HDMI-FlickerPatch.zip
    NOTE: this is not for everyone!, just for the few that have incompatable TV's and have screen flicker at 1080p60/50

    To install the available updates (this is not for the Firmware!) rename the downloaded file to update.zip and place at the internal flash drive root, android will find the update and request you to install.
  6. verticalj

    verticalj New Member

    Thanks Villa!
  7. Phoenix409

    Phoenix409 New Member

    i've updated my machine about 3 months ago, update went smooth. and the minix seems to work fine and better. except the portable hotspot. the minix is connected to the internet through Ethernet.
    when i turn the portable hotspot, the WIFI on other devices(iPad,smartphones) is so slow it's unbearable. nothing loads.

    before the update, everything was fine.

    help?
  8. letterale

    letterale New Member

    For people like me who has continuous random reboot after the upgrade to version 240 or 230, I recommend you do a downgrade to firmware NEO X7 mini 011 (June 2014).

    To downgrade you have to start from a fresh installation of NEO X7 Mini 006 firmware (12th September) - you need to use the flashtool on a PC to flash it - and then upgrade to version 011 by OTA.

    The download file .zip for upgrading to ver. 011 in the forum minix is no longer available (in its discussion on the download link is broken). I have downloaded the upgrade to 011 from here:
    http://itcast.eu/tag/neo_x7mini_20140614_011-zip/

    Now I finally solved the problem concerning the random reboot and my NEO X7 Mini works well.
  9. Villa

    Villa Well-Known Member Super Moderator

    The link is now fixed!
  10. alsaliho

    alsaliho New Member

    Dear friends, first of all, thank you for the awesome device you built. It is a really nice HTPC alternative and serves its purpose well for more than a year (I bought it almost as it came out and never regretted it). YouTube for kids, streaming from my Dreambox from other room (of course via Ethernet), as well as from my other HTPC. This latest update is great, everything works as it is supposed, this latest issue has even solved full-HD playback issue with content streaming from Dreambox. Built-in stuff works like a charm, as usual.
    However, one of the reasons I decided to join in on this forum and write something is an update procedure via BatchTool. These is an issue with recognizing the drivers when using latest Windows editions. After putting the device in service mode, I had trouble getting it to work. First it was my Dell XPS with Windows 10, 64 bit edition. Whatever I did (and considering that I am an IT guy myself I tried bunch of stuff) , I would end up getting yellow warning in device manager Code 41 and message that device has been halted, because failed driver load. No luck even after doing manual install of drivers which were provided in the package. Probably no need to mention that BatchTool was not able to recognize device. Then I went Google and there were suggestions for some workarounds, some even included options like replacing sys files which were related to USB, as the problem was mostly identified as an USB issue. Since I was not in the mood to mess up perfectly fine working legal copy of Windows, I went and tried doing the same thing with my daughter's netbook - this one running Windows 8.1 32bit edition. Almost identical error. I lost more than 2 hours and almost gave up.
    Then I remembered that my former update had an issue with Windows 8 (o11 version), so I took the whole thing to my work, where I immediately had success with flash on Windows 7 X64 machine. Everything done in 10 minutes! Then, for the sake of measure, redid flash on Windows 7 X32 machine. Success again.
    I've gone through this thread, and I have noticed that some people were complaining about this as well, but they were getting answers that no one in support came across similar issue. There is definitely an issue with this, and I would be very grateful if this issue could be solved. Flash procedure is already well complicated for majority of users. Cheers.
    Marios-x90 likes this.
  11. Villa

    Villa Well-Known Member Super Moderator

    @alsaliho It is fairly common knowledge that the BatchTool does not work on the newer Windows versions and that Windows 7 or earlier is recommended.
    There are workarounds that some Members have had success with!
  12. alsaliho

    alsaliho New Member

    Thanks for that, do you happen to know by any chance that will be corrected soon, as this really a drag? I mean, I am not a "spoiled brat", I can live without OTA, but this is becoming an issue as in year or so, it will be hard to find a machine which has not upgraded, especially having in mind that Win 10 upgrade is free.


    Sent from my iPhone using Tapatalk
  13. Villa

    Villa Well-Known Member Super Moderator

    I do not know! I presume it's a matter for Rockchip.
  14. alsaliho

    alsaliho New Member

    Thanks for the explanation, but it is not the one I wanted to hear. But anyway, I hope that they will get it soon. With free of distribution of Win 10, within year or two we might end up with shortage of available hardware to use, which leaves as only with OTA. But I hope that they will get it by then. Thanks again anyway mate.
  15. Noct

    Noct New Member

    Ever since upgrading to 240, my x7 mini keeps changing the HDMI video output to 1080i. I change it back to 1080p (TV's native res), but inevitably it changes itself back.

    It seems to happen when the device is left idle, so I disabled sleep and daydream, but it didn't help. I am now thinking that something went wrong while flashing the new OS, so perhaps I should redo it... but that would be a significant inconvenience.

    Has anyone else encountered this, or have any ideas?

    Also, I'm getting audio stutters when using HDMI passthrough in Kodi, but I suspect it's a problem with Kodi.
  16. Konstantin one

    Konstantin one New Member

    Hi friends,aftereveryrebootthere is a barat the bottom of the screen, how to dothatby default? Prompt me please, how to installTWRP onminixx7mini.

    instaled X7mini Kitkat v2.2.0 Community Edition
  17. Marios-x90

    Marios-x90 New Member

    Hello mod's and guys ...
    Happy new year to all...
    This is my first post ,i'm Marios and am from Cyprus,how you all doing ???
    i just bought my MINIX NEO x7 mini...I'm not an expert on this so before i make anything not necessary i will like to ask you if i need any updates at all,because all this numbers is confusing...
    This is my numbers/model/version/software...

    Model number : NEO-X7-mini
    Android version : 4.2.2
    Baseband verion : Unknown
    Kernel version : 3.0.36+ neilnee@ubuntu#1 Wed Jun 11 11:36:08 CST 2014
    Build number : JDQ39
    Vendor software version: 2014-06-12.4.2.011

    Thank you all in advance...
  18. Villa

    Villa Well-Known Member Super Moderator

    You have Jelly Bean Android 4.2.2 Firmware v011
    Latest is KitKat Android 4.4.2 Firmware v240
    Check this out...
    http://www.minixforum.com/threads/h...irmware-for-minix-x7-mini-x7-x5-mini-x5.5230/
    KAR and Marios-x90 like this.
  19. pogs109

    pogs109 New Member

    Is there a 8G app space patch/update for this Firmware?
  20. Nebula

    Nebula New Member

    Hello!

    I have device minix ne0 x7 mini (flashed X7mini Kitkat 240 firmware) and I want to connect to it USB Wifi adapter on Ralink rt5370 chip. I found kernel source and driver source, build (cross compile whith arm toolchain) the ko module. But system reboot right after insmod.
    I try insmod any existing ko in folder /system/lib/modules - the result is the same - system reboot.

    what am I doing wrong?

    Thanks in advance for your reply, I apologize for the awful English...