1. Welcome to the official forum for MINIX devices!

Official Release X7mini Kitkat 250 ( february 8th 2016 )

Discussion in 'NEO X7 mini Official Firmware Releases' started by gufone, Feb 8, 2016.

  1. LebArmy75

    LebArmy75 New Member

    Hello :)

    We have a 3M (the manufacturer) touch screen I would like to use with a Minix. I thought of using an X7 mini, which will be enough I think, but I don't know if this build will support the USB touch screen? I have been on their website and I can see they have a kernel patch (for Android 4.0, 4.1, 4.2 and 4.4) ; if as is the ROM/the kernel doesn't support USB touch screen (and especially that one), am I able/allowed to modify the kernel in the ROM to integrate it HardwareGuru? In the latter case, how do I proceed to rebuild the kernel?

    Thank you for your help :)
    Last edited: Jun 16, 2016
  2. Laszlo Homola

    Laszlo Homola New Member

    How can I install driver for Win 10 64 bit please? There are win 7 and win 8 drivers only under 64 bit.
  3. midnight

    midnight Moderator Moderator

    I don't believe it is possible yet for 10 .....need to use an older version of windows:(
  4. Villa

    Villa Well-Known Member Super Moderator

    midnight likes this.
  5. Laszlo Homola

    Laszlo Homola New Member

    Finally I have made the upgrade by a win 7/64 laptop. :) And the result is dam good!!!!

    This upgrade works extremely well on my Neo mini 7, it is stable, fast, PERFECT!!
    MANY Thanks to the team!!!!
    midnight and Villa like this.
  6. ig0r

    ig0r New Member

    Is it possible to make all 8Gb flash as single partition ?
  7. bastik

    bastik New Member

    Hello from Spain!!
    I have a Minix x7 Mini with the nitroteam firmware 4.2.2 since i bought it, long time ago.
    I think now is the time for update. I change the TV and now i think the real 1080p would be a good improvement.

    I read the first post but i can't understand why i have to do for update this official firmware from my nitroteam firmware.

    Can anyone help me and write me the instructions??

    Thanks
  8. MagicFeather

    MagicFeather New Member

    I can't seem to get it rooted. Moving the file with the ES File Explorer doesn't work because I can't access the internal flash drive, because I don't have the permission. Moving it to the external flash drive gives me a error when it's trying to install the update, it tells me the it external drive is unmounted.

    What am I doing wrong :(?
  9. HardwareGuru

    HardwareGuru Developer Administrator

    An x88i will work with touchscreens ( corporate minix hardware ). Pleaae PM me for info and do not discuss this model here as this is a consumer forum.
  10. HardwareGuru

    HardwareGuru Developer Administrator

    If it runs good dont change a thing i allways say.. ;)
  11. HardwareGuru

    HardwareGuru Developer Administrator

    Run a factory reset before update.. if that does not work something else is going wrong and you can try flashing it again with pc tool.
  12. ahkit

    ahkit New Member

    after upgrading to this firmware i notice the output interface left 2 options only which is
    1920x1080p-60 and 1280x720p-60.

    How can i enable the rest of the resolutions? my tv only support 420p the older firmware that i have I'm able to yse 420p.
    Please help.

    Thanks.
  13. gavenkoa

    gavenkoa New Member

    I upgraded firmware to this one via VirtualBox + WinXP. Under Linux I got VID/PID:

    usb 2-1.1: unable to get BOS descriptor
    usb 2-1.1: New USB device found, idVendor=2207, idProduct=310b


    and passed this USB device to guest WinXP. I had to connect this device and

    usb 2-1.1: Product: USB-MSC
    usb 2-1.1: Manufacturer: RockChip
    usb 2-1.1: SerialNumber: 㘰丰估䬰㠰㤰㤰倰
    usb-storage 2-1.1:1.0: USB Mass Storage device detected
    scsi host13: usb-storage 2-1.1:1.0
    scsi 13:0:0:0: Direct-Access RockChip RKSOC 1.00 PQ: 0 ANSI: 0


    several times while RKBatchTool waited for appearing these devices. If you delay passing USB devices to guest OS RKBatchTool fail at corresponding step.
  14. ulticomp

    ulticomp New Member

    Hello Everyone, I am a newby with a Minix Neo X7 Mini 8GB, with a Minix Neo A2 remote control and the original remote that came with the Device.

    I have traveled and have decided to give the device to my brother in Italy. Upon arrival, I discovered that it was not working. Initially it was not starting and not being recognised by my laptop. We eventually got it to start. The A2 remote would not work wit/ pair with device. It works everywhere else, on my laptop, and the TV. In my attempt to get things to work, installed Kodi 16.0 Jarvis, but this did not work well so I reverted to an older version of Kodi.

    Everything was OK except for the A2 remote which could not be detected by my Minix. I found a link on how to flash the box so that it would be would be recognised b my laptop. I downloaded the firmware update http://www.minixforum.com/downloads/download.php?file=x7mini-rk3188-250.rar. This did not work, I did the registry thing and that worked. I beleive I followed the instructions and had to revert to an older Kodi again.

    The A2 remote still does not work. The various displays I get look strange and Kodi does not work as it did before. I would like to start over again.

    Is there an update for windows 10 users? and an easier to follow video?

    Sorry for such a long story, just suffering with this issue:coffee::coffee:, and would love any additional assistance:sick:
  15. gavenkoa

    gavenkoa New Member

    Is there an update for windows 10 users? and an easier to follow video?

    For Windows 8/10 (or Linux) users I may suggest flashing MINIX via VirtualBox.
  16. ulticomp

    ulticomp New Member


    Thanks for your reply gavnkoa, but I don't know what you mean by "via Virtual Box"
  17. Villa

    Villa Well-Known Member Super Moderator

    VirtualBox will allow you to run Windows 7 (or other OS) within Windows 10
    https://www.virtualbox.org/wiki/VirtualBox
  18. Villa

    Villa Well-Known Member Super Moderator

    If you follow the Hint for Win 10 users here then you shouldn't have a problem!
    http://www.minixforum.com/threads/h...irmware-for-minix-x7-mini-x7-x5-mini-x5.5230/

    Here is an alternative tutorial video...

  19. ulticomp

    ulticomp New Member

    Thanks Villa and others!

    Just want to clarify, the video in the link referred to minixcomhk I am unable to get to that. I am suspecting this has changed. I work through and eventually download the following frmware:

    Is this correct and or the latest firmware?

    Also, does anyone have any idea why I am unable to connect my A2 remote?
  20. Villa

    Villa Well-Known Member Super Moderator

    You can still get to MINIX http://minix.com.hk
    ...but now this Forum is where they will lead you back to for MINIX Support.

    The firmware is in Post #1 of this thread!

    This is it...
    Download link (to be used for a Fresh install or pre CE210 versions)
    http://www.minixforum.com/downloads/download.php?file=x7mini-rk3188-250.rar
    (drivers and Flashtool included)

    Have you inserted the A2 USB dongle?