1. Welcome to the official forum for MINIX devices!

Official Release X7mini Kitkat 250 ( february 8th 2016 )

Discussion in 'NEO X7 mini Official Firmware Releases' started by gufone, Feb 8, 2016.

  1. ulticomp

    ulticomp New Member

    Thanks for the advise will have a go shortly.

    Yes, USB dongle definitely inserted.
  2. ulticomp

    ulticomp New Member

    Thanks Guys, I am all setup now!

    I followed the process as instructed. It did not quite go exactly as in the video but I worked it out.

    Now I am left with the A2 remote issue. Does anyone know how to re synch it?

    Thanks again!
  3. Villa

    Villa Well-Known Member Super Moderator

    Fn+P
    And after that if it works again but drifts then use Fn+Y. Read the Air Mouse Re-alignment Instructions for this!
    http://www.minixforum.com/threads/instruction-leaflet-neo-a2.6771/
  4. baderks

    baderks New Member

    Hallo Minix,

    Some years ago, I bought myself a Neo X7 Mini player. I put it aside for its limited remote control functionality and because it internally only worked at 720p. Recently I came across your latest firmware and I installed it on my X7 Mini, not only for the fun of it, but also to have a alternative player available.
    I'm impressed by the fact that the firmware for the X7 Mini is still being maintained and that it now works internally on 1080p. After reading through the X7 [Mini] forum posts, I got the impression that the X7 Mini remote control functionality was extended to include the basic media player commands like play - pause - stop etc. I re-programmed my Logitech Harmony 350 remote control and I notice the now available extended command set for the Neo X7 Mini. Before I flashed the remote control with this new extended X7 Mini command set, I linked the back-button to the Return function and the exit-button to the Home function. To my disappointment, none of the extra buttons are working. The original stock buttons work flawlessly, including the reprogrammed back-button and exit-button. To make sure that the problem was not my remote I also added the X5 and X7 definitions to my remote with the same result. To be sure I did not overlook something, I started reading more and more about remote controls and Minix devices on the internet. Unfortunately there is not much available for the X7 [Mini] as the original (unofficial) forum has been taken down. Over and over I was directed to the now missing post "how-logitech-harmony-remote-owners-can-map-more-buttons-for-their-minix-neo-x7.3126". (Sorry, I'm not allowed to give the full URL to this post. Maybe you could add a copy of this post on the current forum as a guide.)

    Still looking to solve this issue, I followed some of the suggestions I found on the internet. To my surprise there is no /system/etc/remote.conf file available in this firmware. The same is true for the essential utility /system/bin/remotecfg. Lacking both files could explain why the Remote Control is not behaving as expected. Question is: why are these two files missing in the X7 Mini firmware, as both files are part of the normal Android distribution. Is it by design or is this an omission error. I did find the file /system/usr/keylayout/rkxx-remotectl.kl. This looks like to be the standard key layout file for the X7 Mini, although I'm not sure as the /system/etc/remote.conf file is missing to check this out.

    Please help me out to solve this remote control issue. The easiest way looks like to make the 2 (3) missing files available for direct downloading or offer a patch file (update.zip) for it. If there is an other way to solve this issue, please instruct me so I can enjoy using the X7 Mini at its full potential with my Harmony 350 remote control.

    TIA, Baderks
  5. Laoyao64

    Laoyao64 New Member

    Dear all,

    I need help.

    My Minix Neo X7 mini stucked at MINIX screen after boot up. I wanted to reflash firmware and downloaded the driver and firmware from link below.

    http://www.minixforum.com/downloads/download.php?file=x7mini-rk3188-250.rar

    I was able to load the driver using my laptop running Windows 7.

    When I used the RkBatchTool 1.8, I could complete steps 1 to 3 below. But when I did step #4 and selected the img file (firmware) in FW Path, it displayed Loading Firmware and hanged there. So I can't click the RESTORE.

    May I know what's the problem and looking forward to your advice.

    1) Start the flashing tool utility (run the file “RKBatchTool–1.8.exe”).
    All the connected devices should be in gray color.

    2) Now you need to bring the Minix into flash mode. Use a paper clip to insert into the reset hole of the Minix. Hold it down and in parallel plug the power cord, keep the paper clip there for 3 – 5 seconds. Take out the paper clip. You’re supposed to hear a ding sound from the connected PC. That means the Minix is now in flash mode and ready to be flashed.

    3) On the PC, in the RocketChip flashing utility, you’re supposed to see a
    green square in the connected device frame (representing your Minix).

    4) In the RocketChip flashing utility, in the “FW Path” choose the image file which you downloaded

    Thanks
  6. gbaker72

    gbaker72 New Member

    After attempting to update my device it says: Vendor Software Version 2015.12.18-250
    Is this the latest version? It has 250 showing, but 2015?
    Should it be 2016.08.02-250?
    Did I not do this correctly?
  7. Villa

    Villa Well-Known Member Super Moderator

    It is correct! (y)

    The date a thread was created bares no relevance to the date of the firmware.
  8. gbaker72

    gbaker72 New Member

  9. Bizz

    Bizz New Member

    I've been using my X7Mini since they first came out and a few months ago updated to this firmware and all was good. I now have a very strange audio sync problem which affects Youtube and BBC iPlayer. I have a digital optical cable connected to my AV receiver and the sound device set to SPDIF passthrough, this setting always worked and i no sync issues at all. Now sometimes the audio is in sync to the video and then for no reason it will shift and the video is ahead of the audio. After lots of messing around I have found that if I go in to the sound settings and set output to HDMI it goes back in sync, I can change back to SPDIF and that too will be back in sync. If I fast forward through a Youtube playlist of music videos it will all of a sudden go out of sync again and I have to set to HDMI and back again to make it work. BBC iPlayer also is affected and the HDMI setting change works for that too.

    Any ideas?

    I'm sure I was a member before but had to register again as my email address was not recognised.
  10. Villa

    Villa Well-Known Member Super Moderator

    The Forum was changed/made official around August 2014 which meant everybody had to re-register.
    Unless you've been back since then, that would be the reason!
  11. Jazzzhead

    Jazzzhead New Member

    Hi Guys,
    Just downloaded and flashed "x7mini-rk3188-250.rar"(as per your instructions) in a bid to fix audio dropout in my kodi build. All went well as expected and reported as "successful". Disappointingly on first boot of X7 mini, It looped back to boot screen continually about 10 seconds into boot. Occasionally it will boot to the Minix Launcher, but is very unstable and crashes back to re-boot randomly, and then the cycle starts all over again....only reaching Minix launcher every 5 or 6 boot cycles.

    Is there any way I can fix this....as it is now unusable. Thanks in advance. :)
  12. burning

    burning New Member

    Hi,
    I have a problem after I flashed 250 version. The wifi don't work. I enabled the wifi but the scan button is grey. Bluetooth and Ethernet work. What is the problem? I flashed a different firmware? I have a minix neo x7 16G. Thank in advance guys.
  13. Higgs

    Higgs Yellow Dude Super Moderator

    Do you have the X7 or the X7 mini? You say X7 but you posted in the X7 mini section.
    Reflash the correct firmware for your device.

    Sent from my MotoG3 using Tapatalk
  14. Stephan1983

    Stephan1983 New Member

    Hello Guys,

    I have a question.
    My mother in law has a Minix X7 Mini, but it got stuck on the Minix Bootlogo forever. Nothing works to pass that.
    So i wanted to update it and hopefully i could solve the bootlogo problem with it.

    I downloaded everything and done it as said in this topic, but it won't work.
    This is the report i got:
    **********Restore Action**********
    **********Restore Start Total<1>**********
    <Layer 4-1> Test Device Start
    <Layer 4-1> Test Device Success
    <Layer 4-1> Lowerformat Device Start
    <Layer 4-1> Lowerformat Device Success
    <Layer 4-1> Test Device Start
    <Layer 4-1> Test Device Success
    <Layer 4-1> Check Chip Start
    <Layer 4-1> Check Chip Success
    <Layer 4-1> Get FlashInfo Start
    <Layer 4-1> Get FlashInfo Success
    <Layer 4-1> Prepare IDB Start
    <Layer 4-1> Prepare IDB Success
    <Layer 4-1> Download IDB Start
    <Layer 4-1> Download IDB Fail
    **********Restore Done Success<0> Fail<1> Time<170400>ms**********

    How can i solve this problem? I can't check if the android settings are on connecting to PC, cause i can't come further then the bootlogo.
    I see some "brick fixes" for the normal X7, but the mini does not have a power button.

    Can you help me with this?
    Kind Regards,

    Stephan
  15. somethingelse

    somethingelse New Member

    Recently bought 6 Minix X7 minis from a third party and ran into issues flashing this 250 firmware on two of them.
    All x7 minis seem authentic w/hologram and have identical upc but two boxes that fail have different codes on one of the stickers.

    The first four x7 minis with code JX7MNBOX15.. all flash this firmware fine with RKBatchTool.
    The two with code JX7MNBOX17.. both failed during Download Firmware step while flashing.

    Every subsequent flash attempt after always gives me Prepare IDB Fail no matter what I tried.

    Finally got the two back up by opening them up and putting them in Maskrom mode, then using the RK Developer Tool to erase everything and re-install boot.

    Back to the batch tool I successfully flashed 10a firmware from: http://www.minixforum.com/threads/neo-x7-mini-010a-firmware-11th-feb.67/
    Tried using the 250 update.zip method this time and that failed. Taking a break for now but I'll try other firmware versions and see what happens.

    So for some reason this 250 firmware will not flash on X7 mini with JX7MNBOX17 code?
  16. deyna

    deyna New Member

    hi did you manage to sort out ?? i also have the same problem
  17. khanhsac

    khanhsac New Member

    Xin chào Villa, MINIX X7 Mini nâng cấp firmware mới nhất là vào 18/12/2015 cho đến nay hơn 1 năm là quá dài. Hiện nay rất nhiều các ứng dụng mới không tương thích với phần mềm này. Được MINIX kế hoạch nâng cấp phần mềm của nó để phục vụ khách hàng của mình trong tương lai?
  18. Villa

    Villa Well-Known Member Super Moderator

    English please!
  19. Rodrigo Martinez

    Rodrigo Martinez New Member

    Hi everybody,
    I have this version installed but I would like to flash it again. Could anyone tell me about the process? I'm not sure about.
    Thanks
  20. midnight

    midnight Moderator Moderator