1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Custom ROM X7mini Kitkat v2.2.0 Community Edition

Discussion in 'NEO X7 mini Custom ROMs, Kernels & Discussion' started by HardwareGuru, Jan 24, 2015.

Thread Status:
Not open for further replies.
  1. I saw it but only the X7 version :-( not the mini version :)
  2. Polly80

    Polly80 New Member

    Should i install an other version of xbmc?
  3. HarisS

    HarisS New Member

    First I would like to thank the developers.

    I have an x7 mini 8GB without antenna and lately I was experiencing regular crashing problems so I decided to try this rom, to find out, on my disappointment that my problems persisted. I was impressed though by the overall look and feel quality plus the fast performance of this rom.


    I noticed that the problem on my minix started after several days that I was switching off my device every night. The fact that the device does not have a shutdown button to safely unmount partitions, prior to power off, probably caused partition corruptions. Unfortunately these problems did continue after the installation of this rom. I was almost sure that my device had some kind of hardware damage until I decided to try installing the original minix software version 10a which I noticed that on initial startup did format some of the working partitions, something that I did not see this rom doing.


    My conclusion is that if my device is misbehaving and like to upgrade to this rom is probably better to first install the original software 10a and follow the update path up to this rom and I would like to ask the developers if this conclusion does make sense.
  4. KAR

    KAR Developer Super Moderator

    No it does not matter, installing this ROM will wipe all files /data.

    But it could also be releated to the sensor driver which causing reboots/shutdowns with some hardware attached. In the new release this issue has been resolved.

    I have a BETA available which you can try if you want ?, just PM me.

    KAR
    HardwareGuru likes this.
  5. CyberTron

    CyberTron New Member

    When running on previous official rom, one of the iptv app was laggy. Upgrading to the new rom, the streaming no longer work. The app loads, but stuck trying to load the channel.
  6. KAR

    KAR Developer Super Moderator

    The 230 version which we are testing now have different HLS configurations. So using one of them I believe your app will stream property. I Have Beta pm me if you want to try.

    Kar
  7. CyberTron

    CyberTron New Member

    if I update to the beta, when the official 2.3.0 is out, will it be updated OTA?
  8. HarisS

    HarisS New Member

    Please let me have the beta firmware to check it out
  9. Polly80

    Polly80 New Member

    Hello Kar,

    Can I test the beta?

    I'm playing files from my nas. But i have about 3 of 4 timen an audio drop.

    Grtz. Paul.
  10. DeuxEx

    DeuxEx New Member

    Please, add to Changelog the release date of the every ROM.
  11. albertinicapo

    albertinicapo New Member

    hi guys, first at all, congratulations about your great job, i am Spanish and i try to run "yomvi" app but when i choose view some movie or video the app closes. i tried to run the app from minix launcher and from KODI/XBMC, do you know what could be the problem?

    Thankyou
  12. Galmok

    Galmok New Member

    I just installed CE 2.2, but I have to drop it as it has a too weak HDMI signal compared to the latest official release. This means I get a black screen every 1-20 seconds (approx.). and make the device pretty much unusable to me.

    Is there something I can do to this release to increase the HDMI signal to match the latest official release?

    If not, what do I need to downgrade to the working 4.2 release? Just the 4.2 image and rkflashtool?
  13. Galmok

    Galmok New Member

    Hmm, CE 2.2 rebooted itself during the night. It had only run about half a day. Guess there is a stability issue to sort out.

    And a request: could the thread/process handling the flymouse (in my case Mele F10) get a higher priority? Right now, when anything uses the cpu, the mouse is blocked. This makes it difficult to move the mouse on certain web pages that run JavaScript or in apps the uses cpu during scrolling (most apps). Giving higher priority to the mouse will make the interaction much better.
  14. Galmok

    Galmok New Member

    And now it rebooted while I interacted with it. I think it may be the sound driver as I heard a short burst of static just prior to the reboot.
  15. Galmok

    Galmok New Member

    There is also no way to change the default media player away from MX Player. In the Apps menu it is not marked as default player, but even though bsplayer and vlc (which I installed) are present, I am not given a choice to use them (except when starting them directly). I wanted to steam to my Chromecast while the X7 was in flicker mode, but this process impossible (with my current knowledge) as I can only use MX Player (I wanted to use Localcast).

    EDIT: I uninstalled MX Player and then the app I used specifically wanted MX Player. I guess the above report is invalid. Sorry about the noise.


    Minor bug: in the Apps list, clicking on an app and then go back (pressing back on the F10) makes it impossible to click on another app until you have scrolled the list (doesn't matter how much).
    Last edited: Mar 8, 2015
  16. HardwareGuru

    HardwareGuru Developer Administrator

    I think you should do a factory reset, these issues are unknown .. running an x7mini 24/7 here(famaly use) without any issues
  17. Galmok

    Galmok New Member

    But a firmware replacement such as the one required to install CE 2.2 performs a implicit factory reset so how could I have changed anything that would cause such issues?

    Anyway, I'll probably return to the latest official firmware soon as the HDMI flicker is driving me nuts.

    Could it be the Mele F10 causing this problem? If the wrong driver is loaded for the F10, my experienced stability issues could be explained that way. Does this kernel have the correct driver for the Mele F10?
  18. Galmok

    Galmok New Member

    For reference, the official release can lock/reboot on me while I interact with it. And the latest release also has poor interaction with the F10, something the release prior to the latest official did not have (smooth interaction always).
  19. HardwareGuru

    HardwareGuru Developer Administrator

    mele F10 could be the issue, it is adressed in our next release ( probably tomorow )
    Do you have HDMI flicker issue?
  20. Galmok

    Galmok New Member

    HDMI flicker is severe, but varies. Sometimes 8 times in a row in 10 seconds and other times minutes apart.

    I will most definitely try the next release and if this fixes my two main issues, I will be a happy camper. :)

    I have noticed slight screen noise. It is only present for approx 1 frame and can be seen as a white line of approx 5cm/2 inch width on a 46 inch tv. The line is only 1 pixel high. Occurs randomly and I cannot force it. Could look like a very slight memory controller issue (write happening on the same cells that the display controller wants to read). It is nothing vital, just thought I'd mention it. But could perhaps indicate something more serious?
Thread Status:
Not open for further replies.