1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

X8-H bricked or what? Trying to flash official firm

Discussion in 'Official Firmware Releases' started by gica, Aug 23, 2016.

  1. gica

    gica New Member

    I don't know the firmware it's at and the blue light powers on when pushed but I get no video no matter how long it's on. I tried to hook it up to the computer and using the latest Burning tool v2.0.6.2 I tried to flash the 009 firmware I get Connect Success but am not sure it's in the right mode because I get the error:
    [0x10105002]Romcode/Initialize status/Read initialize status/USB Control setup error
    No matter how many cables I tried same result. I get connect success even if I plug it in and press Power only. I hear the ping which leads me to believe it's not in flash mode. I am running win10. Is there a way to unbrick? Any help would be appreciated.
  2. gica

    gica New Member

    In Win 7x86 it's asking for M8-Chip driver and it didn't find it right out of the box.
  3. gica

    gica New Member

    Where do you guys have it installed in device manager mine is in libusb-win32 Usb Devices and subfolder is WorldCup Device
  4. Villa

    Villa Trusted Helper Super Moderator

    It doesn't look good! :(
    http://www.minixforum.com/threads/help-on-minix-neo-x8-h.7637/page-4#post-74231

    @MINIX - Ken @MINIX - John
    Will someone please find out what is causing this?
  5. gica

    gica New Member

    Damn I thought so, tried them all shorted the pins, hell shorted everything else too and no video and no response passed 2%