1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

BUG!! X8-H is dead?

Discussion in 'NEO X8-H, X8 Plus & X8' started by geggo, Aug 31, 2017.

  1. geggo

    geggo New Member

    Hi all, I ask you help for my X8-H. Last week, without any problem with power, I found my X8-H power off. I pushed power button and blu led turned on for 2 seconds and stop. Black screen. I tried take off cable, change HDMI cable but nothing.
    So I connect Minix to my PC and I tried to flash FW with USB Burning tool but it stoped at 4% with problem of partition table. I tried connecting to USB 2.0, changed some USB cable but same result. Tried different ROM and different version of USB Burning.
    Now if I push power button led light turn on and doesn't turn off again, it remain on.
    I tried to connect Minix to another PC but it made same problems, though with different error, but always at 3-4%

    Before trash the Minix I would know if there are some other option to try.

    Thank you.
  2. 53peterp

    53peterp New Member

    I had a similar problem with my X8 H Plus using the usb cable to install the firmware. I would push the otg connector into the port but it would not stay in firmly. I found out from one of the other threads (that I can't seem to find now) that the cable that came with the Minix box that I wasn't using at that time had more of the otg connector showing and so went in further into the port. The thread also suggested trimming off some plastic with an nt cutter from the otg end of the cable. I trimmed off around 1 mm and it went into the minix box fine. I had no further problems downloading the firmware.
    Davie_b likes this.
  3. geggo

    geggo New Member

    Yes maybe you rught but I already try with some cable and PC. To be sure I'll try with OTG cable of new U9-H but I don't have much hopes...
  4. king_mongo2k

    king_mongo2k New Member

    Same problem here.

    Is there a solution offered by Minix team on this?
    Very dissapointed so far
  5. johnnie walker

    johnnie walker New Member

    Hey guys. My X8H is dead, with the same problem. When I connect the power supply and pres the power button, the led turns on for 2 seconds and turn off.

    To restore it with OTG cable, it should be powered from USB connection, or should I use the power supply also?
  6. cold iron

    cold iron Member

    You must use the power unit.
  7. jonmarkwright

    jonmarkwright Member

    Is there a solution to this problem. My minix has been randomly freezing crashing for a while now. Works perfectly most of the time but on average every 2 weeks will freeze and crash. At the weekend it did this. So pulled out the power cable and tried to switch back on and as you guys have mentioned the blue light switches on for 2 seconds and then nothing happens.