1. Registration issues have now been resolved. New accounts are able to be created

Beta Release X8-H PLUS Lollipop RC2 firmware (July 2017)

Discussion in 'Beta Firmwares' started by MINIX - Ken, May 27, 2017.

  1. the kid

    the kid New Member

    Just flash rc2,thanks for all your fantastic work.
  2. jesse james

    jesse james New Member

    I successfully installed firmware rc2 and it works great.
    Thank you minix team
    Best Regards from bkk
  3. doxmaster

    doxmaster New Member

    Is it just me or with RC1 and RC2 max resolution in Kodi 17.3 is set on 1920*1080, and in Android i can set 3x different 4k resolutions. On none 4k dont work in Kodi (only 1080p).
  4. mark2

    mark2 Active Member

    This RC2 runs really well i like the clear all in recents apps is great addition
    wifi and ethernet no problem
    wake from sleep works
    the only bug i have when i start the box the Minix boot screen logo is huge and up the right handmade corner
  5. laughingspamfritter

    laughingspamfritter New Member

    Great Thanks @ken & Minix team.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1080 reported is UI resolution, not video resolution :)
  7. Grippy Man

    Grippy Man Active Member

    thanks for your great work to this machine.
  8. fasteerboss

    fasteerboss New Member

    Hello thank you, I had RC 1, and now with this rc2 I have a problem, when opening some apps, they open in reduced format and the mouse does not work, an exp: APP cleaner

    Enviado do meu HUAWEI VNS-L31 através de Tapatalk
    racecane likes this.
  9. Kristian

    Kristian Member


    Yes its a problem with the airmouse support, I have the A3 airmouse and have noticed that it does have problem in some apps, like its not possible to log in to Spotify. When i press log in, ore log in from facebook nothing its happening, but i manage to log in to spotify with the mouse that came with the box, not the airmouse , and only by pushing on log in from facebook, nothing else worked, but innside spotify my airmouse is working fine...
  10. HereIsTom

    HereIsTom Member

  11. ginamarat

    ginamarat New Member

    Hello. Thanks for your hard work Ken! I'm having an issue with the daydream option. I went to day dream and went to the option to select "None" instead of any icons on the screen. However I was unable to change the amount of time daydream appears. When I went back, I could not go into the daydream options again. When I click on it, it just takes me take into the settings screen. What do I do Thanks.
  12. maxbaron

    maxbaron New Member

    Hi Ken,
    is there a way to output audio on both spdif and hdmi as in kitkat?
  13. KeongPN

    KeongPN New Member

    Hi Ken, I'am very glad that RC2 is good, it's been smooth all the way , confirmed working fine for me.
    I noticed that for RC1 & 2, the device serial is not known or shown in Settings, would it be a problem for future
    FOTA updates? I hope it could corrected by then with your guidance.
    Thanks again for Team-Ken great efforts.
    Best regards to you & all.
  14. ed hansen

    ed hansen New Member


    Great is this available as kit kat to old to load Krypton. Is is a self reloading, clearing or takes some tools ? It will be released--- sometime ?

    Hmm Seems other tools needed to get this zip to upgrade . Flash tool ? and some OTG cable ?


    are the new x8 H plus being sold have the latest Lollipop or that model is dead and gone ?
    Last edited by a moderator: Jul 18, 2017
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  16. mark2

    mark2 Active Member

    On my tv the resolution is 1280x720 this was set automatically on first boot to 720p-60hz the mouse cursor is huge and so is the boot screen
    this is with auto switch to best resolution set to on
    if i change to 1080p-60hz the resolution says its 1920x1080 with the auto switch set to off
    but then the Minix boot logo is normal size and so is the mouse cursor
    just a minor bug that didnt happen in the beta for me
    everything else runs fine
  17. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    On my tv the resolution is 1280x720 this was set automatically on first boot to 720p-60hz <-- This is correct
    Old TV tells the box the native resolution is 720, even if it supports 1080 (not native).
    In beta there was no mechansim to read TV's EDID, but there is in RC/RC2.
    So, not a bug. ;)
  18. chengdaddy

    chengdaddy New Member

    yes its the x8h plus. i have tried to even flash to the original firmware that was on the minix but keeps going to the reset screen
  19. ed hansen

    ed hansen New Member


    Thanks !
  20. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Could you please show me the reset screen?