1. Welcome to the official forum for MINIX devices!

X8, X8 Plus, X8-H Official Firmware 004A (NOT for X8-H Plus)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 004' started by MINIX - Ken, Apr 24, 2015.

  1. carmini

    carmini New Member

    Thanks wildbyte for your reply and now i understand this feature and why did it affect the streaming application that I use..
  2. Prizm

    Prizm New Member

    After upgrading to 004 from factory default firmware, my X8-H has frozen during playback a number of times. It will just freeze on a frame and I have to pull the plug and restart the box. I temporarily upgraded to 002 months ago and this same freezing problem happened. I got sick of it, so I downgraded back to factory default. Now I'm having the same problem again with 004.
  3. Peacerich420

    Peacerich420 Member

    Hi guys!
    When i go to Mbox setings -> System Update -> Update&backup
    (this is FOTA right ?)


    I get message no update.
    I got a:
    X8-H
    KOT49H.20141128 release-keys
    kerneel v: 3.10.33
  4. Jugmeister

    Jugmeister New Member

    Whenever i try to update using the usb flashing tool it fails everytime at 3%:meson fail.
    I tried with update 002 and 002a also and the same issues. I have re-installed the stock firmware without issue and still get the same error when trying to install firmware 004.
  5. adi_tca

    adi_tca Trusted Helper Trusted Helper

    No, that's the old one, never used.
    Check the 1st post in this thread, page 1. You can upgrade straight to FW 004 using the USB burning tool provided withing the FW package (you will loose your data & installed apps)
  6. adi_tca

    adi_tca Trusted Helper Trusted Helper

    Did you checked the MD5 checksum? Are you using the burning tool provided in the FW package?

    Full system image w/Windows USB burning tool:

    Download from MINIX server (ASIA): http://minix.com.hk/firmware/X8_X8PLUS_X8H_FW004A.rar
    Download from forum server (EU): http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_FW004A.rar
    MD5 checksum: A44F2FEC7493805C4AC11952E0285AC3
  7. Jugmeister

    Jugmeister New Member

    I was using the burning tool provided in an early update.
    Re-installed it using the installer from the download and works fine now.

    Thanks.

    p.s i couldn't reply as my account is new and the quote contained a link lol
  8. Peacerich420

    Peacerich420 Member

    Nice tnx for the quik response, but is this the only way? i have no problem whit this way.. But as i understand the FOTA was not avaible from the begining or am i wrong? :)
  9. stav

    stav New Member

    Hi.
    I have a real problem & need your help.
    I'm trying to install a new fw using burning tools without any success since my minix seems to have a problem with recovery button. I can not enter to recovery mode.
    Later botton System Update works but now it is Fota!
    Please advise.
  10. adi_tca

    adi_tca Trusted Helper Trusted Helper

    FOTA app was introduced with FW 002, the one you were referring to was in stock FW or beta FW, but never used, to what I know. Now,from KOT49H.20141128 release-keys you can either upgrade to FW 002 as described HERE and then via the new FOTA in 2-3 steps to FW oo4 (you will be able to keep your data), or directly to 004 via USB burning tool described in the 1st post in this thread.

    Good luck
  11. Brad505

    Brad505 New Member

    If we do a factory reset will we have to setup xbmc again.....put fusion in
  12. Kerenfood

    Kerenfood Member

    Hi
    after updating last week to 004-0428 via the FOTA, i got notification today that there is a newer version , when try to update , the mbox makes the reboot and stuck on the MINX logo, when i reset it from the power cord i get back to my existing version
    i remember you mentioned to " factory default reset needed, i did reset to default today but it didn't help i cannot get the latest upgrade to be installed.
    should i give up and skip this last update?
    my current release is - 004-0428
  13. Peacerich420

    Peacerich420 Member


    Ok, now i get it. I did update direct to FW 004 via USB buring tool. No need to update twice :)
    It worked like a charm.. doing 1st start up as we "speak"
    tnx again
  14. Charlie666

    Charlie666 New Member

    Hello MINIX Team,

    CEC doesn't work on 004 and 005 firmware. CEC worked PERFECT on 003 firmware.
    TV Samsung serie C650.
    Please, could you check this?
    Thank you.
    Regars
  15. 463nt_0ran63

    463nt_0ran63 Member

    Same here.
  16. Scott4646

    Scott4646 Member

    Hi,

    I cannot get my neo x8h to install the latest update 07052015 via ota?? I have done a full clean install of the 004 firmware via usb but still getting the same results. Go to update download the package approx 17mb click install box reboots but never goes into recovery just reboots as normal?? I have tried clearing the cache and data in the ota app but still no success. Does anyone have any ideas please. I have another x8h and an x8h plus and they are updating without any issues.
  17. parisfox

    parisfox New Member

    Hi,

    I am a little "lost" with this updte...
    Can I update my Minix Neo X8-h via usb (I don't want to update via pc)?
    How can I do that? Can I download the fw from post 1 and copy it to the pendrive?
    Can anyone explain how can I do that, plesae?

    Thanks
    Last edited: May 16, 2015
  18. Villa

    Villa Well-Known Member Super Moderator

    If you have done a full clean install of the 004 firmware, did you not think to just do a full clean install of the 005 firmware!

    There is no need to have 004 if you are flashing the firmware.
    To have 004 just means you will be able to update via OTA, which you appear to be having trouble with.
  19. Villa

    Villa Well-Known Member Super Moderator

    Do you know which firmware is installed presently on your device?
  20. parisfox

    parisfox New Member

    Yes, is the 002, I did that upgrade with a pendrive when it was available on the forum.
    But this one seems to be more complicated...