1. Official MINIX forum

X8, X8 Plus, X8-H Official Firmware 006 (20150708)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 006' started by MINIX - Ken, Jul 9, 2015.

  1. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1.) Booting up into system recovery menu:
    To enter system recovery menu, your box has to be connected to a display (so that you can access the menu options) and the USB drive has to be plugged in;
    a.) Press and hold the "Recover" button on the back of the case next to them HDMI port;
    b.) While holding the "Recover" button, press the "Power" button to boot the box into recovery menu;
    c.) You may release both buttons when you see the MINIX boot logo;

    2.) Choose "apply update from EXT", then choose "Update from udisk";

    3.) Select the "X8_X8PLUS_X8H_FW006_20150708.zip" [which is copied to your USB drive]
    This an easy method to update, and it keeps data as well;

    4.) Enjoy a cup of tea and let the update complete in about 3-4 minutes;

    5.) Choose "reboot system now" after the update is complete;

    Below video was recorded with X8-H PLUS for reference, it works the same way for X6/X8/X8 PLUS/X8-H, just using a different .zip package:
  2. wms

    wms Member

    Hi Ken,

    Even though my Minix is running fine, I'm tempted to update the firmware based on all my readings here.

    To confirm, baby steps with me, to keep all existing data on my Minix:

    1. I download this file to my PC:
    "X8_X8PLUS_X8H_FW006_20150708.zip"

    2. I save this entire zip file to a USB stick?

    No other files are needed??

    So far, so good?

    3. I plug the USB stock into the single port located beside the SD card slot?

    4. I navigate to: Apps -> Backup/Update -> Search.

    5. I locate and click on the update.zip file.

    6. I select the update option.

    7. I confirm the update and let the device reboot.
  3. adi_tca

    adi_tca Trusted Helper Trusted Helper

    Y
    Yes, you described Minix steps 1 post above yours. Make sure your USB stick is FAT32 formatted.
  4. brandnewbien

    brandnewbien New Member

    I did the steps you mentions. But I'm stuck at the number 2. I can't see my usb nor my harddisk. They are both fat32. When in recovery menu, my system doesnt detect anything, only my minix air mouse.

    How can I resolve this? Is there anything I missed?
  5. Luis Angeles

    Luis Angeles New Member

    Hi, i have installed firmware 002m , can i have install the new firmware 006 direct with flash tool or i new to install first other version .
  6. ARS

    ARS New Member

    Hi Devs! Thank You for 006! (flashed from 002 to 006 with burning tool without any issue)
    I have one question only, sorry if it has been asked before. Read a lot on this forum but I'm still confused about this automatic refresh rate switching thing.
    There's 2 different place referencing this kind of feature:

    1) Minix settings app / Display / "Self-adaptive refresh rate switching"
    2) XBMC / Settings / Video / Playback /
    "Adjust display refresh rate to match video"
    " - Pause during refresh rate change"
    "Sync playback to display"
    " - A/V sync method"

    Can You please tell me the correct values for this settings to get the best (smooth) playback experience?
    My TV is a Samsung UE46F6400 (46", full-hd, native 100hz)
    As I've just flashed 006 full system image, I think I have XBMC 13.3.3final2. (it says: 13.3-MINIX(3) Git:20141220-03810e0 Compiled Dec 29 2014)

    Thanks in advance and for your continuous support on this great box!
  7. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    Turn it on in minix settings, off in xbmc. That's it :)
    MINIX - Ken likes this.
  8. mtl514

    mtl514 New Member

    Just want to confirm, loading this onto a box with factory firmware (bought a year ago) will automatically install all the updates leading to current one? Or do I have to install each update leading up to this one? My box is working fine other than random timeouts here and there, should I still update? Thanks.
  9. ENDRJUPL

    ENDRJUPL Well-Known Member Super Moderator

    You don't have to flash all firmwares one by one. This one will suffice.
  10. Damon piall

    Damon piall New Member

    Apologies but I seem to be having issues with this.

    My minix x8 H has never been updated yet since I bought it last year and maybe that's why this isn't working.

    However tonight I finally decided to give it a go and downloaded the folder via the link above.

    Formatted the usb to MS Dos (fat) on my mac and copied the entire folder (nearly 1gb) and carried on with the instructions.

    Everything seems to work but when I get to the part after 'update from udisk' I select the folder downloaded and that then just opens up further menus etc, it doesn't start the installation.

    Should I be installation 002 firmware or something first?
  11. Higgs

    Higgs Yellow Dude Super Moderator

    First of all what "folder" did you download from what link.
    You should have a zip file not a folder, this is what you select.
    What further options/menus do you get?

    Sent from my HUAWEI Y550-L01 using Tapatalk
  12. Damon piall

    Damon piall New Member

    I used the link above given by Ken, using the Mac it downloads as a zip but when its finished its just a folder, should i just re-zip it as it is?
  13. Damon piall

    Damon piall New Member

    I think i may have just answered my own question, seems the mac is set to auto unzip hence why I'm not ending up with a zip file.


    i'll redownload and give it another go and report back in a minute
  14. Higgs

    Higgs Yellow Dude Super Moderator

    Are you sure its a folder, does your download program automatically unzip a zip file?
    Do you use a download manager?
    You can try zipping the folder, but I dont know whether this will work or not.
    Preferably try and download the zip file intact.

    Sent from my HUAWEI Y550-L01 using Tapatalk
  15. Damon piall

    Damon piall New Member

    Happy days, all done.

    Thanks Ken / Higgs.

    FYI if anybody else gets this issue it's because in Yosemite safari auto unzips files, you have to uncheck a box in preferences
    Last edited: Aug 2, 2015
    Higgs likes this.
  16. Igorian

    Igorian New Member

    I have X8-H, updated via OTA since 002, (no cache or data been formatted yet), rooted, firmware 006. I'm going to re-flash 006 and format cache and data partitions. May be it will help... As I see - firmware becomes more and more buggy since new SDK applied (firmware 4.0, if I'm not mistaken)... Below is my most annoying bug list...

    When I fix 720p-60 or 50Hz manually and enable optical/hdmi (no matter) direct spdif output - I see frequent changes of video frame resolution (during 16:9 1080p playback) from 4:3 to 16:9 on video start, and same story during video stop. Self-adaptive refresh switch does not resolve the problem. It's quite annoying when your TV all the time try to adjust resolution during video start and stop. As soon as I play low-res. 16:9 video 360p-560p, HDMI output starts to work fine, i.e. without changing to 4:3, even next playback of 1080p video is fine, but SPDIF output all the time crashes (AC3 2.1-5.1 playback) - I've got noise instead of sound... As soon as I enable automatic HDMI resolution switch - HDMI output works perfect (no more switching back to 4:3), but problem with SPDIF noise arises very frequent! Some times, on starting video playback, I loose signal from HDMI at all - black screen (switching inputs on my Panasonic TV helps), sometimes MINIX re-switch resolution from 720p-60 to 1080p-60 Hz on video start (very frequent it happens after wakeup)... Many bugs, some of them detected on 005. Beautiful SPDIF noise discovered since 006. I remember 002-003 firmwares)))) it seems there were no problems with HDMI resolution at all, no one MINIX freeze detected, no black screen, SPDIF was ОК... I hope total reflash can help... Anyway, thanks for you work! Check the bugs if possible! Regards,
  17. kendub

    kendub Member

    I Have a Mele F10 Deluxe remote, thx for adding the kl file, how do I edit the file?

    and separate question, can someone describe the issue between the Minix and Mele F10 Deluxe

    Thanks
  18. handy77

    handy77 New Member

    hi i am struggling to download the zip file. the page is just loading. nothing iss happening. is there anywhere else i can download the zip file
  19. Higgs

    Higgs Yellow Dude Super Moderator

    Have you tried both links? or a download manager?
  20. handy77

    handy77 New Member

    I have tried downloading both links get same issue page loading connecting that's it. Nothing else.any where else to download from my minix seems to be dead need to check it updates