1. Official MINIX forum

X8, X8 Plus, X8-H Official Firmware 006 (20150708)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 006' started by MINIX - Ken, Jul 9, 2015.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    Both links are working fine - I just tested them. What browser are you using? Are you using a download manager?

    If your minix is dead (or seems to be), shouldn't you be downloading the full system image for the usb burning tool (rar file), instead of the zip file. You need to be able to boot into recovery mode to use the usb update.zip package
  2. Andur1l

    Andur1l New Member

    I have this exact same problem. I can move up/down through the menus in recovery, but the select button on my remote doesnt do anything. Tried plugging in a USB keyboard but it doesnt work at all. Any suggestions?
  3. Higgs

    Higgs Yellow Dude Super Moderator

    The usb keyboard should work, make sure it is plugged in before you boot into recovery mode.
  4. Andur1l

    Andur1l New Member

    Hey,

    yes, thanks, of course it works that way. :) Updated succesfully.
  5. gr-bris

    gr-bris New Member

    Hi, I have downloaded the .rar and installed the usb burner tool as my X8-H wouldn't load into recovery. It got 65% installed and had a fatal error. I have uninstalled and re-installed the software and still get fatal error at same point.

    Windows 7 Pro 64bit
    Last edited: Aug 7, 2015
  6. wcwcwc

    wcwcwc New Member

    Hi. have a Minix Neo X8-H, with a minix_neox8_finless20a_rom.
    i want to install the X8_X8PLUS_X8H_FW006_20150708 version, i´ve tried several times in USB mode, but always appears on screen this mensage: (...) This package is for "NEO-X8" this is a x8_h(...)

    What is wrong???

    Help me
  7. Villa

    Villa Trusted Helper Super Moderator

    When you say USB mode do you mean the USB update.zip method?

    You can not use that method you need to use the full system image with flashing tool:

    Minix server: http://minix.com.hk/firmware/X8_X8PLUS_X8H_FW006_20150708.rar
    Forum Server ( EU ): http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_FW006_20150708.rar
    MD5 checksum: 8DE881A7FE7A4A12DCC1AAF9DE197253

    How to...
    http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Why it wouldn't load into recovery? I'm curious...
  9. gr-bris

    gr-bris New Member

    I honestly don't know, it would just sit at the minix logo. I tried different combinations. Power cable out push recovery button in, put power back in, press power button. Tried power out then in, push recovery button in, press power. I did that on the TV and PC Monitor.

    That's when I tried to flash it up to 006, but the software usb burner keeps failing. I have tried it on 2 PC's and a laptop. thinking on taking it back to the shop and asking for a replacement. I only purchased it 10 months ago
  10. adi_tca

    adi_tca Trusted Helper Trusted Helper

    To enter recovery mode you don't have to unplug the power cable. Simply turn off the box via clicking on the "Power off" soft button in the power menu. Once the box is powered off, with the help of a paper clip press and hold the reset button on the back of the unit and, while keeping it pressed, press also the power on physical button until you will see the recovery menu. This should take less than 20 seconds, if I remember well. This is just to test that your X8-H goes into recovery menu.

    Now for the FW upgrade: 1st of all, you didn't mentioned what is your FW release. You said that you have your box for ~10 months, not clear if you ever upgraded it since then.

    FW upgrade: if you want to upgrade using the USB burning tool, once you checked as above that your box can enter the recovery mode, did you followed the instructions from here: http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/?
    You need to use the provided OTG cable tha you connect on one side to the microUSB port on your X8-H and on the PC/laptop USB port on the other side (which has to be a USB 2.0 port). How did you reached 65% of burning process if you said that you are not able to enter recovery mode?
  11. Villa

    Villa Trusted Helper Super Moderator

    How long have you waited?
    Other members have been impatient, expecting recovery screen to come up instantly. That is not the case! The MINIX logo is displayed for a few seconds before the recovery screen is displayed but it can seem like an eternity!
  12. wcwcwc

    wcwcwc New Member

    New
    Hi there.
    I´ve just made what come on "http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/", but when i put my minix in recovery mode, nothing happens in flashing tool or even in pc.
    I´ve tried in 2 diferent pc´s, one with win10, other with win7...
    One thing, in my minix i have install recovery mode twrp. Should i install in standard recovery mode?
  13. estelios81

    estelios81 New Member

    Hi,

    I have Minix x8-H with FW006 and I just bought a new TV Samsung UJ6000 which is UHD and has Motion Refresh Rate 50Hz.

    The question is what mode should I select in the Minix display settings? 4k2k 30Hz or 4k2k 25Hz.
    Also should i use the pre install xvmc of FW006 or download the kodi 15.0 from google play store.

    Do i have to enable or disable auto refresh rate in Minix?

    In xbmc (or kodi) what display settings shall I use?
  14. wcwcwc

    wcwcwc New Member

    I got it install official 006 fw ,(y) with win7, after a few scares with win 10:eek:...
    All ok, all work 5*
    Now, aplly root and twrp.

    Thanks for all support
  15. Skrell

    Skrell New Member

    noob here: How are you guys figuring out what version of FW you currently have? When i go to options/system I see:
    Android Version : 4.4.2
    Build number: KOT49H.20141023
    Kernel: 3.10.33

    This seems REALLY old to me, can i still update using the zip X8_X8PLUS_X8H_FW006_20150708.zip

    It fails in recovery with a signature invalid error.....WHAT AM I DOING WRONG?? Please be detailed. :((((
  16. adi_tca

    adi_tca Trusted Helper Trusted Helper

    Did you rooted your box and/or used xposed installer? If yes, clean your box 1st and unroot
  17. Skrell

    Skrell New Member

    Figured it out! Stupid error on my part! Thank you for responding tho!
  18. Villa

    Villa Trusted Helper Super Moderator

    Please share your ''stupid error'' no matter how stupid it may appear. :X3::censored: It may help others! (y)
  19. Carlo

    Carlo New Member

    Hi Minix,
    i tried to play some mp3 in a 8 gb sdcard with google music and the stock music player of minix 8-H but it's impossible because they crashed.
    This is an known issue?
    Thx
  20. jussipussi

    jussipussi New Member

    Hi Minix,
    I have Minix x8-H with FW006. Wifi access stopping after few minutes using. After reboot worked better. But yesterday it not worked. Now I use ethernet, it worked good. I am thinking, that what is the reason.
    I once did a factory reset, helped a little time.