1. Official MINIX forum

X8, X8 Plus, X8-H Official Firmware 007A (20150924)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 007' started by MINIX - Ken, Sep 4, 2015.

  1. harpua1982

    harpua1982 New Member

    I'm sorry if this was answered, but I used the Flash Drive method to update my FW from 002 to 007 (lol).

    Love it! Now it can see my Logitech C310 Webcam for Skyp Video Chat and I can use the mic for Google Now/AutoVoice integration. Making my TV a true SmartTV!!

    I did, however, lose root in the FW upgrade process. :(

    I use ROOT for most system wide actions implemented through Tasker to execute certain tasks from within Android (that requires ROOT) to ease use and access for the whole family...

    For Example:
    • Access the Minix Remotely using TeamViewer (on PC) and Quick Connect - By using Secure Settings, (w/ Root) I can enable this w/out interrupt through a Pushbullet msg sent from my comp or Tasker Task setup w/ remote.
    • Kill certain Apps through Tasker, (specifically Kodi) when misbehaving (troubleshooting) through Pushbullet
    • Possibly activating a CEC input switch by using the "OK Google" command - no matter the input mode.
    • Many, many more things that I haven't thought of!

    What is a safe and easy way to ROOT this device?

    The old method?
  2. Villa

    Villa Trusted Helper Super Moderator

    http://www.minixforum.com/threads/patches-update-zip-root-unroot-system-mods-no-cwm-no-pc-needed.95/
  3. kendub

    kendub Member

    Im open to correction, but Root may stop some TV Catch up services running, 40d, BBC I player etc.
  4. Villa

    Villa Trusted Helper Super Moderator

    BBC iPlayer, ITV Player run on an X7 with root.
  5. ForceClose

    ForceClose New Member

    Hi to all!

    I own NEO X8-H and had 002 FW for most of the past year. Yesterday I checked for some updates through blue MINIX app and found new update (approx. 500MB) . I updated once and tried again and it again offered new update, this time approx. 90MB. Then again checked and again found new update of approx. 540MB. So, I decided to flash 007A FW from my USB in order to avoid numerous updating. Now that I do have 007A version I checked again with MINIX app and again been offered with same update of 540MB. Am I missing something or what?
  6. nandomericoni

    nandomericoni New Member

    Hi.....

    I have a question.

    Can I update my X8-H from actual 001 FW directly to 007 FW???? In wich way???? The date of my FW is July 2014 and in the past I wasn't able to upgrade to 002 FW

    Thanks
  7. Villa

    Villa Trusted Helper Super Moderator

    Download the full system image with flashing tool:
    Forum Server ( EU ): http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_FW007A_20150924.rar

    MD5 checksum: 7AE54A53F943F09C3BAADD80A2B88E98

    How to...
    http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
  8. Helly

    Helly New Member

    Hi,

    Tried to update my X8 Plus to 007 FW via usb.zip method but it's been stuck for 20 minutes on "Installing update".
    What do I do now? Can I turn it off without bricking my device?
    I was on December 2014 FW, maybe that's the problem?

    Help please.

    Edit: Unplugged power cable, tried again and then it worked flawlessly..
    Last edited: Jan 15, 2016
  9. nnever2000

    nnever2000 New Member

    HI all,
    I'm happy using my minix since FM002 and so I stay using FM002.

    But after reading this feature

    5.) Added Ethernet to faked WiFi state option

    i realized that I need to update my minix firmware :)

    Can I go from FM002 to FM007A using FOTA update (that I prefers)? Or I need the full zip package passing for windows?

    Thanks

    UPDATE: I try to update via FOTA. I go succesfully from 20141213 to 20141224 then to 20150207.

    Update 20150428 downloaded succefully, decrompressed succefully restarted succefully but at near 50% of installing (robot on screen) it restarted and I are stick to 20150207. Argh

    UPDATE 2: Ok, I updated using zip file and recover mode.
    http://www.minixforum.com/threads/how-to-use-the-usb-zip-update-method-x6-x8-series.6828/
    Aesy and fast. Ethernet as wifi work! :)

    UPDATE 3: Anyway I have now this problem: audio crackles. Before update all was fine. I'm using all previous hardware (samsung tv and hdmi minx cable). How I can do?

    UPDATE 4: I have done a factory reset but the audio crackles problem still occur. Help please!! :(
    I had to stay with FM002
    Last edited: Jan 16, 2016
  10. lanszelot

    lanszelot New Member

    Hello!
    I bought more than a year ago my minix neo-x8-h .
    I reseted the device, and xbmc is gone.
    I never updated, or rooted. I only used.
    I want to update, in settings - other - system update - online, but it said no update.
    I don't know where can I found official file, which one is the best, and how I have to update.
    I updated, rooted, and change rom many phones, so I think I can do it, but I can't find how.
    model: neo-x8-h
    android version: 4.4.2
    build nr: kot49h.20140722 test-keys
    kernel version: 3.10.33
  11. Villa

    Villa Trusted Helper Super Moderator

    Download the full system image with flashing tool:
    Forum Server ( EU ): http://www.minixforum.com/downloads/download.php?file=X8_X8PLUS_X8H_FW007A_20150924.rar

    MD5 checksum: 7AE54A53F943F09C3BAADD80A2B88E98

    How to...
    http://www.minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
    lanszelot likes this.
  12. jussipussi

    jussipussi New Member

    If I want a new android version for my Minix, I must buy a new minix device. Am i right?
    Maybe this is answear my question: Why have Lollipops or Marshmallows when you can have Chocolate! :)
  13. Higgs

    Higgs Yellow Dude Super Moderator

    If you want android lollipop then you have to buy the U1, its the only minix box with lollipop OS at present.
    The X8/X6 series and Z64A all have KitKat firmwares and there are KitKat firmwares available for the X5/X7 series
  14. Harry S

    Harry S New Member

    I have issues with firmware update by any versions; with the usb burning tool
    it shows always by 93% [0x30101004]UBOOT/Low Power/Send command/Error result

    what goes wrong? going into recovery mode does not work as in did prior a fota update.

    Box ix a neo x8 plus
  15. Higgs

    Higgs Yellow Dude Super Moderator

    1 Just to confirm your box is a X8 Plus and not a X8-H Plus...(because the firmware is different)?
    2 Which firmware do you have now?
    3 Which firmware are you trying to flash and with which usb burning tool version?
    4 How are you trying to go to recovery mode?
  16. Harry S

    Harry S New Member

    Hello Higgs,
    i confirm its a X8 Plus as i didn't found here anymore different sections for each model.
    By this i suggest to add a ftp drive to put public downloads for the models.
    I don't know which version the box had as the fota update broked it (as i stated up in my
    first post, and i hate to spell the same things twice).
    The usb burning tool is 2.0.4.3
    Going in recovery mode as shown in the faq section "hold the recovery button and the
    power button for 6 seconds". By this, nothing will happen.

    thank you for the fast response!

    cheers :D
  17. Harry S

    Harry S New Member

    maybe it's an issue with unplugged devices, the flash process goes after unplugging
    anything except the power- and ota-cable to 95%. woot 2% more then before! :whistle:
  18. Harry S

    Harry S New Member

    It's still hanging by by 93% [0x30101004]UBOOT/Low Power/Send command/Error result
    No one a solution? I strongly prefer to work with a tool from which even uboot- and other
    system flash can be modified to surpass the old and broken firmware.

    \edit
    the second device who is broken; the last has been exchanged by the dealer but this one
    i think they will not simply exchange.

    i think i need a modified u-boot code within the firmware and this firmware should
    be so coded that it ignores the "machine code" of the prior, wrong flashed m200
    firmware.
    From my understanding its odd that the faulty chinese firmware does not "accept"
    an override thru the minix firmware, but at the other side the "quality product from
    minix" grants flashing with any fucked-off and faulty firmware you can find.
    There went something wrong as the minix firmware not have a machine check built in.

    \edit
    Would it work to modify minix-firmware where the string is "ro.build.product=k200" to "n200c" as its been in the actually flashed firmware?
    Last edited: Nov 5, 2016
  19. Harry S

    Harry S New Member

    FW 007a is the best firmware as i tried from 009 to 4 any one. The only
    one problem to mention is still the audio - as with all versions - fault
    by some incompatible repo's or add-ons.

    Firmware flashing failures with the burning tool can be avoided, when
    you follow this simple procedure as another one here typed it;
    1. Remove the power plug
    2. Press the reset button
    3. Plug back in the power plug
    4. Press the power button for 6 seconds by holding the reset button,
    after this 6 second release both buttons.
    VoilĂ , the box is in the recovery mode and will be recognized from the
    usb burning tool.
    With this procedure, i had with any firmware success & it flashed it
    to 100%!
    Last edited: Nov 7, 2016
  20. Harry S

    Harry S New Member

    Reconnecting the hdmi cable on the tv solved the problem. wtf