1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

X8, X8 Plus, X8-H Official firmware 009 (20160324)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 009' started by MINIX - Ken, Mar 25, 2016.

  1. toto le heros

    toto le heros New Member

    Hello
    I have switched to an other hardware, 4K compatible and still have audio freeze/drop , and lots of difficulties with audio passthrough setting (S912 oblige )
    I made radical change : forget android and move to libreelec : still some audio freeze/drop, quite more in fact
    But libreelec was full open , so quite more easy to diagnose.

    Two causes of audio drop in fact : some hardware failure, when checking the interface with ethtool -s eth0 , i found some crc errors : reboot the switch help a little, i will check my calbe also later
    But the root cause was kodi with its implementation of NFS
    Mapping the NFS in autostart.sh of libreelec kodi fix all audio dropforum.libreelec.tv/thread/10612-8-90-11a-libreelec-9-x-for-s912/?pageNo=10
    Hope this help
     
  2. Kerry

    Kerry New Member



    Installed zip file as shown onto usb. Followed instructions and it starts to load. Loading stops with errors. See attachment. Why is this?
     

    Attached Files:

  3. nirms

    nirms New Member

    If you are trying to install 009, try 008 instead. I couldn't get 009 to work.

    You will be able to update to 009 from 008 in the menu on your box.
     
  4. Kerry

    Kerry New Member

    Thanks will try 008 first then 009. Is there a big difference? Also once updated firmware is installed, what is the latest version of xbmc or kodi that i should install and what is the link to download it. Thanks!!!
     
  5. Menorca Man

    Menorca Man Active Member Trusted Helper

    Might be worth checking that the MD5 checksum of your downloaded oo9 zip file is the same as that provided in Post #1.
     
  6. Kerry

    Kerry New Member


    Tried 008. Same errors coming up. I have to be doing something wrong. I download zip file to usb device. Install it into my x8-h. Start download and eroors come up...whats going on? Anybody!
     
  7. Higgs

    Higgs Yellow Dude Super Moderator

    Did you check the md5 checksum of the downloaded file as suggested above?
     
  8. M Nogueira

    M Nogueira New Member

    Hi everyone.
    I've try to update my Minix 8-Plus using the .zip file trough a pen drive but every time i've tried it gives me this error.
    Any ideias to solve it?

    Thanks
    IMG_1229.JPG
     
  9. Villa

    Villa Administrator Administrator

    Looks like you're trying to install an older or the same firmware over a newer build which is not possible!

    You're device must already be updated with FW009.

    The zip you have is dated 2016 03 24 and your device has a firmware dated 2016 03 28
     
  10. M Nogueira

    M Nogueira New Member

    After doing this, i have reboot the system and it goes to the old android system.
    What am i doing wrong? I'm not an expert doing this, and i have already tried everything, without success.
    I was trying to update my android version, from 4.x.x to 5.x.x., but it keeps over and over maintaining the old system.
     
    Last edited: Jun 15, 2018
  11. exitguy

    exitguy Member

    What you have been doing is trying to update the FW, you don't use that to upgrade the OS.
    There is another thread that details how to go about update from Android 4.x.x to 5.x.x
     
  12. Marty

    Marty Moderator Moderator

  13. M Nogueira

    M Nogueira New Member

  14. skynet

    skynet Moderator Moderator

  15. Marty

    Marty Moderator Moderator

    Unfortunately there is no zip upgrade available, it has to be a full image flash.
     
  16. M Nogueira

    M Nogueira New Member

    My problem is that i only have Mac and i can not use the USB Burning tool to do it. That is why i'm trying to do it trough a pen drive.
    Whitout the .zip files i cannot do it. Beside i thought it would be much easier but so far is a nightmare.
     
  17. Villa

    Villa Administrator Administrator

    There is no zip file! Zip files are only a FOTA alternative.

    You have to do a full image reflash or you can use the Burncard method but you still require the use of a Windows PC.