1. Official MINIX forum

X8, X8 Plus, X8-H Official firmware 009 (20160324)

Discussion in 'X8, X8 Plus, X8-H Official Firmware 009' started by MINIX - Ken, Mar 25, 2016.

  1. Higgs

    Higgs Yellow Dude Super Moderator

    The details are all in the first post.
    Use either the Full system image with USB flashing tool or the USB .zip update package (keeping exisiting data, requires FAT32 USB drive)
  2. iGiorgis

    iGiorgis New Member

    Hello, any updated firmware for Neo X8-H Plus ???? I have the stock many months... :(
  3. Villa

    Villa Trusted Helper Super Moderator

  4. Spaboy

    Spaboy New Member

    Hello,

    I'm trying to update a minix X8-H from update app on the minix seeting but says no update and I have version KOT49H.20140722. Is #3?

    Why i cannot update over Internet?
    I tryed deleting data and cache for the setttings and update app but no luck...

    Any idea?
  5. frutiloopis

    frutiloopis Member

    Update not OTA

    https://r.tapatalk.com/shareLink?ur...&share_tid=8331&share_fid=153432&share_type=t


    Enviado desde mi iPhone utilizando Tapatalk
  6. Higgs

    Higgs Yellow Dude Super Moderator

    Please make sure you use the correct firmware file for your model. Only use the files in the link above if you have the X8-h plus.
    If you have a different x8 model then look in the firmware section for the latest firmware for your model.

    Sent from my MotoG3 using Tapatalk
  7. Zaheed

    Zaheed New Member

    Hi,

    my firmware version of my x8-h is KOT49H.20141128
    How can I update to firmware-9
    when I tried update zip from USB, its says signature veryfication failed.
    please help.
  8. Arezzo

    Arezzo New Member

    From that version of software I believe you have to use the Burning tool. Follow the link for instructions.
    http://minixforum.com/threads/how-to-flash-firmware-image-x6-x8-series.116/
    HardwareGuru likes this.
  9. Emanuel Argentina

    Emanuel Argentina New Member

    Hola tengo esta versiónKOTH49H.20140529
    Del minix X8-H, ahí puse una captura
    Me gustaría actualizar a una más reciente que funcione bien alguien me ayuda? Gracias
  10. Villa

    Villa Trusted Helper Super Moderator

  11. habib

    habib New Member

    When 010 firmware fixed avi problem
  12. kensterboy

    kensterboy New Member

    Hi everyone, I have a Minix X8 H and recently I tried to update the FW and as a result I lost everything including MINIX boot screen and Android My fault selecting " CLEAN DATA As a result . Its Just gives me the same options and I try again using the USB method and select correct install from EXT but again after reboot no Android. If I follow the instructions above in Post Reply by Villa will this bring me back to the original state where by I can run Android again and possible perform general up dates and such. I just want to bring the box back up and running to use Android if possible . Thanks everyone waiting for a reply and clarity on this. Also when you say Full system image does this include not only latest FW but Android as well?
  13. sweman11

    sweman11 Guest

    Hi!

    If the Minix 8H has an very old fw,can I still insert the newest fw(se below) or do I need to upgrade whit other fw before that?
    Official firmware 009 (20160324)

    Edit,10th Oct:
    No need to answer this question!
    I don´t use Minix anymore!
    Last edited by a moderator: Oct 10, 2016
  14. cyrus82

    cyrus82 New Member

    Hi all, i have tried looking for answers, found something similar in X8H-Plus. but not sure whether is it the same for my X8-H.
    I have never upgrade the firmware for my box before and its firmware is before 20141122.

    Would like to ask, do i have to flash to 002 before going to 009? Or i could just download 009 and using the full system image flashing using the usb flashing tool?
    Also, will XBMC 15.2 be already inside 009 firmware or only XBMC 13.3.3 is inside 009?

    Many thanks in advance.
  15. HardwareGuru

    HardwareGuru Developer Administrator

  16. cyrus82

    cyrus82 New Member

    Thank you so much sir for your reply, i'll try and flash it by these few days. Have a good day!
  17. jtmon3y

    jtmon3y New Member

    Hi guys.

    I am currently running the version from 20140414. I put this new update.zip file for 009 onto a USB but when it loaded up I didn't have the option to apply from ext like in the tutorial. I had an "install" button that I tried. Selected the file on the USB and and it tried to install. Then it tells me no MD5 file found. And then an error message saying this package is for Neo X8 and that mine is an X8-H followed by "error flashing zip"

    Please help. Have spent many hours trying to figure this out
    TIA
  18. Villa

    Villa Trusted Helper Super Moderator

    You posted before in the X8-H Plus forum!
    http://www.minixforum.com/threads/official-x8-h-plus-009-firmware-20160328.12155/page-7#post-108664

    If you have the X8-H Plus, and because of the Build number you have, you will have to use the full system image and flash using a PC.
  19. jtmon3y

    jtmon3y New Member

  20. Villa

    Villa Trusted Helper Super Moderator

    So which device do you have exactly?
    I would flash a full system image with the burning tool and a PC.