1. Registration issues have now been resolved. New accounts are able to be created

BUG!! X8H

Discussion in 'NEO X8-H, X8 Plus & X8' started by lawrence, Jul 15, 2017.

  1. lawrence

    lawrence New Member

    Hi there , my X8 H is powering up (blue LED) on an display on TV is MINIX LOGO with a hazey blue and green background & a very jumpy display. I have tried to reset with button on rear of box but it will not go into reset mode .
    Any direction or help appreciated.
    Thanks
  2. dirkdiggler

    dirkdiggler Member

    Might be the HDMI cable. I had that. Pull it out and back in or try and swap it and restart the device. Ie. Pull power.

    Sent from my ONEPLUS A3000 using Tapatalk
  3. lawrence

    lawrence New Member

    Thanks for reply ,I have tried second cable with same results, but I'm not even getting what would be the normal display on startup.
    Cheers
  4. dirkdiggler

    dirkdiggler Member

    Try this. Unplug it. Wait 10 Seconds. Plug it in. Push and hold reset button and then push and HOLD the power button (reset button still depressed) release the reset button but keep holding power button for at least 30+ seconds until recovery shows up
    Last edited: Jul 17, 2017
    zantv011 likes this.
  5. lawrence

    lawrence New Member

    Thanks, I will try that.
  6. lawrence

    lawrence New Member

    Hi , tried that but no joy ,here is a link to see what my display is ,
    Cheers


  7. lawrence

    lawrence New Member

    Sorry about audio.
  8. dirkdiggler

    dirkdiggler Member

    But you did get into the reset mode no?

    Sent from my ONEPLUS A3000 using Tapatalk
  9. lawrence

    lawrence New Member

    No , tried multiple times but no success.
  10. lawrence

    lawrence New Member

    Is there a way of resetting it via a connection on laptop, or am I now the proud owner of a "Brick" ?
  11. dirkdiggler

    dirkdiggler Member

    You should be able to reset using the reset on the back. Try unplugging and then plugging itnin WHILE the reset button is depressed. Then leave it pushed in while holding power for at least 30 or more seconds. Otherwise yes. You should be able to connect to pc and try it from there

    Sent from my ONEPLUS A3000 using Tapatalk
  12. lawrence

    lawrence New Member

    Thank you for your help, found pins bent in tv hdmi socket . Sorted now.
    Thanks again for your help.