1. Registration issues have now been resolved. New accounts are able to be created

XBMC 16.3 OSD hangs after pausing

Discussion in 'Kodi/XBMC for MINIX Releases' started by Sherpa25, Mar 10, 2017.

  1. Sherpa25

    Sherpa25 Member

    :ROFLMAO: And this was after a long pause? :unsure:
    Last edited: Mar 18, 2017
  2. CybeRider

    CybeRider Member

    I always did it like that even with the previous versions of XBMC and firmware. The first few times I was learning the howtos with the gadjet I couldn't get rid of the OSD and that was the way I found. I always do it like that, even after long phone calls leaving the Minix with a movie paused in XBMC for half an hour or more, or when I write messages in forums with the movie paused at another window, like now. It never let me down ever since, so I thought that was the proper way to do it, as I didn't know this forum by then didn't have anybody to ask. . That is why I trust it will work for you as well. Please try it and let us know, ok?:p
    Sherpa25 likes this.
  3. dryster

    dryster Active Member

    I've been trying to reproduce this phenomenon on my setup with the NEO X8-H Plus and A2 Lite and my mouse with no success.

    In KODI while playing a video file off a USB stick I hit pause on the A2 lite and the video pauses, if I wait 10, 20 or 30 seconds and hit pause again, the video restarts.

    If I use my mouse, move it so that the OSD displays, hit pause on the OSD and wait, the OSD disappears after a few seconds, then after 10,20 or 30 seconds I move the mouse again, the OSD appears and I hit play and the video plays.


    KODI version : 16.1 Git :2016-04-24-c327c53
    Firmware : KOT49H.20170119 release-keys
    Files used : Random 720P
    CybeRider likes this.
  4. CybeRider

    CybeRider Member

    I really believe KODI and XBMC act the same for this situation. I also tried to reproduce the stalling OSD situation that Sherpa25 mentioned, and I described as having happened to me the first few days of my getting acquainted to MINIX U1 (in November, before last firmware and 16.3 XBMC), but to no avail. Since I started using the Left+Back to quit the OSD I found at least two significant benefits:

    - I never got stuck with the OSD anymore, either because the mouse movement would put it back if my arm doesn't rest steady as I press "back" (a trembling arm will leave you with the OSD coming back and out like forever) or for any other fault.
    - I get out of the OSD very quickly without having to wait for it to fade after the "few seconds" that can look like an eternity, with no risk of getting to the initial menu with the poster image and the movie running behind and so -someone mentioned also that, above- , which I also got once or twice during those couple of initial days of learning basics.

    Also, by default the screen dimms dark after 2 minutes in pause. That should not be a problem either. But I don't know. I solved the situation I had, so I don't have the situation anymore. Yet, I'm glad to see someone is going more scientific and spending some more time trying to recreate a situation which for me is not a situation anymore, since there is a way of getting us free from something that might be as personal related as a trembling arm or a full device cache, or a bad LAN connection, or just a twich in key pressing. I also wish I could recreate that. I tried and tried yesterday before my first answering to Sherpa25, I didn't find the issue anymore but still hope my solution fits. ;)
    Last edited: Mar 19, 2017
    Sherpa25 likes this.
  5. skynet

    skynet Well-Known Member Trusted Helper

    Hi Sherpa,

    I tried again with long pause and couldn't reproduce this. When I push the Back key Osd disappear.
    I tried with more than 1 mn and more than 2 minutes.

    Sent by my S7 edge
    Sherpa25 likes this.
  6. CybeRider

    CybeRider Member

    Actually I tried to use just the "back" key as ppl seem to find logical, and yes the OSD disappears, but the minimum movement with the A2 brings it back immediately unless we keep the hand very steady until the mouse pointer turns automatically off. How can this not be an annoyance?:confused:

    PS: I'm not addressing this question to anybody in particular because I could use the help of someone to enlighten me if I'm doing something wrong. Thanks!
    Last edited: Mar 19, 2017
  7. dryster

    dryster Active Member

    I use my mouse in KODI as I find my A2 Lite annoying at times, especially when the room is dark.
    CybeRider likes this.
  8. Sherpa25

    Sherpa25 Member

    Could this be a buffer issue? Or perhaps concerns some parameter of the video being played (haven't investigated this further)? What buffer settings (ie. advancesettings.xml) do you guys use?

    @CybeRider, isn't there a button on the A2 to temporarily turn off the airmouse?
  9. CybeRider

    CybeRider Member

    I use the stock definitions. Changed the buffer size once but didn't notice benefits, besides I read it stresses the disk too much when we decrease the kodi buffering, and these disks have a certain number of thousands of times to write and delete operations before dieing which is inferior to the mechanical drives, and so I ended up deleting the advancesettings file I had created.

    In the A2 we can stop the airmouse by pressing the same button that calls it. But then, if I have to stop the mouse there to press the "back" button after, I rather use my system of the left + back, because it is much easier to perform without even looking to the remote, due to the location of the keys (one is above the other).

    So it didn't solve your problem, hum?(n)
    Last edited: Mar 20, 2017
  10. Sherpa25

    Sherpa25 Member

    I see. Can you pm your advancesettings? Thought those in the buffer thread was useful, but it doesn't seem to improve on my end.

    Regressing, I mentioned the airmouse button just to help address the sensitive mouse shake, causing the OSD to keep reappearing, and hence you'd have to keep pressing left & back. Unless I'm mistaken. :)

    Anyway, yes, still investigating the hanging OSD issue :)
  11. CybeRider

    CybeRider Member

    I don't have it anymore. I deleted that file I had created. It doesn't exist in the original app.

    Thanks for the idea of the airmouse button, I hadn't thought about it anyway. It would be a solution if I hadn't found mine. :sneaky:

    Sorry to know the OSD still hangs. :censored:
  12. Sherpa25

    Sherpa25 Member

    It's fine, thanks.

    Just to clarify one thing with your solution (ie. left, then back). Since the OSD remains on screen despite pressing 'Back' after I resume playback, pressing the left button goes to the 'Rewind' function (though doesn't execute it), correct?
  13. CybeRider

    CybeRider Member

    That is correct. all that happens is clearing the OSD out. :)

    Recalling:

    Resume playback
    Left
    Back
    Last edited: Mar 20, 2017
  14. Higgs

    Higgs Yellow Dude Super Moderator

    Just FYI - Pressing any of the d-pad buttons disables the airmouse, hence pressing left then back works the same as pressing the airmouse button then back. Pressing up, down or right should work the exact same way.
    I tend to keep the airmouse disabled when using Kodi and only use the d-pad for navigation. I find it quicker.
    Sherpa25 and CybeRider like this.
  15. skynet

    skynet Well-Known Member Trusted Helper

    "I tend to keep the airmouse disabled when using Kodi and only use the d-pad for navigation. I find it quicker."
    Same here, it's a lot faster.
    I use airmouse only to reach some buttons during web navigation.
    CybeRider likes this.
  16. CybeRider

    CybeRider Member

    Ahhhhh.... For a few days I felt so clever. and now all the magic is gone... :p

    (Of course I'm jocking. Thanks Higgs!)
  17. CybeRider

    CybeRider Member

    I'm starting to realise that my constant presence of the airmouse is because I keep jumping from Kodi to the web browser and back, and so I keep unawarely turning it on. That can really explain a lot. Thanks Skynet! (y)
  18. skynet

    skynet Well-Known Member Trusted Helper

    ;) (y)