1. Registration issues have now been resolved. New accounts are able to be created

XBMC SMB Shares when using Network Domain

Discussion in 'Kodi/XBMC for MINIX' started by UltraFusion, Jun 26, 2017.

  1. UltraFusion

    UltraFusion New Member

    On my Minix X8H-Plus I have set up ES File Explorer to access some shared folders on my Win7 notebook (which is part of a Domain) and it works great. I set up the ES FE connection by entering my Domain name, then the LAN IP address of my notebook and then my User Name and Password - and bingo - I can browse and access my shared folders / videos...

    Now I'm trying to access those shared folders by adding a video file source in XBMC using,
    - Browse...
    - Add network location...
    - Protocol Windows network (SMB)
    - Server Name = IP Address on my notebook
    - Hared folder = tried leaving blank, and adding the path names...
    - Port = 0 (default) - but also tried 445
    - Username = my notebook username - and have tried Domainname\username ...
    - Password = my notebook p/w

    ( Basically everything is the same as I used to config ES File Exp, which works perfectly ... )

    But then when I try to connect to the SMB sacred folders I get either an immediate Connection Timed Out or an Operation Not Permitted error ...

    Can't understand why I can (easily) config/connect to the SMB shared folders using ES File Exp and am hitting a brick wall using XBMC... ???
    I suspect it has something to do with the "Domain" - ie. I'm somehow not entering it correctly into the above config window...

    FYI - I can easily set up a XMBC SMB shared connection to an old XP PC (not part of my Domain) I have on the network!
  2. UltraFusion

    UltraFusion New Member

    Happy to reply to my own question ... Not exactly sure what I did to get it working but it's now working !!

    Two things -
    1- entered my username exactly as it was shown on my Windows account log-on - namely a) with the Domain name and b) being case sensitive on the text - as an example; where Domain name is TERRAIN and Username is territory then use TERRAIN\territory
    2- I eventually rebooted my win7 machine
    ...and subsequently I was able to see/access my SMB shares...

    Gonna head out and buy myself a lottery ticket -
    Villa likes this.
  3. Rui Oliveira

    Rui Oliveira Active Member

    Hi. You also need to pay attencion to firewall in win7/router and any antivirus you have installed.
    You might be something blocking....
    Ip adress and Server name must be correct and also username/password .

    Ps: pay attencion if your PC have more than one account. I advice you work with user admin account and enable The needed permissions.
  4. UltraFusion

    UltraFusion New Member

    Good advice Rui - many thanks.