1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

Your system was damaged, wireless update is disabled

Discussion in 'NEO X8-H PLUS 007 firmware via MINIX FOTA' started by cbulcu, Sep 26, 2015.

  1. ZebSogo

    ZebSogo New Member

    Jeffers Many thanks all works fine migrated the kodi folder back to data folder installed kodi Many Many Thanks for your help
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    3 possibilities that I could tell:

    1.) Older data/cache files stored in the FOTA app folder gave a false alarm;
    2.) Not enough disk space left;
    3.) Device is rooted;
  3. Jeffers24

    Jeffers24 Active Member

    Ken,
    Would it be possible for FOTA to check for each of the above as a first FOTA step/s and issue a more meaningful error message?
    I fell foul of 2 in my early Minix days and all I got was a non-specific message that did not help me identify the problem.
  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    We could help you deliver the message to the FOTA service provider,
    I can't answer you the question by myself.
    The bottom line is we always provide the full system image & .zip package for flashing/update.
  5. Jeffers24

    Jeffers24 Active Member

    Thanks Ken, my limited knowledge, I thought FOTA was a produced by Minix.
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    No, we have made an introduction when we announced the service.
    http://mg.adups.cn/adups/index_en.html
  7. Jeffers24

    Jeffers24 Active Member

    Ken, are you providing Minix Forum feedback to FOTA, or are you suggesting I should do it with your help?
  8. Solorzano

    Solorzano Member

    To solve the issue, just Clear Cache and Data from the Minix System Update app. Go to Settings- Apps- then look for System Update app and clear cache and data. The Warning "System was damaged, wireless update is disabled" gets deleted. Now if you have root then go to the SuperSU app's settings and do a Full Unroot. Then run the update.
  9. elpopa

    elpopa New Member

    Hi, No chance to install latest update OTA - I get: Your system is damaged, wireless update is disabled!

    Device: Minix Neo X8-H Plus
    I have firmware KOT49H.20150925 rooted
    I want to update to KOT49H.20151231

    I tried
    1. Install update as usual (for the last successfull update I could run OTA update even if device rooted - Only thing happened was after the update the device was unrooted)
    2. Use Solorzano suggestions:
    Clear Cache of System Update app -> do full unroot -> try update -> no succes
    + I tried a multitude of combinations like
    clean cache for all aps -> clean system update cache separately again -> full unroot -> reboot -> clean system update cache separately again ->try update -> no succes
    or perform unroot by appling zip update in recovery -> clean cache -> try update -> no succes

    Alwayas the error as you may see attached "Your system is damaged, wireless update is disabled!"

    3. Finally I did Factory Defaults on my device and try the Update -> the same : Your system is damaged, wireless update is disabled!

    What is to be done?
    Thanks!
    Adrian

    Attached Files:

  10. Solorzano

    Solorzano Member

    I tried taking the 21mb zip to the recovery and installing there and I got an error saying "signature error". I read that installing Clockworkmod recovery disables signature checks and installs perfectly, but I don't know what is the right cwm recovery to flash.

    My method worked to cancel the error but I still want able to update via fota even after full I root etc. If you find something let me know. I don't want to flash manual firmware just for a few new updates.

    Sent from my LG-us990 using Tapatalk
    Last edited: Jan 10, 2016
  11. elpopa

    elpopa New Member

    Guess what :)

    As I have anyhow lost everything from my box, I did update via USB... and of course it worked

    In fact the reason I did the firmware update was "Youtube app updated" -> I thought is the youtube app for android TV where you may pair devices.. but it was not like this.

    Anyhow, I have the new firmware :)
    and of course I rooted again the device:cool:
  12. Wittty

    Wittty New Member

    I am posting this to hopefully help others that had a similar issue to me.
    I recently rooted and changed my build.prop file. After i did this I unrooted and everything was working smoothly for a few months.

    1 day i saw the new update and forgot about what i did earlier. tried to update and was getting the wireless update is disabled error. After much reading in the forums and everything i tried not working including updating latest firmware via USB. It didn't allow the update after many attempts. Finally in order to get it to install I put my old build.prop file back. Ran the USB update and all worked smoothly!

    My kodi settings and apps were also working as before.
  13. elpopa

    elpopa New Member

    You want to say that if You do update by usb you dont loose apps and configuration of device?
  14. Wittty

    Wittty New Member

  15. elpopa

    elpopa New Member

    This is really a great news, I didnt know. , so I dont care about ota anymore. Thanks
  16. Manuel Hoyos

    Manuel Hoyos New Member

    Hi.

    I have the same impact.

    Some time ago I set up the root user, but I've already removed and still produces the error when trying to update wirelessly. Yes I managed to upgrade my MINIX U1 (Android) from USB, but still above error still occurs.

    Any solution?

    Thank you
  17. Higgs

    Higgs Yellow Dude Super Moderator

    So do you have a U1 or X8-H Plus? This thread is for the X8-H Plus.
  18. Manuel Hoyos

    Manuel Hoyos New Member

    Ok. I look up in other thread.

    I'm sorry.
  19. Higgs

    Higgs Yellow Dude Super Moderator

    Please post your issue in the U1 thread. But some advice;
    • A factory reset will remove any root (plus any remnants left you attempted to remove root)
    • Flashing firmware using the usb burning tool will also solve this.
  20. lvr

    lvr New Member

    I discover this morning that my Minix is now banned from possible FOTA upgrades while I never rooted it (and don't say an app can root it without notification!).
    I consider this as totally unacceptable and unfair.
    Now only proposed solution is to reset to factory default and then reinstall everything configured since more then 1 year !
    Unbelievable, Unsupportable !
    Thanks to provide a real solution to cancel the mistake you did in implementing this stupid check in V7 or at minimum a patch to repair the device (not to say about the really absurd message : "your device is damaged" !).
    I am now a really angry customer which will tell about this unfair behavior over internet.