1. Welcome to the official forum for MINIX devices!

YouTube in 1080p?

Discussion in 'Firmware Wishlist' started by daWinni, Sep 18, 2014.

  1. daWinni

    daWinni New Member

    Since a few weeks Google's YouTube app should be able to stream videos in better quality (up to 1440p). Unfortunately I can't set those options on my X8-H in the latest YouTube app. I still get 720p as max resolution. Minix, could you please change this, so we get more than 720p in the YouTube app? Thanks
    max8xam, jk-nz and Yoramile1 like this.
  2. traxdata

    traxdata Retired Super Mod Moderator

    I think your stock x8-h will be 720. You tube should present the best possible stream for you.
  3. timboom009

    timboom009 Member

    Hi I have same problem my x8-h youtube not giving result more then 720p bull shit!
  4. traxdata

    traxdata Retired Super Mod Moderator

    But how can it play 1080 when firmware is 720?
  5. timboom009

    timboom009 Member

    X8-h doesn't have 1080p firmware?
  6. HardwareGuru

    HardwareGuru Developer Administrator

    X8 is 1080p firmware.
    Youtube probably decides on Device ID if you get 1080p or not..
    its not the device it is the app of youtube that gives you a sertan resolution.
  7. HardwareGuru

    HardwareGuru Developer Administrator

    Please keep your tone down.
    Stay respectfull to people on the forum, eventhough some might give a wrong awnser or an awnser you dont like.
  8. daWinni

    daWinni New Member

    One requirement for 1080p YouTube videos is Android version 4.4.2. But the X8 is already 4.4.2.
    So the next question is, what Device ID do we need to get 1080p? Might it be possible to hack the Device ID with a prop editor?
  9. HardwareGuru

    HardwareGuru Developer Administrator

    I dont know te details of the youtube at 1080p or if there are other requirements asside device id.. Probably a nexus 10 id will work.. Not sure though...
  10. timboom009

    timboom009 Member

    My apologies@HardwareGuru!
  11. traxdata

    traxdata Retired Super Mod Moderator

    Damn it, I thought it was 720. sorry guys
    HardwareGuru likes this.
  12. traxdata

    traxdata Retired Super Mod Moderator

    By the way, just changed my x8 to 1080 60hz. Bazzzzzing
    Higgs likes this.
  13. WeK05

    WeK05 Audio Visual Master Specialist

    I know that I can now get the 1080p option on my Nexus 7. I will spoof the device ID to Nexus 7 or 10 and see what happens. You will have to use a custom firmware from Finless Bob, device ID is hard coded on X8, simply changing build.prop will not help.

    Update:
    It doesn't look like it is the device ID. I spoofed it as Nexus 10 and Nexus 7. It was still limited to 720p in both the cases. I can now always get the 1080p option on supported videos on my real Nexus 7. YouTube is checking something else.
    Last edited: Sep 19, 2014
  14. daWinni

    daWinni New Member

    Might it be, that Google limits the resolution because of HDMI Out? Or because it cant't detect the screen or the screen size and therefore limits it to 720p?
  15. Gopichand Pai

    Gopichand Pai Member

    May be youtube is reading build.prop to see lcd density value? X8/X8-H doesn't consider lcd density value from build.prop, so youtube is streaming max at 720p?

    May be X7 owners can confirm if they are seeing 1080p on X7 kitkat firmware(if X7 reads lcd density from build.prop )?
  16. traxdata

    traxdata Retired Super Mod Moderator

  17. Gopichand Pai

    Gopichand Pai Member

    X8-H is on 4.4.2 so no need to change the release version
  18. traxdata

    traxdata Retired Super Mod Moderator

    Sounds like you tube are trying out . Try a different version in build.prop.
    Last edited: Sep 19, 2014
  19. WeK05

    WeK05 Audio Visual Master Specialist

    It is not the release version. I tried 4.4.4 (there is nothing above it). It may not be the lcd density, I tried 160 and 320 in command line. It still was limited to 720. It is something else.
  20. HardwareGuru

    HardwareGuru Developer Administrator

    In build prop try change test-keys to release-keys