1. Welcome to the official forum for MINIX devices!

Z64A (20150930) can't access Google Play store

Discussion in 'NEO Z64 Android OS' started by nvhg, Dec 24, 2017.

  1. nvhg

    nvhg New Member

    My Neo Z64A (20150930) can't access CH Play(v. 8.5.39) now? I removed update &back to default ver. 5.1.11. But some app. could't play on this? It has failed again after update new ver. of CH play & Google play service.
    samir_miro likes this.
  2. Rafael7up

    Rafael7up New Member

    Same problem here, just flashed my z64w into z64a and all google apps are stuck on loading, if I restore them to default, they start, but after a while they ask for google account authentication, but mine is already authenticated.... Can someone help?? please
    samir_miro likes this.
  3. K Abdou

    K Abdou New Member

    Mine is the Android version, last December, I made my first and only factory reset since I have it 2 years ago. since then, it won't accept any of my working Gmail accounts so I can login to the Store.. no Google applications works.
    I successfully flashed the original firmware from the forum and it was working for 10 minutes then it stopped again. No Google apps working.
    I tried to be aggressive and I downloaded the marshmallow on my Minix Z64 A, after little modifications it was working great but with little negative behavior, it freezes every now and then.
    Then, I went to CM 13, and again, freezing sometimes but all the applications was working so nice and clean.
    Finally, I went back to the original firmware and still the same problem,, NO Google store working properly or any other Google apps want to start. I tried different working Gmail accounts, even I made new account. Nothing want to work normal again.
    I like this device, and it was working perfectly for the last 2 years untill I decided to factory reset it.
    I'll appreciate any help bringing back my Minix to normal behavior. Thank you
    Last edited: Jan 9, 2018
    samir_miro likes this.
  4. samir_miro

    samir_miro New Member

    Same problem here no Google applications works.
  5. samir_miro

    samir_miro New Member

    Google Play store ask for google account authentication and no Google applications works.:cry::cry::cry::cry::cry::cry:
    Can someone help please
  6. samir_miro

    samir_miro New Member

    I thinking
    Its synchronized issue
    Google Play outage
  7. samir_miro

    samir_miro New Member

    there is no solution for minix neo z64
    this the answer form technical support


    Dear Samir,


    Apologies for the delay getting back to you.


    We find out this is a compatibility problem, and it is cannot be fixed except update the firmware.


    While the current situation is MINIX NEO Z64-A cannot be updated beyond its existing Android 4.4.4 KitKat OS firmware.


    We stopped manufacturing this model about 3 years ago, and are no longer providing firmware updates for this model.


    We’re unable to provide any fixes or patches for this model as the chipset manufacturer, Intel, is no longer providing support for Android OS on this CPU.


    So, the only solution we can offer is uninstalling updates of Google Play Service and Google Play Store.


    At the same time, disable the ‘Auto Update’.


    Apologies again for all the inconvenience.


    Best Regards,


    Martin Yuan
    K Abdou likes this.
  8. MINIX - Martin

    MINIX - Martin Moderator Moderator

    Uninstall the updates of all google's APPs, and disable auto-updating for the APPs.
    I tried, and it worked.
    samir_miro likes this.
  9. samir_miro

    samir_miro New Member

    Facebook and his Messenger and Google Chrome not work at all there is any way to make it work
    Last edited: Jan 16, 2018
  10. K Abdou

    K Abdou New Member

    Thanks Samir for the info.
    Now as an owner of the Z64 A ver. The only solution is to transfer it to windows ver. or try to install other OS.
    As I mentioned before, I'm very happy with the marshmallow on my device, but still looking for a solution to the stability issue. It keep freezing..
    I'll keep trying till I find a solution or some one from Minix can help us (even unofficially).
  11. samir_miro

    samir_miro New Member

    Windows is not solution it's a very slow and I have already pc I tried before windows 8.1 and Windows 10 it's a very slow and i returned back to Android also I tried remix OS and most of application not work capability issue and also I tried Android x68 marshmallow and it is freeze all the time and not compatible with most application and there is no power option and no resolution option and the remote control not work and the big problem with GPU not work correct I have some issue with video as YouTube and normal Media and kodi the video is not clear like when you install new windows without driver
  12. K Abdou

    K Abdou New Member

    You are absolutely right Samir.

    Thank you minix for the last 3 years and wish you the best.
  13. samir_miro

    samir_miro New Member

    K Abdou
    If you have any recommendation for any version of Android you can share it with me
    Thank you
  14. K Abdou

    K Abdou New Member

    I'll keep trying to make it work, if i reach something I'll post it here if the Administrator let me.
    I was trying to post something yesterday but it didn't allow me to post it, even i didn't say anything bad because really it was a good device for the last 3 years, but it's time to let it go. Nothing last for ever.
    It's not Minix falt, but they should do something to help the owners of this kind of device, that's it.
  15. samir_miro

    samir_miro New Member

    You are absolutely right we don't need software update we don't need marshmallow this is a software issue only we need small batch to fix it please minix try to fix it
  16. Nicolas31

    Nicolas31 New Member

    found out a solution. Go to apkmirror website and download a previous version of the play store. The 7.9.8 seems to be fine.
    I also use chrome version 61 and google play services 11.9.51 (070)
    Stop the auto update

    hope to help
  17. samir_miro

    samir_miro New Member

    I have Google play service 11.9.51 and I downloaded Chrome version 61 and it not works and I removed all updates from Google play store and it updated it self automatically how I stop auto update. Inside the app setting?
  18. Nicolas31

    Nicolas31 New Member

  19. Nicolas31

    Nicolas31 New Member

    you right play store keep auto update... chrome still works at least!
    samir_miro likes this.
  20. midnight

    midnight Moderator Moderator

    Auto" App" updating and " Google Play Store " auto updates are different. I believe if you want to stop the Play Store from updating to a newer version, I've read that you need Root Access . I've never tried it so I can't confirm this to be true !