1. MINIX team will be having Chinese Lunar New Year holidays from 23/01 to 05/02, replies will be limited during this period, please kindly note.

FAQ Z83-4 black screen [virtual extended display]

Discussion in 'Z83-4 Guides & FAQs' started by amitosh10, Nov 13, 2016.

  1. amitosh10

    amitosh10 New Member

    hi ,
    I gust got my new minix z83-4 and when I try to turn it on from sleep mode after a couple of hours of not using it. I get a black screen.
    The only thing that help is to unplug the power and plug it back
    Is there any solution?

    Solution provided by Intel:
    1.) Download the attached .zip file
    2.) Extract it to Desktop
    3.) Right click on the .bat file to Run as administrator (JUST NEED TO DO THIS ONCE)
    4.) Reboot the machine
    5.) No more annoying virtual display issue

    Attached Files:

    Last edited by a moderator: Nov 17, 2016
  2. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1.) Update the graphics driver inside Windows to the latest first:
    https://downloadcenter.intel.com/do...dows-10-8-1-for-Intel-Compute-Stick-STK1A32SC

    2.) "The only thing that help is to unplug the power and plug it back"
    --->Don't do that again, it could damage your Windows system<---

    3.) You may try unplug and plugging HDMI instead, but not the power.

    4.) Please make sure you disable fast startup if you unplug the power from time to time:
    http://www.minixforum.com/threads/disabling-fast-startup-in-windows-10.14034/

    5.) Did you unplug the HDMI cable from the unit before or during sleep, and plug it back before waking the system up?
  3. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

  4. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    @amitosh10 , and do you see a mouse cursor on the black screen?
  5. amitosh10

    amitosh10 New Member

    Hi ,
    Thanks for your answers.
    At the beginning I didn't see the mouse but after a minute the mouse cursor showd on the black screen
  6. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    OK, then I'm 100% sure that you're experiencing the Intel driver bug of a non-exist virtual display being created.

    It happens when HDMI is unplugged/altered during sleep.
    the incorrect virtual display will remain until you unplug the HDMI and plug it back again.

    It's a known Intel graphics driver bug.
    We have no solutions but to patiently wait for their driver update.
    It is affecting other CPU platforms as well, regardless of brands.

    This "Generic Non-PnP Monitor" device shouldn't exist, when it does, you see the problem:
    nonpnp.jpg

    Primary display being shifted to this virtual display, causing the problem you are mentioning:
    virtual.jpg
    amitosh10 and Villa like this.
  7. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Unplug HDMI and plug it back, "Generic Non-PnP Monitor" / virtual display disappeared,
    image back to normal again:
    novirtual.jpg
  8. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If you have no password, you could still hit "Enter" to go into the system.

    Then you may change the wrong extended desktop mode to clone displays mode -> Digital Television + Virtual Display.

    This would temporarily fixed the issue until Intel release the new driver with a fix about this virtual display issue, it shouldn't exist.
  9. ilGimmy

    ilGimmy Member

  10. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    In this case, it's the driver's job.
    Intel is looking into this.
    That virtual display should never be created, and even if created, it shouldn't take over the display output priority.
    ilGimmy likes this.
  11. amitosh10

    amitosh10 New Member

    Ok so I wait until intel will fix the bug.
    At the meantime it is ok to keep the minix on all the time ?
  12. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    The problem doesn't happen if you don't disconnect the HDMI from the unit during sleep.
    It's either Intel driver or Windows update to fix this problem, as we copied the same issue on other platforms as well,
    including Celeron and Pentium.

    I asked a question above:
    5.) Did you unplug the HDMI cable from the unit before or during sleep, and plug it back before waking the system up?
  13. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    If you have no password, you could still hit "Enter" to go into the system.

    Then you may change the wrong extended desktop mode to clone displays mode -> Digital Television + Virtual Display.

    This would temporarily fixed the issue until Intel release the new driver with a fix about this virtual display issue, it shouldn't exist.
  14. amitosh10

    amitosh10 New Member

    The hdmi cable is always plugged to the minix
  15. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    To what device? TV? Monitor? Brand and make?
    Please provide as much info as you can,
    we can pass these info to Intel.

    Thanks.
  16. marc keller

    marc keller New Member

    I have exactly the same problem, and I never disconnect the HDMI from the unit during sleep or when the device is shut down. Every day when pushing the power button for the first time, I only get a black screen with the mouse on it. I have to unplug the power cord for a second and then restart the device. If I shut down windows and immediately restart the device, there are no problems. Only having problems when starting the device the first time the next day...

    Edit: I checked, I don´t have the problem with the "Generic Non-PnP Monitor". I deactivated "fast startup", and changed the "when I press the power button" settings from "sleep" to "shut down", no issues today when turning on the device in the morning. Hope this solved the problem...
    Last edited: Nov 16, 2016
    amitosh10 likes this.
  17. amitosh10

    amitosh10 New Member

    The minix is concocted to a hisense tv
  18. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    Intel will provide us a registry patch to fix this problem.

    -> Disabling the virtual display feature in the registry.

    They want to keep this function for industrial customers for remote access without a physical screen.
  19. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    You can't see the "Generic Non-PnP Monitor" anymore when you recovered from the issue.
    It requires a special method to see it:
    When you see the black screen -> hit Enter to go into system (when there is no password) -> change the display output mode to Clone Displays -> Now you can access the device manager page -> You can see 2 monitor devices.

    Next time if you see this problem (only when you're waking up the device from sleep mode), don't disconnect the power, try unplugging the HDMI cable and plug it back, see if you get the proper display back, this could prove the theory.
  20. MINIX - Ken

    MINIX - Ken MINIX Team Member Administrator

    1.) Download the attached .zip file
    2.) Extract it to Desktop
    3.) Right click on the .bat file to Run as administrator (JUST DO THIS ONCE)
    4.) Reboot the machine
    5.) No more annoying virtual display issue

    Attached Files:

    MAS1 likes this.