1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

FAQ Z83-4 black screen [virtual extended display]

Discussion in 'NEO Z83-4 Guides & FAQs' started by amitosh10, Nov 13, 2016.

  1. Villa

    Villa Administrator Administrator

    Yes, you have v1.50
     
  2. klapa

    klapa Member

    Yea - I've been through the BIOS thread here.

    I probably should update to V 1.66 (the latest) but worry in case I want to go back to 1.50 that it is not available. I will address these issues in the BIOS thread.
     
  3. Chip Louie

    Chip Louie New Member

    So has anybody here found a solution to the black screen? I had to disconnect the battery to get mine to boot up again. Even though I have all power saving and sleep and hibernate turned off it still seems to go to sleep and never wake up. The only way to get it to boot back up is pull the battery and then it acks fine. So I have just left the battery disconnected and it is working perfectly, it seems to not go to sleep or hibernate and the video stays active. If the battery is left off and the power cord is removed and left out overnight it comes back up and still seems to know the date and time. How can that be?

    BTW, this has been updated to FW1.66 and has the blackout patch done and the latest video drivers.

    Chip
     
  4. klapa

    klapa Member

    Hi,

    I had this problem when I first got my machine but solved the problem just by going through the FAQ (this thread) and following the instructions.

    I have BIOS 1.5 and Win 10 anniversary update version. I have the Minix HDMI output going to home theater HDMI input and home theater output to monitor. I would get the black screen problem when either monitor or home theater would go into "sleep" mode and power down. I would have the Minix LED GREEN in that mode, not BLUE as it normally is. I could recover from that mode by using the power button to reboot.

    I did not remove options for sleep - I only followed the instructions to update the driver THEN run the powershell script (Run As Administrator) to remove the virtual monitor entry in device manager. I use the Intel driver manager to update the driver and while they listed TWO driver packages i installed the one they recommended (no HD in package name).

    When I say the problem is fixed what I mean is when everything goes to sleep and I restore home theater and monitor to on I just need to "wake up" the Minix with keyboard. It does take maybe up to 15 seconds to wake up and many times I will need to hit a key (ENTER key) more than once. It will not wake up with only mouse - I MUST hit a key - I use the enter key.

    I never see a GREEN LED except very briefly when first powering up the unit.

    Hope this helps.
     
  5. SOFISTISOFTWARE

    SOFISTISOFTWARE New Member

    Hi,

    my system with two monitors: the first one in hdmi port and the second one in DP port, when windows goes in power save I can't reactivate the syste, I must disconnect and connect again one of the two monitor plug, or hdmi either DP and it works again, I've for work purpose two monitors connect in clone mode, the system has last bios 1.66 and lates HD graphic driver of Intel, virtual screen doesn't help, if I try to switch only one monitor or via software HD control panel either disconnect one of two monitor the system works perfect, I can resume the system after the power saving feature is activated, anybody know the solution ??

    Thanks in advance
     
  6. Paulo_Boo

    Paulo_Boo New Member

    Hi!

    I had used the script on the first post and it solved the black screen problem on my system, all was fine and nice. So, recently I have updated my system to the latest Windows 10 version following the steps described in this thread: http://www.minixforum.com/threads/it-is-possible-to-install-windows-creator-update.16565/. After the updated the black screen issue returned. I ran the procedure once again with no results, then I ran it one more time with still no fix. Does anyone had the same problem? Are there any fixes for this?
     
  7. SOFISTISOFTWARE

    SOFISTISOFTWARE New Member

    Hi,

    I finally solved the problem;

    You need to set in windows the functionality of the power button of Z-83 to power off, if you set it to suspende mode you'll get the infamous issue, try and give me a feedback
     
  8. Paulo_Boo

    Paulo_Boo New Member

    SOFISTIS,

    I updated the video driver (using Intel Update Tool) and set the power button configuration as you said and things seems to get back as they were previously.

    Thanks for you tip!