1. Welcome to the official forum for MINIX devices!
    Dismiss Notice

Z83-4 Windows 10 drivers

Discussion in 'NEO Z83-4 Guides & FAQs' started by 759M, Oct 11, 2016.

  1. FGendron

    FGendron New Member

    Hi!
    Also having problems with audio jack output (scratchy sound before the actual sound). I see v10.0.14393.0 in device manager for Speakers (Intel SST Audio Device (WDMI))
    Any idea?
    Fran├žois
     
  2. dogpee

    dogpee New Member

    Hi. I tried to install Ubuntu on my Z83-4 and when I found that the sound and wireless didn't work, I went back to Windows 10 but I ended up messing up the partitions by mistake and lost the ability to boot back into windows 10... i purchased a new copy of windows 10... but when I installed it, there is no option for wireless connection, it keeps looking for a wired network connection. I tried to install the drivers in this package but it just returned a message that my drivers were already the latest version. It still doesn't work. What am I doing wrong?
     
    Last edited: Feb 15, 2017
  3. Villa

    Villa Administrator Administrator

    Why did you purchase a new copy of Windows 10?
    It can be downloaded here....
    https://www.microsoft.com/en-us/software-download/windows10ISO
    The Windows license key is stored in the UEFI BIOS.
     
  4. dogpee

    dogpee New Member

    i did not know that.
     
  5. TMAC897

    TMAC897 New Member

    HI,
    Having Issues installing Drivers
     
  6. Zenji9

    Zenji9 New Member

  7. Jim Petersen

    Jim Petersen New Member

    I am in need of advice. I was having difficulties with the Z83-4 upgrade to Win 10 ver 1703 so I did a fresh install of Win 10 ver 1703. But now the WiFi and other assorted peripherals are not working. How do I go about installing the proper drivers to the system for proper operation?
     
  8. Silverwolf0

    Silverwolf0 New Member

    Hi I did the same thing although it was because the partition resize failed when I tried to update to creators. Had to fresh install everything.

    Download and extract the .rar driver package from the first page that ken linked. Go to your device manager (or type it in the search box). Under the "other" tree there will be a whole bunch of unknown devices. Right click one and click update driver. Choose to manually update driver. Point the file location to be the driver folder you just extracted. Make sure subfolders is checked. Then click next and it will find and install the driver for that device. Do the same for every other unknown or other device in the list. You can also try looking through the rest of device manager and updating anything that is labeled generic or is having issues as they may be using generic windows drivers. You can use the search online option when updating drivers instead of the manual update if the driver package doesn't have what you want.

    Also, for future headache avoidance, once you have the drivers all figured out and installed, go type in "recovery" in thte search box and click create recovery drive. Plug in a thumb drive you don't need and it will backup windows along with the associated drivers you just installed so you won't have to go through it all again next time.
     
    Villa likes this.
  9. Jim Petersen

    Jim Petersen New Member

    Hello Silverwolf10,

    Thanks for your follow up on this question. I appreciate your help. Your recovery suggestion is one that I intend to use as well.

    Cheers,
    Jim
     
  10. Silverwolf0

    Silverwolf0 New Member

    np. Also if you are having graphics driver issues here's my other post. http://www.minixforum.com/threads/cannot-update-display-adapter.17106/

    This little box has gotten way more complicated than it should be. I was led to believe the support from minix would be ample judging by reviews but I do not call downloading drivers that have no setup executables from a forum post or relying on user generated and risky guides to resizing partitions (pinned to the top no less) in order to update windows properly as passable support. Most every other computer I've owned had a driver page right on the product page on the company's website, including recovery images. Also would like to thank Intel for not properly giving microsoft the cherry trail drivers to use in their latest windows 10 installation files.
     
    JonB likes this.
  11. LocalMagic

    LocalMagic New Member

  12. LocalMagic

    LocalMagic New Member

    For what it's worth, I circumvented my issue by updating the drivers from an image (DriveSnapshot) of the original install - Device Manage found the drivers by rummaging through the Windows folder, I suspect. I then added the '4345r6nvram.txt' file, and the Broadcom driver is also happy. Hope this helps a fellow traveler...
     
  13. Pristik

    Pristik New Member

  14. MINIX - Ken

    MINIX - Ken Former MINIX Team Member Administrator

  15. dbenyakar

    dbenyakar New Member

    Hi
    For a clean Windows 10 installation via USB drive I get three options to choose from, Windows 10, Windows 10 Home (single language), and Windows 10 (N version).
    Which Windows edition do I choose?
     
  16. Villa

    Villa Administrator Administrator

  17. kirshenz

    kirshenz New Member

    Hi Ken,
    I don't know if this is related. I went from a 40'' TV to LG 55'' and the display looks very laggy. I can see videos very well but YouTube for instance and even the mouse movement looks like my Minix is 40 years old.
    Could you think of any reason why?
    I've update the Intel Graphics driver through Windows Device Manager and got only version 20.19.15.4549 from Nov 2016. The version from your link is valid for the Minix? can it make a difference?
    Thanks a lot.
     
  18. Arnulfo

    Arnulfo New Member

    Hi,
    So I haven't had a Windows machine since XP and got the Minix Z83-4 for my kids to use for school and online games. It worked great until a few months ago when the wifi disappeared. We only had it for a couple months, but I'm guessing some update did it. Haven't really used it since, but my kids are really needing access now, and I can't keep sharing my work laptop with them.

    I downloaded the drivers on page 1, placed the '4345r6nvram.txt' file in the drivers folder and followed Silverwolf0's instructions, but no luck. It just says the driver cannot be found for both automatic and browse my computer options. To be honest, I've only spent an hour trying to correct this, mostly reading this forum and writing this post. Call me lazy but I don't want to spend any more time to research this. I don't have the time like I use to, so I'm hoping someone can share clear instructions for a novice on how to correct this. If not, that's cool. Tis' the season for cheap buys, so I may end up just buying something else.

    Thanks!
     

    Attached Files:

  19. JaMo

    JaMo New Member

    Hi Ken...

    I have a Minix NEO Z83-4 running Win 10.

    Recently I tried to update to the Fall Creators. I couldn't do it the normal Win Update way, because of 0xc1900200, partition size and other problems! So I did a Clean Installation. After zillions of issues (I am not tech savvy) I finally got it running with Win 10 version 1709 (16299.192)... but now I have no sound coming through the TV HDMI connection when watching a YouToube video, which I obviously had with the previous Win 10 version. (when connecting to the TV HDMI with an other PC the sound from YouTube is ok)

    When clicking on the Audio Icon, it says : "no audio output device is installed". It says the same thing in the Control Panel under Sound.

    I read from this thread and others on this forum that it may be an audio driver problem.

    With Device Manager I cannot see an Audio Device in the Devices List. So I guess that it is one of the generic or unknown devices in the list.

    I downloaded Ken's file http://www.minixforum.com/downloads/download.php?file=Z83-4_device_drivers_Win10_64bit.rar and extracted files with WinRAR x64 5.50 (demo version) in a folder ... than manually tried with Device Manager to update every generic/unknown devices from that folder... with no success as there is still no audio.

    Note : before trying with DM to update the drivers, was there another step needed beside extracting Ken's .rar file with WinRAR ?

    Need help...
     
  20. JaMo

    JaMo New Member

    UPDATE: I found that a second Generic Device without a driver had to be installed as I did for the Realtek 12S Audio Codec .... this time it installed the Realtek Audio Device in addition to its Codec ... that fixed the problem as I now have sound through the HDMI connection !!